Problem z uzyskaniem dzwięku z HDMI manjaro monitor HP ZR2440w (Soundbar HP NQ576AA) i Nieodblokowana Baza Kluczy konta Chromium

Witam mam problem z uzyskaniem dzwięku z HDMI w systemie Manjaro Cinnamon monitor nie jest widoczny w wyjściach dzwięku sprawdzałem też na komputerze pod windowsem i tam wszystko działa dzwięk jest normalnie przekazywany

Zainstaluj sobie pavucontrol i tam sprawdź. Sprawdź dokładnie, czy domyślna karta dźwiękowa jest ustawiona dobrze. Jeżeli masz dedykowaną kartę graficzną GPU, może ona też służyć za wyjście dźwięku.
Jak nie pomoże to dołączę Ci skrypt, który wygeneruje logi na podstawie których postaram się pomóc.

1lajk

mam własnie pavucontrol tyle że niby mam wyłączone wyjscie dzwięku HDMI a jak próbuję to włączyć to i tak po restarcie się ustawia na wyłączone

Zrzut%20ekranu%20z%202020-02-21%2016-02-48 Zrzut%20ekranu%20z%202020-02-21%2016-13-14

Sprzęt
Karta Asus GTX 650

popatrz sobie na suwaki w alsamixer, może tam jest coś nie teges

jak odłączę zewnętrzną kartę dzwiękową na PCI to wtedy dzwięk zaczyna działać normalnie jak wymusić by dzwięk był odtwarzany przez HDMI ?
dodam że w sterowaniu dzwiękiem gdy odłączę zewnętrzną kartę dzwiękową
dzwięk HDMI się pojawia

#1 wyjęta karta CMI8738

#2 wpięta karta CMI8738

W profilu wyjsciowym gdy wpięta jest ta karta nie pojawia sie HDMI

A dlaczego masz w “Urządzenia wyjściowe” ustawione na “Wyjście analogowe” ?

Musi być ustawione na HDMI (a więc cyfrowe). Dopiero potem ustawiasz profil w “Konfiguracja” na odpowiednie wyjście HDMI.

Wygeneruj mi log tym skryptem:
audiolog.zip (688 bajtów)
Rozpakuj, dodaj prawa do uruchomienia ( chmod +x audiolog.sh ), i uruchom ( ./audiolog.sh )
Zawartość pliku z logiem (audio.log) z katalogu domowego wklej na pastebin.com

to nie ta karta a jak to zaznacze to mam tylko wyjscie cyfrowe stereo IEC958 i nic więcej myslę że w urządzeniach powinno być widoczne wyjscie hdmi z nvidi czy coś takiego a tego tutaj niema

oto log o który prosiłeś
https://pastebin.com/4rjiVHRD

znalazłem rozwiązanie gdy dodam ten wpis
set-card-profile 0 output:hdmi-stereo-extra1 do /etc/pulse/default.pa
wpis%20w%20default%20pa

i tu ustawię CMI 8738 na wyłączone

wtedy dzwięk działa

a tutaj w zarządzaniu dzwiękiem to wygląda tak gdy była włączona karta CMI 8738 nie dało się ustawić dzwięku po HDMI jak widać żadna CMI nie jest zaznaczona i dzwięk działa


a dlaczego się HDA Nvidia nie pojawia w urządzeniach wyjsciowych nie mam pojęcia

Wiem mniej więcej w czym jest problem. Po prostu kartę PCI zewnętrzną jak jest podłączona to ustawia jako kartę domyślną główną dla serwera dźwięku PulseAudio, przez, co wyjścia HDMI z karty grafiki są niedostępne, ale widoczne.
Trzeba wymusić kolejność kart dla podsystemu dźwięku, która jest nadrzędna lub wyłączyć sterownik dla tej podłączonej na PCI, ale wtedy z niej nie skorzystasz.

Pokaż jeszcze jak możesz wynik tych dwóch poleceń:
pactl list short sources
pactl list short sinks

(i jeżeli możesz to po odłączeniu karty PCI dźwiękowej też pokaż wynik tych poleceń)
Ustawi się, co domyślne i powinno być ok. (chyba :P)


od siebie dodam że wyniki tych poleceń są zgodne z tym co ustawiłem wcześniej przeczytaj mój post wyżej zaraz odepnę kartę ale podejżewam że wynik będzie taki sam lub podobny bo wymusza to set-card-profile 0 output:hdmi-stereo-extra1 w default.pa

wynik po wyjęciu karty CMI8738
wynik2

szkoda że nie da się tego ustawić tak jak na innym systemie poprostu biorę wybieram wyjscie z którego chcę puszczać dzwięk i tyle a tu muszę się przeklikiwać przez ustawienia w pavucontrol wyłączać urządzenia i do tego jeszcze wymuszać w default.pa aby było ustawione/widoczne to źródło dzwięku które chcę ale mniejsza z tym może kiedyś to poprawią a mi to aż tak nie przeszkadza bo i tak głównie będzie używany soundbar z hdmi

może kiedyś znajdzie się lepsze rozwiązanie dzięki za pomoc

Spoko, generalnie jest to do rozwiązania.
Wszystko zależy od konfiguracji. Jak masz więcej niż jedną kartę dźwiękową to bywa problem z enumeracją. Sama Nvidia to przyznaje w swojej dokumentacji.
https://download.nvidia.com/XFree86/gpu-hdmi-audio-document/

Ja np. przy Nvidii GTX 980 i audio na płycie głównej normalnie było widoczne do wyboru i wszystko ok. Więc dużo też zależy od połączenia, co z czym.

Możesz zawsze zamiast fizycznie wyciągać kartę PCI to wywal sterownik:
modprobe -r -f snd_cmipci (wcześniej pulseaudio trzeba zatrzymać)
I dźwięk powinien powrócić bez wyciągania karty. Jakiś konflikt chyba jest i PulseAudio świruje.

dzwięk własnie przy tym ustawieniu jak wyżej w moim poście działa bez wyciągania karty i niezależnie czy mam wsadzoną CMI8738 czy Creative SoundBlaster SB0100 tak czy siak muszę wyłączyć w pavucontrol kartę na pci bo inaczej nie działa dzwięk HDMI

powiedz mi jeszcze jeśli wiesz jak wyłączyć te każdorazowe pytanie o hasło w chromium chodzi o nieodblokowaną bazę kluczy konta wkurza mnie to wpisywanie hasła za każdym razem

Dzieje się tak, bo Chromowate korzystają ze systemowego subsystemu na klucze, w przeciwieństwie do np. Firefox, gdzie używa szyfrowanych baz SQL do przechowywania poświadczeń.
Jedyny sposób to ustawienie pustego hasła dla pęku kluczy “Login”
Znajdź w systemie apkę “Hasła i klucze” znajdź pozycję “Login” zwykle pierwsza opcja z ikoną katalogu. Prawym p. myszy kliknij, potem “Zmień hasło”, podaj stare, przy zapytaniu o nowe nic nie wpisuj i tylko potwierdź.
Od tej pory nie powinno pytać.

W KDE można to zrobić w nieco bardziej cywilizowany sposób w Access Control, ale to QT :wink:

ostatecznie pomogły te komendy
sudo mv /usr/bin/gnome-keyring-daemon /usr/bin/gnome-keyring-daemon-old
sudo killall gnome-keyring-daemon

A co do firefoxa to z niego nie korzystam na manjaro z powodu stutteringu/rwania obrazu z którym nie mogę sobie poradzić opcja force-full-composition-pipeline działa częściowo płynność jest większa ale rwanie pozostaje próbowałem w about:config włączyć layers.acceleration.force-enabled ale to powoduje że okno przeglądarki świruje i jest przeźroczyste

znalazłem lepsze rozwiązanie które nie powoduje przedstawionego wyżej problemu i rozwiązuje problem rwania stron w about:config trzeba przestawić gfx.xrender.enabled na true

Mi “force-full-composition-pipeline” zaznaczone z poziomu panelu Nvidii rozwiązuje problem w 100% przy GTX 980, wcześniej używałem “tripple buffering” kosztem oczywiście wydajności.

Przy aktualizacji będzie Ci sypać błędami i w logach systemowych też. Weź z autostartu go po prostu usuń.
Nie wiem, jak jest w Manjaro, ale w Arch Linux jak go nie dodasz to nie startuje.
Można też wywalić najlepiej:
pacman -R gnome-keyring
Jeżeli sprawia ten problem tylko Chrome to możesz dodać mu parametr: ```
`-password-store=basic’

ok wyłączyłem go z autostartu jak będzie sypał błędami to najwyzej zainstaluje to spowrotem własnie ten problem był tylko na chrome ale skoro ff działa to chromium już mi raczej potrzebne nie będzie :smiley:

Ja mam na odwrót, pod Gentoo działa od strzała, pod Windows ni hu hu.