Problem z WebServ'em

Mam problem z WebServ’em.

Gdy go uruchamiam, pokazuje się, że Apache jest nie tak. Lecz wszystko jest dobrze skonfigurowane.

O co chodzi?

Z góry dzięki.

http://www.hotfix.pl/articles.php?article_id=71

Wiem, jak zainstalować WebServ’a, czytałem inny, lepszy opis.

Nie mam Skype’a.

Restartowałeś kompa? Nie miałeś wcześniej innego serwera?

Nie restartowałem kompa, mam cały czas zainstalowany Alacer 2.0, lecz przy instalacji i próbie użyciu WebServ’a Alacer był wyłączony i zamknięty.

A ma to jakiś wpływ?

jeżeli program słucha na :80 to ma

start -> uruchom -> cmd

netstat -abnp tcp

i sprawdź czy coś nasłuchuje na :80

Czy ten Alacer i brak restartu przeszkodził?

Boże, zrestartuj kompa to się dowiesz

Zrobię tak.

Tylko czy mam jeszcze odinstalować Alacer’a?

możesz sprawdzić w uruchom -> msconfig czy nie ma tam czegoś od niego.

Nie, nie ma nic od Alacera.

pytałem, czy coś nasłuchuje na :80, nie odpowiedziałeś…

Odpowiedziałem, ale widocznie ktoś usunął posta… pokazije się odpowiedź, że nie mam do tego uprawnień. Ale Alacer też był na 80 nastawiony, i działał…

Dodano po chwili:

W WebServ’ie zmieniałem też porty, nie działało, więc to chyba nie ich wina.

zajrzyj do logów apacha (powinny być gdzieś w katalogu instalacyjnym webserva) i znajdź opis błędu

C:\Program Files\WebServ\apache2\logs\errors.txt lub error.txt

PUSTY! !!

Lecz wyskakuje takie coś (podczas startu serwera)

Cannot creatr file: C:\Program Files\WebServ\apache2\bin\showerror.bat

Dodane 08.01.2009 (Cz) 13:52

Już naprawiłem, wystarczyło zmienić nr portu na 84.

Lecz mam nowy problem:

nie uruchamia mi się MySQL: pokazuje się:

WEBSERV MONITOR - KONSOLA INFORMACYJNA

Podczas uruchamiania MySQL napotkano nastepujacy blad:

========================================================

============================

Pomoc techniczna:

http://forum.webserv.pl

==============================

Aby kontynuować, naciśnij dowolny klawisz..._

To pewnie od tego poprzedniego serwera, miałem podobnie. Usuń go, wyczyść rejestr i sprawdź w mscnfig czy nie ma czegoś od mysql.

Poprzednio miałem Krasnala (który nie działał, więc usunąłem program I PLIKI! !!

Czyścić rejestr? A to nie uszkodzi komputera?

to narzędzie jest bardzo bezpieczne :wink:

:arrow: http://www.ccleaner.com/