Problem z zamontowaniem partycji w Ubuntu 8.10


(Rykendo) #1

Witam!

Dziś postanowiłem wrócić do linuxa. Zainstalowałem sobie Ubuntu 8.10, a w raz znim pojawiły się pierwsze problemy. Mianowicie, nie mogę zamontować żadnej partycji windowsowej w ntfs. W komuterze zaś widać wszystkie. Próbując uruchomić jedną z nich. Widze taki komunikat:

Poradzcie. :? Mam 2 dyski obecnie zamontowane w komputerze. Wpisując w terminalu "fdisk -l" pojawia mi się:

I nie wiem jak otworzyć spis partycji z danego dysku. rykendo


(bachus) #2

Daj proszę wynik komend:

sudo fdisk -l

ls -al /media/

cat /etc/fstab

(Rykendo) #3

Wynik dla sudo fdisk -l

Disk /dev/sda: 320.0 GB, 320072933376 bytes

255 heads, 63 sectors/track, 38913 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0x0003ee67


   Device Boot Start End Blocks Id System

/dev/sda1 * 1 10199 81923436 7 HPFS/NTFS

/dev/sda2 10200 30596 163838902+ 7 HPFS/NTFS

/dev/sda3 30597 34420 30716280 7 HPFS/NTFS

/dev/sda4 34421 38913 36090022+ 7 HPFS/NTFS


Disk /dev/sdb: 80.0 GB, 80026361856 bytes

255 heads, 63 sectors/track, 9729 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0x5fb27919


   Device Boot Start End Blocks Id System

/dev/sdb2 1 9729 78148161 f W95 Ext'd (LBA)

/dev/sdb5 3825 8708 39230698+ 7 HPFS/NTFS

/dev/sdb6 1 1275 10241343 83 Linux

/dev/sdb7 8709 8839 1052226 82 Linux swap / Solaris

/dev/sdb8 8840 9729 7148893+ 83 Linux

/dev/sdb9 1276 3824 20474811 7 HPFS/NTFS


Partition table entries are not in disk order

ls -al /media

razem 36

drwxr-xr-x 9 root root 4096 2009-02-05 17:54 .

drwxr-xr-x 20 root root 4096 2009-02-05 15:25 ..

lrwxrwxrwx 1 root root 6 2009-02-05 15:11 cdrom -> cdrom0

drwxr-xr-x 2 root root 4096 2009-02-05 15:11 cdrom0

drwxr-xr-x 2 root root 4096 2009-02-05 16:52 disk

drwxr--r-- 2 root root 4096 2009-02-05 15:35 Kopia zapasowa

drwxr--r-- 2 root root 4096 2009-02-05 15:35 Rozrywka

drwxr--r-- 2 root root 4096 2009-02-05 15:35 Ważne

drwxr--r-- 2 root root 4096 2009-02-05 15:35 Windows 7

drwxr--r-- 2 root root 4096 2009-02-05 15:35 Windows XP

i cat /etc/fstab

# /etc/fstab: static file system information.

#

# -- This file has been automaticly generated by ntfs-config -- 

#

# 


proc /proc proc defaults 0 0

# Entry for /dev/sdb6 :

UUID=d348bd62-7789-4804-ae7e-371b311a1b73 / ext3 relatime,errors=remount-ro 0 1

# Entry for /dev/sdb8 :

UUID=195facc2-7810-4128-ab45-71816be49014 /home ext3 relatime 0 2

# Entry for /dev/sdb7 :

UUID=842c75ae-081e-4bab-8710-e093019ae688 none swap sw 0 0

/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

/dev/sdb5 /media/Kopia\040zapasowa ntfs-3g defaults,locale=pl_PL.UTF-8 0 0

/dev/sda4 /media/Ważne ntfs-3g defaults,locale=pl_PL.UTF-8 0 0

/dev/sda3 /media/Windows\0407 ntfs-3g defaults,locale=pl_PL.UTF-8 0 0

/dev/sda2 /media/Rozrywka ntfs-3g defaults,locale=pl_PL.UTF-8 0 0

/dev/sda1 /media/Windows\040XP ntfs-3g defaults,locale=pl_PL.UTF-8 0 0

(bachus) #4

Hmmm, wygląda to całkiem składnie... Spróbuj jeszcze:

sudo mount -a

Jak nie chce działać, to dla którejś partycji przykładowej spróbuj dopisać auto, czyli np.:

/dev/sda2 /media/Rozrywka ntfs-3g defaults,locale=pl_PL.UTF-8,auto 0 0

/dev/sda1 /media/Windows\040XP ntfs-3g defaults,locale=pl_PL.UTF-8,auto 0 0

Po restarcie sprawdź, czy działa, potem znowu: sudo mount -a


(Rykendo) #5

Wynik dla sudo mount -a

$LogFile indicates unclean shutdown (0, 0)

Failed to mount '/dev/sdb5': Operation not supported

Mount is denied because NTFS is marked to be in use. Choose one action:


Choice 1: If you have Windows then disconnect the external devices by

          clicking on the 'Safely Remove Hardware' icon in the Windows

          taskbar then shutdown Windows cleanly.


Choice 2: If you don't have Windows then you can use the 'force' option for

          your own responsibility. For example type on the command line:


            mount -t ntfs-3g /dev/sdb5 /media/Kopia zapasowa -o force


    Or add the option to the relevant row in the /etc/fstab file:


            /dev/sdb5 /media/Kopia zapasowa ntfs-3g force 0 0

$LogFile indicates unclean shutdown (0, 0)

Failed to mount '/dev/sda4': Operation not supported

Mount is denied because NTFS is marked to be in use. Choose one action:


Choice 1: If you have Windows then disconnect the external devices by

          clicking on the 'Safely Remove Hardware' icon in the Windows

          taskbar then shutdown Windows cleanly.


Choice 2: If you don't have Windows then you can use the 'force' option for

          your own responsibility. For example type on the command line:


            mount -t ntfs-3g /dev/sda4 /media/Ważne -o force


    Or add the option to the relevant row in the /etc/fstab file:


            /dev/sda4 /media/Ważne ntfs-3g force 0 0

$LogFile indicates unclean shutdown (0, 0)

Failed to mount '/dev/sda3': Operation not supported

Mount is denied because NTFS is marked to be in use. Choose one action:


Choice 1: If you have Windows then disconnect the external devices by

          clicking on the 'Safely Remove Hardware' icon in the Windows

          taskbar then shutdown Windows cleanly.


Choice 2: If you don't have Windows then you can use the 'force' option for

          your own responsibility. For example type on the command line:


            mount -t ntfs-3g /dev/sda3 /media/Windows 7 -o force


    Or add the option to the relevant row in the /etc/fstab file:


            /dev/sda3 /media/Windows 7 ntfs-3g force 0 0

$LogFile indicates unclean shutdown (0, 0)

Failed to mount '/dev/sda2': Operation not supported

Mount is denied because NTFS is marked to be in use. Choose one action:


Choice 1: If you have Windows then disconnect the external devices by

          clicking on the 'Safely Remove Hardware' icon in the Windows

          taskbar then shutdown Windows cleanly.


Choice 2: If you don't have Windows then you can use the 'force' option for

          your own responsibility. For example type on the command line:


            mount -t ntfs-3g /dev/sda2 /media/Rozrywka -o force


    Or add the option to the relevant row in the /etc/fstab file:


            /dev/sda2 /media/Rozrywka ntfs-3g force 0 0

$LogFile indicates unclean shutdown (0, 0)

Failed to mount '/dev/sda1': Operation not supported

Mount is denied because NTFS is marked to be in use. Choose one action:


Choice 1: If you have Windows then disconnect the external devices by

          clicking on the 'Safely Remove Hardware' icon in the Windows

          taskbar then shutdown Windows cleanly.


Choice 2: If you don't have Windows then you can use the 'force' option for

          your own responsibility. For example type on the command line:


            mount -t ntfs-3g /dev/sda1 /media/Windows XP -o force


    Or add the option to the relevant row in the /etc/fstab file:


            /dev/sda1 /media/Windows XP ntfs-3g force 0 0

Partycje nadal nie działają. :frowning: Wklepałem do terminala to co podałeś zaraz poniżej.

/dev/sda2 /media/Rozrywka ntfs-3g defaults,locale=pl_PL.UTF-8,auto 0 0

Otrzymałem:

bash: /dev/sda2: Permission denied

Nie wiem co to znaczy. Robie restart.

-- Dodane 05.02.2009 (Cz) 20:25 --

Po restracie to samo...


(bachus) #6

to auto miałeś dopisać do fstab... Spróbuj więc tak:

sudo mount -t ntfs-3g dev/sda2 /media/Rozrywka -o force

(Rykendo) #7

Znów coś nie tak. :?

ntfs-3g: Failed to access volume 'dev/sda2': No such file or directory

Please type '/sbin/mount.ntfs-3g --help' for more information.

(Airborn) #8

/dev/sda2 zamiast dev/sda2


(Rykendo) #9

Rozrywka działa. Ale co z pozostałymi?

sudo mount -t ntfs-3g /dev/sda1 /media/Windows XP -o force

Próbuje tak wklepać, ale wywala mi:

Usage: mount -V : print version

       mount -h : print this help

       mount : list mounted filesystems

       mount -l : idem, including volume labels

So far the informational part. Next the mounting.

The command is `mount [-t fstype] something somewhere'.

Details found in /etc/fstab may be omitted.

       mount -a [-t|-O] ... : mount all stuff from /etc/fstab

       mount device : mount device at the known place

       mount directory : mount known device here

       mount -t type dev dir : ordinary mount command

Note that one does not really mount a device, one mounts

a filesystem (of the given type) found on the device.

One can also mount an already visible directory tree elsewhere:

       mount --bind olddir newdir

or move a subtree:

       mount --move olddir newdir

One can change the type of mount containing the directory dir:

       mount --make-shared dir

       mount --make-slave dir

       mount --make-private dir

       mount --make-unbindable dir

One can change the type of all the mounts in a mount subtree

containing the directory dir:

       mount --make-rshared dir

       mount --make-rslave dir

       mount --make-rprivate dir

       mount --make-runbindable dir

A device can be given by name, say /dev/hda1 or /dev/cdrom,

or by label, using -L label or by uuid, using -U uuid .

Other options: [-nfFrsvw] [-o options] [-p passwdfd].

For many more details, say man 8 mount .

Co znów?


(bachus) #10

Znów to, że nic nie czytasz, co wpisujesz (wklepujesz bezmyślnie). Zwróć uwagę, że "XP" stało się kolejnym przełącznikiem.

sudo mkdir /media/WindowsXP

sudo mount -t ntfs-3g /dev/sda1 /media/WindowsXP -o force

cd /media/WindowsXP

ls -al

(Rykendo) #11

Już jest dobrze. Dziś z rana włączyłem komupter i na pulpicie systemu ukazały mi się partycje. Nie wiem za jaką to sprawą, być może dla tego iż wcześniej wywołałem w terminalu komendę:

sudo mount -a

Dzięki za pomoc! rykendo