Problem ze scryptem java w firefoxie


(Zuri23) #1

gdy wchodze na tą strone pewną strone loguje się ale cały czas czekam i nic ten sam problem mam z innymi menagerami piłkarskimi błąd występuje w firefoxie,operze i IE jave mam ok virusów nie mam więc za bardzo nie wiem co może być przyczyną w konsoli błędów pojawia mi się to

function safeLogin(f)

{

  loginFocus();

  var lf = document.forms["login"];

  var lf2 = document.forms["logindata"];

  md5c = lf['md5c'].value;

  username = lf2['username'].value;

  password = lf2['password'].value.toLowerCase();

  sport = lf2['sport'].value;

  try {

    lf['logindata[md5]'].value = hex_hmac_md5(md5c, password);

    lf['logindata[username]'].value = username;

    lf['logindata[md5c]'].value = md5c;

  } catch(error) {

    alert("There was a client problem when logging in: " + error.description + "\\nPlease report this to support@managerzone.com\\n");

    return false;

  }

  params = "logindata_md5=" + lf['logindata[md5]'].value + "&logindata_username=" + lf['logindata[username]'].value + "&logindata_md5c=" + lf['logindata[md5c]'].value;

  ajaxCallLightboxLoading("ajax_com/start.php", "val=Login&" + params, "loginResponse", "");

  return false;

}


function sendActivationRequest()

{

  var f = document.forms["activationemailform"];

  if(f["email"].value!="")

  {

    lightboxHide();

    ajaxCallLightboxLoading("ajax_com/start.php", "val=resendactivation&email" + f["email"].value, "loginResponse", "");

  }

}


function setNewLoginKey(key)

{

  document.forms["login"]['md5c'].value = key;

}


function loginSport(sport)

{

  var lf = document.forms["login"];

  if(document.getElementById('markasdefault'))

    if(document.getElementById('markasdefault').checked)

      lf['logindata[markasdefault]'].value = "on";

  lf['logindata[sport]'].value = sport;

  lf.submit();

}


function loginResponse(readyState, response, responseParameter)

{

  if (readyState == 4)

  {

    eval(response);

    if(templates['regselectsport']!=undefined)

    {

      prepareRegistration(4, response, '');

      return;

    }

    if (templates['login'] && templates['login'].length == 3)

    {

      if(templates['login'][0]!="L")

      {

        lightboxHide();

        if(templates['login'][0]=="E")

        {

          handleErrorFrame(templates['login'][1]);

        }

        else if(templates['login'][0]=="F")

        {

          myfunc = eval(templates['login'][1]);

          if(myfunc)

            myfunc(templates['login'][2]);

        }

      }

      else {

        lightboxShow(590, [templates['login'][2], "closebutton"], templates['login'][1]);

        lightboxSetPosY(130);

      }

    }

  }

}


function handleErrorFrame(content)

{

  layer_write('login_error_window', content);

  layer_show('login_error_window');

}

// Połączono posty.

Może to nie jest wina scryptu ale nie wiem co sie stało ponowna instalacja przeglądarki nie pomogła


(Kaka') #2

zuri23 ,

Rejestrując się na niniejszym forum zobowiązałeś się przestrzegać jego regulaminu. Niestety, w tym momencie łamiesz go nie tytułując poprawnie tematu. Proszę więc zapoznać się w pierwszej kolejności z całym regulaminem forum, a następnie używając przycisku zmien.gif

W przypadku zignorowania prośby temat poleci do śmietnika oraz mogą zostać wyciągnięte konsekwencje w postaci ostrzeżenia.

Pragnę również przypomnieć, że w języku polskim występują także znaki interpunkcyjne, których Ty nie używasz. Musisz zmienić przyzwyczajenie i zacząć z nich korzystać, bowiem na forum piszemy poprawną polszczyzną.