Problem ze skrótem do uśpienia systemu po nowej aktualizacji


(fan77) #1

Cześć, po wczorajszej dużej aktualizacji Windowsa, przestał prawidłowo działać skrót do uśpienia systemu. Skrót miał taką lokalizacje “rundll32.exe powrprof.dll,SetSuspendState Standby” i po kliknięciu w ikonkę następuje uśpienie. Teraz też tak jest tylko z tą różnicą, że wybudzenie nie następuje po kliknięciu dowolnego klawisza na klawiaturze lub po trąceniu myszką tylko trzeba normalnie włączać laptopa przyciskiem on i trwa to o wiele dłużej niż dotychczas, tylko nieco krócej niż normalny rozruch.
Po kliknięciu we wbudowane uśpienie w menu start, działa prawidłowo, może trzeba wybrać inną lokalizację pliku uśpienia, orientuje się ktoś?


(stens1950) #2

ppm na start >menadżer urządzeń> klawiatury ppn na klawe właściwości i zarządzanie energią i tutaj zaznacz “zezwalaj temu urządzeniu na wznawianie systemu”. Tak możesz na myszkę też zrobić.


(fan77) #3

Nie w tym problem. Usypianie w menu start działa jak trzeba, problem z usypianiem ze skrótu pliku.


(krystian3w) #4

Pewnie masz zresetowaną opcje hibernacji:

:arrow_down:

I się może wtedy hibrernować i włączać tylko Power.


  • Sprawdź takie polecenie (powinno działać przy wyłączonej hibernacji):

    rundll32.exe powrprof.dll,SetSuspendState 0,1,0
    
  • wyłączanie hibrernacji, usypianie, włączanie hibernacji po wybudzeniu:

    powercfg -h off
    rundll32.exe powrprof.dll,SetSuspendState 0,1,0
    powercfg -h on
    
  • Klawiaturą dwie metody:

    • Press Windows key + X, followed by U, then U again to turn off.

    • Press Windows key + X, followed by U, then R to restart.

    • Press Windows key + X, followed by U, then H to hybernate.

    • Press Windows key + X, followed by U, then S to sleep.


    Are those shortcuts too many buttons for you? Well guess what, you can just hit the classic: ALT+F4. There’s also the another of the favorites: a double CTLR+ALT+DEL

  • Można spróbować użyć:


(fan77) #5

Działa ale po nowemu, czyli usypia ale potem nie reaguje na ruch myszy i klawiatury. Hibernację mam wyłączoną. Dalszych instrukcji nie bardzo rozumiem z powodu niezbyt dobrego angielskiego.

Chciałbym by było po staremu, aby usypiało po kliknięciu na ikonę skrótu. Przez kilkanaście lat tak miałem i dopiero wczoraj Microsoft coś tą aktualizacją pomieszał.


(krystian3w) #6

sleep.zip (395,0 KB)

Spakowane nircmd / psshutdown / wizmo:

obraz

te pliki z zębatkami mają to samo co w nazwie i nimi możesz przetestować czy tak samo mało wygodnie uśpią.


(fan77) #7

Po kliknięciu w rozpakowanym folderze dobrze działa wyłącza i wznawia ale po przeniesieniu samego zębatego pliku na pulpit przestaje działać, a na pasek narzędziowy w ogóle nie da się umieścić.


(krystian3w) #8

to ciągniesz prawym przyciskiem myszy i na pasek pulpit - “utwórz skrót”.

image

Wtedy będzie działać.


A jak na pasek to chyba zostaje np.:

sleep skrót zamiast pliku cmd.zip (397,4 KB)

aby działał folder z aplikacją i skrótem być w folderze:
moje dokumenty / biblioteka dokumenty - zastosowałem “%UserProfile%”.



(fan77) #9

Dzięki za porady, zrobiłem tak jak napisałeś, wrzuciłem folder z plikami na inny dysk i zrobiłem skrót, na pasek nie da się wrzucić ale to już jakoś przeżyję.

Przeczytałem , że w niektórych laptopach Fall Creators Update powoduje problem z uśpieniem, co prawda opisują inny model niż mój i nieco inny problem ale pewnie coś i w moim skopali. Może powinienem poczekać na aktualizację w Windows Update a nie wymuszać za pomocą windowsupgrade no ale już za późno.


(krystian3w) #10

Da się wtedy powinno w skrócie zrobionym z aplikacji (nie w pliku tekstowym jak wcześniej) na końcu być dopisane standby lub -d -t 0 (z opcji właściwości).
Przeciąga się bez problemu na pasek.