Problem ze skryptem MemHT


(Meethod) #1

Witam, mam problem z tym cms a dokladniej z kodowaniem znakow. Sytuacja byla omawiana na forum tego skryptu lecz Polskie wsparcie nie dziala od kilku lat.

Z informacji jakie udalo mi sie uzyskac wyszedl patch na ten skrypt tyle ze nie przynosi on efektu. Kodowanie w pliku jest na ISO normalne, lecz nawet "reczna" zmiana na UTF nie wiele zmienia.

Czy moge liczyc na pomoc w tym temacie ?

Co bedzie potrzeba to wklejam zaraz na forum by szybko to naprawic bo czas mnie goni :slight_smile:

Dzieki


(adpawl) #2

jedno, to w lang/polish.php ustawił bym kodowanie utf-8

w inc/inc_config.php polish

a w inc/inc_database.php zaraz po nawi─ůzaniu po┼é─ůczenia da┼é bym mysql_query ('SET NAMES utf-8');

...w samej bazie te┼╝ przestaw kodowanie na utf-8 i popraw metody por├│wnania znak├│w w tabelach.


(Meethod) #3

Rady przeczytane, wcielone ale efekt ten sam ..

baza jedzie na UTF General, lang zrobiony, config i database tez.

Kurcze no szkoda mi rezygnowac z tego skryptu bo jedyny "w miare" samoaktualizujacy przez rss.

Co by jeszcze mozna bylo zrobic ?


(adpawl) #4

Efekt ten sam, bo musisz jeszcze wyedytowa─ç/poprawi─ç i zapisa─ç ponownie dodane wcze┼Ťniej wpisy.

...albo usun─ů─ç i doda─ç na nowo.


(Meethod) #5

Ok, wyrzuce wszystko to co jest teraz pobrane przez rss, i poczekamy az zaciagnie nowe wiadomosci.

Jeszcze mala uwaga, Polskie znaki jakie były wczesniej w skrypcie ( bo jest tłumaczony ) przybraly postac "kwadratowa"

Czyli wczesniej skrypt zawieral Polskie znaki, a zle publikowal newsy. Natomiast teaz jest zle kodowana tresc skryptu np. w adminie i no tresc ale to zobaczymy jak zaciagnie nowe info.

-- Dodane 18.02.2012 (So) 9:56 --

Witam, problem pozosta┼é. Pobra┼éo nowe dane i tak samo jak wcze┼Ťniej wy┼Ťwietla tre┼Ť─ç bez Polskich znak├│w..

-- Dodane 18.02.2012 (So) 14:06 --

Dla zainteresowanych tym CMS. Nie ma mo┼╝liwo┼Ťci naprawy tego b┼é─Ödy. Rozmawia┼éem z developerem skryptu. Dopiero od wersji 5 b┼é─ůd ma by─ç skorygowany.

Temat do zamkni─Öcia.