Problemy z działającym flashem


(rpm) #1

Cześć, mam problem z wyświetlaniem wielu filmów na YouTube na przeglądarkach Firefox i Chromium. Mam zainstalowany najnowszy flash 26.0.0.137. Ale i tak pojawia mi się taki komunikat przy wielu filmach na YT.

twoja przeglądarka nie rozpoznaje obecnie żadnego z dostępnych formatów wideo

Na Chromium jak by całkowicie flash nie działał, podobno potrzebny jest pakiet Pepper-Flash. Ale nie znalazłem go do Fedory 26, zainstalowałem tylko ten co był i każdy go instaluje.

su -c "rpm -ivh http://linuxdownload.adobe.com/adobe-release/adobe-release-x86_64-1.0-1.noarch.rpm"
su -c “dnf install flash-plugin”


(Seba228215) #2

Z tego co wiem, YT nie korzysta z flash (ze względu na bezpieczeństwo), tylko z html 5 player. Może problem u ciebie leży w tym, przeglądarka nie radzi sobie z html 5 i mp4 (większość filmów).


(rpm) #3

Wychodzi na to że Chromium do poprawnego wyświetlania flash wymaga Pepper-Flash.
Robiłem niby w ten sposób z dowiązaniem, ale to nie pomogło.
Odinstalowałem
sudo dnf remove flash-plugin
Dodałem repozytoria RPMFusion aby zainstalować
sudo dnf install freshplayerplugin
sudo mkdir -p /usr/lib64/chromium-browser/PepperFlash
cd /usr/lib64/chromium-browser/PepperFlash

Pobrałem do folderu pakiet flash_player_ppapi_linux.x86_64.tar.gz i wypakowałem go.
https://get.adobe.com/pl/flashplayer/otherversions/

sudo tar -xf flash_player_ppapi_linux.x86_64.tar.gz

Próbowałem też drugi sposób
https://doc.fedora-fr.org/wiki/Flash_:_installation_du_plugin_propriétaire
su -lc ‘dnf install flash-player-ppapi’

ln -s /usr/lib/adobe-flashplugin/libpepflashplayer.so /usr/lib64/chromium-browser/PepperFlash/
ln -s /usr/lib/adobe-flashplugin/manifest.json /usr/lib64/chromium-browser/PepperFlash/

Żaden sposób nie pomaga.


(Seba228215) #4

A przeczytałeś co napisałem. Domyślnie youtube odpala html 5, a filmiki bodajże są wrzucane tam jako mp4, ale mogę się mylić co do formatu wideo. Natomiast standard to html 5 player / nie flash. Może z tym jest problem. Masz możliwość sprawdzenia np na Firefox albo Chrome u siebie ?


#5

Nie ma jednego standardu przesyłanego wideo i nie zawsze odtwarzacz korzysta z HTML5.

@rpm Wejdź na stronę https://www.youtube.com/html5?gl=PL&hl=pl i sprawdź, jakie funkcje obsługuje Twoja przeglądarka.

Na jakim sprzęcie działasz?
Sterowniki aktualne?
Na jakim GPU działasz?


(rpm) #6

Ok z YouTube już sobie poradziłem instalując według tej strony, ale pakiety o trochę innych nazwach.


sudo dnf install gstreamer1-vaapi.x86_64
sudo dnf install gstreamer1-libav.x86_64
sudo dnf install gstreamer1-plugins-bad-free-fluidsynth.x86_64
sudo dnf install gstreamer1-plugins-ugly.x86_64
sudo dnf install gstreamer1-plugins-bad.x86_64
Pozostał jeszcze flash do rozwiązania w Chromium.
Edycja
Rozwiązanie flasha w Chromium
Pobieramy PPAPI Linux for a 64bit system
https://get.adobe.com/flashplayer/otherversions/
su
tar -xf flash_player_ppapi_linux.x86_64.tar.gz -C /usr/lib64/chromium-browser/PepperFlash

Trzeba jeszcze usunąć katalog ~/.config/chromium

Jednak Fedora nie wspiera kodeków H.264 MSE & H.264
dlatego nadal nie wszystkie filmy na YouTube mi działają. Nigdzie nie znalazłem rozwiązania, czy jestem skazany na Chrome.