Problemy z grafiką - gry DX9 czarny obraz, DX10/11, OpenGL działają


(Marcin Obala) #1

Cześć

Mam laptopa HP dv6-3040ew. Ma on dwie grafiki. Jakieś pół roku temu laptop zaczął się zachowywać tak jakby uszkodziła się grafika, blue screeny przy próbie użycia grafiki. W menadżerze urządzeń informacja "Nie udało się włączyć urządzenia". Próbowałem przeinstalowywać system na windows 7, od nowa windows 8 i ciągle były problemy. Laptop poszedł w odstawkę a ja kupiłem nowy. Teraz jednak do niego wróciłem żeby się upewnić czy można traktować go jako zwykły lapek do internetu i na stałe pracować na zintegrowanej grafice. Zainstalowałem od nowa Windowsa 7, sterowniki i wszystko działa, grafika nie zgłasza że nie da się jej uruchomić i nie mam żadnych BSODów. Jednak jest coś dziwnego:

  1. Ze sterami ze strony HP w momencie kiedy ustawię "wysoką wydajność" to żadna aplikacja korzystająca z grafiki nie uruchamia się. Np. Steam, 3dMark, Raptr. Na oszczędzaniu energii wszystko się uruchamia.

  2. Sterowniki ze strony AMD mają dynamiczny tryb przełączania grafiki, nie jest to ustawione na sztywno. I teraz tak:

2.1. Uruchamiając grę na Steamie która korzysta z DX9 mam czarny obraz (np. Serious Sam 3, Devil May Cry 4 DX9)

2.2. Uruchamiając grę która korzysta z DX10 wszystko działa bez zarzutu (3DMark, Devil May Cry 4 DX10)

2.3. Uruchamiając wybierając grafikę Intel HD działa i DX9 i DX10.

Domyślam się że grafika automagicznie się nie naprawiła ale czy ktoś się spotkał z takim zachowaniem?

Znacie jakiś soft do przetestowania kompleksowo w wzdłuż i wrzesz grafikę? Ściągnąłem kilka programów ale każdy daje inne możliwości np.

MSI Kombustor testuje tylko OpenGL i wszystkie testy działają na Radeonie, na Intelu żaden nie działa bo wyrzuca że nie obsługiwany jest openGl x.x.

Futuremark 3dMark najnowszy wszystkie testy działają.

Przy Heaven Benchmark 4.0 Directx 9.0 ma czarny obraz, DX 11 się uruchamia, jest ładowanie a później mi się zamknął a przy wyborze OpenGL dostałem BSODa.

Update: Po restarcie Heaven Benchmark 4.0 DX9 czarny ekran, DX11 działa, OpenGL działa. Dla Intel HD oczywiście DX9 działa bez problemu.

Pozdrawiam


(Dimatheus) #2

Marcin511 , zapoznaj się, proszę, z tym poradnikiem i stroną, a następnie - korzystając z przycisku Edytuj (na dole pierwszego posta po prawej stronie) i opcji Użyj pełnego edytora - popraw tytuł wątku tak, by mówił konkretnie o problemie. Poprawnie zatytułowany wątek zwiększa szansę na uzyskanie szybkiej pomocy. Zignorowanie tej prośby będzie skutkować przeniesieniem tematu do kosza.

Pozdrawiam,

Dimatheus


(Wowa Tatarin) #3

a sprawdź za pomocą debugging tool for windows kod błędu i co go spowodowało?

albo spakuj do rar i wyśli na kppotoczny@gmail.com plik *.dmp z c:Windows/minidump