Program exe nie uruchamia się na innym komputerze


(angry) #1

Mój komputer: Windows 10
Pracuję w Code::Blocks i piszę w c++

taki błąd wyskakuje na innym komputerze:
image


(xBotekx) #2

A coś więcej o tym programie? Jakie bibliotek podpinałeś? Program ma jakieś UI czy to zwykła konsolówka?


(angry) #3

zwykła konsolówka

#include < cstdlib>
#include < iostream>
#include < iomanip>
#include < chrono>
#include < random>
#include < windows.h>
#include < conio.h>

no i jeszcze w ustawieniach projektu mam że dołączam bibliotekę libwinmm.a
image


(Fizyda) #4

Na innym komputerze nie masz dll’ek. Skompiluj program ze statycznym linkowaniem lub przenieś też na drugi komputer dll’ki kompilatora.


(angry) #5

A jak to zrobić w codeblocks? Jestem zielony
Może to dlatego że ja mam nowsza wersję kompilator którą instalowałem poza codeblocks.


(Fizyda) #6


Nie używam Code blocks, ale jak już wiesz w czym jest problem powinno Ci wystarczyć google.


(angry) #7

Ale skąd mam wiedzieć jakie biblioteki tam dodac


(Fizyda) #8

Ah, right :slight_smile: Hmm, try adding the -static & -static-libgcc flags to Other linker options text-box (on separate lines) in the same Build Options dialog.


(angry) #9

Serdecznie dziękuję. Mysłałem że mam wszystkie polecenia z tej strony wykonać.

Co prawda zaznaczenie flag zepsuło mi cały program ale nie poddałem się i zrobiłem reinstall kompilatora wkleiłem kod od nowa i działa teraz dobrze.