Proszę o pomoc przy kompilacji kTorrent 3.3.3


(Bigkoras) #1

Witam.

Jestem nowym użytkownikiem Linuxa Ubuntu 9.10.

Chciałbym zainstalować program kTorrent ale w wersji TYLKO 3.3.3.

W "centrum oprogramowania ubuntu" jest tylko wersja 3.2.4 której nie chcę.

Wersję 3.3.3 ściągnąłem ze strony http://ktorrent.org/?q=downloads i posterowałem zgodnie z instrukcją tam zamieszczoną, ale nie potrafię sobie z tym poradzić.

Robiłem to tak.

Plik "ktorrent-3.3.3.tar.bz2" jest na pulpicie

otwieram terminal

wpisuję:

tar -xvjf ktorrent-3.3.3.tar.bz2

cd ktorrent-3.3.3

mkdir build

cd build

cmake -DCMAKE_INSTALL_PREFIX=kde4-config --prefix .. Tutaj zaczynają się problemy bo wyskakuje coś takiego:

Proszę o pomoc w instalacji tego programu.


(roobal) #2

Bo to co pobrałeś to kod źródłowy, który musisz skompilować ale tym lepiej sobie głowy nie zawracaj, bo spędzisz nad tym za dużo czasu. Na tej stronie https://launchpad.net/ubuntu/+source/ktorrent znajdziesz gotowe paczki dla Ubuntu ale to są dla Ubuntu Lucid Lynx 10.04, więc program może i ma prawo działać niestabilnie i mogą wystąpić problemy z zależnościami, więc wszystko robisz na własną odpowiedzialność.

Pozdrawiam!


(Bigkoras) #3

Plik o nazwie: "ktorrent_3.3.3+dfsg.1.orig.tar.bz2" juz mam i co dalej z nim zrobić?


(marcin82) #4

Witam.

Zajrzyj tutaj.

Zaczyna się takim samym błędem, jak u Ciebie.

Być może przywołane tam pakiety czy biblioteki na coś Cię naprowadzą.

http://www.mandrivalinux.eu/showthread.php?t=444143 .


(Bigkoras) #5

Niestety nic mi to nie mówi, jestem kompletnie "świeży" w Linuxie i nie radze sobie z tym...

Dziwne jest to że do instalacji jednego programu trzeba odstawiać takie cyrki :expressionless:


(roobal) #6

Czemu się upierasz cały czas przy kompilacji kodu źródłowego, zwłaszcza jeśli nie masz o tym kompletnego pojęcia? Ty miałeś pobrać już skompilowany program w pakiecie deb , który ściągniesz sobie stąd https://launchpad.net/ubuntu/+source/kt ... 1_i386.deb - to jest już pakiet gotowy do instalacji, klikasz na tym dwa razy tak samo jakbyś instalował program w Windowsie.

Pozdrawiam!


(Bigkoras) #7

Nie wiedziałem co dokładnie pobrać :slight_smile: Dzieki.

Ale po ściągnięciu pliku i uruchomieniu pokazuje się duży czerwony napis:

Błąd: Niemożliwe spełnienie zależności: kdebase-runtime (>= 4:4.3.90)

Co teraz?


(roobal) #8

W pierwszym poście pisałem, że może wystąpić ten problem, ponieważ Ty masz Ubu 9.10 a ten Ktorrent skompilowany jest dla wersji 10.04, której jeszcze oficjalnie nie wydano i jest powiązana innymi zależnościami, które musisz próbować uzupełnić ręcznie. Pamiętaj tylko, że system ma prawo się posypać po takiej mieszance. Potrzebne zależności znajdziesz na tej stronie:

https://launchpad.net/ubuntu/lucid/i386 ... 1-1ubuntu1

Jednak myślę, że najprościej będzie zainstalować KDE, z którego nie musisz korzystać (możesz nadal korzystać z Gnome, mając zainstalowane również KDE) ale ono rozwiąże problemy z zależnościami. Tu masz opis jak zainstalować najnowszą wersję KDE4 w Ubuntu:

http://www.ubucentrum.net/2010/02/insta ... ntu-i.html

Pozdrawiam!