Przekierowanie/otwarcie portów w routerze TP LINK W890


(Mori 91) #1

Witam,

mam problem (taki jak w temacie), z którym nie mogę sobie za nic poradzić. Jestem dość zielony w temacie, więc z góry przepraszam za mało fachowe wytłumaczenie problemu.

Dla potrzeb gry Tennis Elbow, żeby móc grać online muszę przekierować jakiś port. Do tej pory ciągle wywala mi komunikat o następującej treści: "Nie można połączyć się z twoim komputerem. Sprawdź czy port UDP 4321 jest otwarty lub przekierowany w zaporze lub na routerze"

Więc moje pytanie: jak ten port otworzyć lub przekierować? Próbowałem samodzielnie zrobić coś wg. tego w ustawieniach routera:

http://www.tp-link.com.pl/article/?id=205

http://support.microsoft.com/kb/308127/pl

Ale ciągle pojawia się ten sam problem. Zresztą sam nie wiem co dokładnie mam gdzie wpisywać.


Router TP LINK W8901G pod Orange Freedom.

Z racji tego, że jestem zielony w temacie, na pewno się da coś z tym zrobić tylko nie wiem jak. Prosiłbym kogoś o pomoc. :slight_smile:


(skrzek) #2

Mam nadzieję, że w polu 'Local IP Address' nie pozostawiłeś zer.

Najpierw ustaw sobie (dla Twojego kompa) stały adres IP na routerze, a następnie wpisz go w w/w polu.


(Mori 91) #3

Nie, nie zostawiłem w tym polu zer - nawet się nie dało, bo wywalało komunikat o braku wypełnienia tego pola.

Natomiast próbowałem tam wpisywać różne kombinacje; nie wiem czy mam wpisywać tam adres routera czyli 192.168.1.1, czy 192.168.0.1 czy 192.168.1.2 (ta ostatnia opcja widnieje u mnie jako 'Adres IP' w połączeniach lokalnych, więc pewnie to?).

W końcu jednak ustawiłem sobie statyczne IP według tego opisu (z góry przepraszam za link z innego forum, nie wiem czy można :stuck_out_tongue: ):

http://www.hellforum.pun.pl/viewtopic.php?pid=100

I teraz wracam do portu 4321 i tych ustawień:

http://www.tp-link.com.pl/article/?id=205

Już wiem, że w polu Local IP mam wpisać 192.168.1.2, ale co z innymi polami?

Prosiłbym o pomoc w poprawnym wypełnieniu pól:

-Rule Index:

-Application: tu w ogóle nie wiem co mam wpisywać, wg instrukcji pisze tutaj, żeby wpisać nazwę serwera, ale jaką? #-o Czy mam rozwijać tutaj listę z prawej strony, tam gdzie do wyboru są opcje, np. FTP, SSH i tak dalej, a numery portów wypełniają się automatycznie? Przecież tam nie ma do wyboru portu 4321, więc CHYBA nie [-o<

Protocol: UDP?

  • Start port number: 4321

  • End Port nr: też 4321?

-Local IP adress: 192.168.1.2

Jak to wypełnić żeby otworzyć problemowy port?

Jeszcze jedna informacja, być może istotna, że do łączenia się z grą używam programu hamachi.


(skrzek) #4

Tak jak wypełniasz jest dobrze, wpisujesz jako port startowy i końcowy 4321. Na protokole UDP - tak wynika z pierwszego posta (jeśli zostawisz ALL to tez nie zaszkodzi). W pozycji Aplikacja wybierz Http serwer. Local IP Address to ma być IP Twojego komputera (nie routera)

W świetle tego, twój router nie wymaga konfiguracji pod grę (na port 4321) tylko dla hamachi.

Czy hamachi ma otwarte porty i zestawia połączenie?

Niestety dalej nie wiem jak to się odbywa, nie korzystałem z tego programu.


(Mori 91) #5

Czyli jeśli domyślnie Http_server jest na 80, to zmienić Start i End na 4321? Bo tak właśnie zrobiłem i nie dało to żadnego efektu. Port dalej wygląda na zamknięty, bynajmniej nadal wywala mi taki komunikat.

W panelu gry mam coś takiego:

Hamachi IP - 25.161.250.207 - to IP próbowałem wpisywać w pole 'Local IP adress' zamiast adresu IP komputera, ale też nie dało to efektu.

Niżej jeszcze coś innego: wykryto IP 188.47.247.156 (nie wiem do czego nawet to IP).

Siedzę nad tym cały dzień i nie wiem co jeszcze mogę zrobić. Ktoś mi jeszcze podpowiada, zeby dodać Hamachi do wyjątków w zaporze ( o tym nie pomyślałem, ale chyba nie tu tkwi problem). Co do Twojego pytania o otwarte porty w Hamachi to nie wiem co odpowiedzieć szczerze.


(Dimatheus) #6

Hej,

Pola o nazwie Application to pola z ustawieniami domyślnymi. W nich nic nie wybierasz - zostawiasz (Please Select). A w adresach IP wpisujesz tak jak podałeś, czyli Start i End na 4321.

W portach wpisujesz swoje lokalne IP - i tylko to IP.

To jest Twoje IP publiczne, czyli adres pod którym widoczny jesteś w sieci.

:arrow: Używasz w systemie zapory sieciowej? Jeśli tak, to jakiej?

:arrow: Czy po przekierowaniu portu zapisałeś zmiany i uruchomiłeś urządzenie jeszcze raz?

Pozdrawiam,

Dimatheus


(Mori 91) #7

Używam systemowej zapory pod Windows XP SP3, ale z racji tego że dodanie Hamachi do wyjątków zapory wiele nie dało, wyłączyłem ją...co i tak też nie przyniosło efektów. Zapora na pewno nie blokuje portu, więc nie wiem co jeszcze mogę zrobić.

Chodzi o restart routera po przekierowaniu portu? Tak, robiłem choć i tak nie mam pewności czy ten port jest poprawnie przekierowany. Skoro nadal widzę komunikat, że nie, to coś musi być źle zrobione/wpisane przeze mnie.

Zrobiłem coś takiego, że pewnie aż śmiać się chce(oprócz 4321 próbowałem też przekierować przykładowo inne, wyczytałem na jakimś forum, że port 4321 jest portem domyślnym dla gry i można go zmienić, ale to też nic nie dało) - :


(Dimatheus) #8

Hej,

Faktycznie wygląda, że wszystko ustawione jest poprawnie. Zasadnicza kwestia, czy faktycznie Twój adres IP lokalny to 192.168.1.4. Upewnij się wykonując polecenie ipconfig w wierszu poleceń bądź sprawdzając to w szczegółach połączenia sieciowego.

Dodatkowo sprawdź, czy w konfiguracji routera nie jest włączona opcje DMZ oraz jak skonfigurowana jest zapora sieciowa w routerze.

Pozdrawiam,

Dimatheus


(Mori 91) #9

Co do pytania o lokalne IP, to tak jak mi doradził wcześniej ustawiłem sobie statyczne IP. Po wykonaniu polecenia ipconfig pojawiło się coś takiego:

Firewalla w ustawieniach routera skonfigurowałem w taki sposób, choć nie wiem czy to o to chodziło - zaznaczyłem opcję 'disabled' i zapisałem ustawienia:

Opcję DMZ też zaznaczyłem na disabled:

A na marginesie, mimo wyłączonego jakiś czas temu antywirusa (Comodo), zauważyłem, że firewall wbudowany w tego antywirusa był nadal aktywny. Wyłączyłem go, sądząc że być może tu tkwi rozwiązanie problemu, ale chyba nic z tego - ciągle wyświetla się ten komunikat i nie wiem co można jeszcze zmienić/wpisać/ustawić żeby można się było łączyć z innymi graczami.


EDIT:

Problem po ostatnich zabiegach wydaje się być rozwiązany, zamiast pokazującego się ciągle komunikatu o porcie 4321 (poprzedni slajd), teraz jest to:

Mam nadzieję, że to nie tylko tymczasowe :lol: Dzięki za wskazówki i pomoc. =D>


(Dimatheus) #10

Hej,

Czyli adres IP jest poprawny. :slight_smile:

Tak, dokładnie o to chodziło i firewall jest wyłączony - tak miało być.

Czasami ta opcja może bardzo się przydać. Poprzez aktywację DMZ i przypisaniu do niego jednego z adresów IP lokalnych, dany komputer widziany jest w sieci globalnej tak, jakby nie stał za routerem, a był bezpośrednio podłączony do łącza sieciowego.

Antywirus i firewall w przypadku Comodo są niezależne - to znaczy, że można wyłączyć antywirusa, a firewalla pozostawić i odwrotnie. By całkowicie wyłączyć funkcje programu, trzeba wyłączyć i antywirusa, i firewalla. I być może w tym ostatnim jest najważniejszy problem - w Comodo też konieczne jest przekierowanie portu. Jak? Wchodzisz w Ustawienia zapory sieciowej -> Ustawienia Zaawansowane -> Reguły globalne -> i klikasz Dodaj. Następnie definiujesz protokół, kierunek i port docelowy oraz zatwierdzasz zmiany. Regułę przenosić na samą górę, klikasz OK i gotowe. :slight_smile:

98332548465587736895_thumb.jpg

Pozdrawiam,

Dimatheus