Przełączanie się na zasilanie bateryjne w laptopie - brak in


(R3v0l1) #1

Witam. Niestety mam ten dość "popularny" problem jakim jest niedziałający internet jeżeli zasilanie nie jest podłączone do laptopa. Stosuje komendę: iwpriv eth1 set_pm 0 ale niestety muszę wpisywać ją za każdym razem jak podłączę zasilanie, a chciałbym, żeby to się robiło "automatycznie". Dodam, że próbowałem już z plikiem rc.local, ale to nie pomogło. Wpisywałem również tam komendę iwpriv eth1 set_power 6. Bez skutku. Macie może jakąś radę jak to rozwiązać?


(marcin82) #2

Pokaż zawartość tego pliku:

cat /etc/rc.local

oraz wynik polecenia:

ls -l /etc/rc.local

======

Podałbyś może model laptopa :smiley:


(R3v0l1) #3
cat /etc/rc.local

#!/bin/sh -e

#

# rc.local

#

# This script is executed at the end of each multiuser runlevel.

# Make sure that the script will "exit 0" on success or any other

# value on error.

#

# In order to enable or disable this script just change the execution

# bits.

#

# By default this script does nothing.


iwpriv eth1 set_power 6

exit 0

ls -l /etc/rc.local

-rwxr-xr-x 1 root root 330 2011-12-23 21:55 /etc/rc.local

I model laptopa: Lenovo G565 :smiley:

-- Dodane 11.01.2012 (Śr) 18:37 --

To jak?