Przywrócenie GRUBA


(system) #1

Witam

Na kompie miałem zainstalowany Windows Vista i Xp ( vista oryginalna,a xp chwilowo był potrzebny) postanowiłem zainstalować sobie LINUXA żeby powoli skończyć współprace z Windowsem. Zrobiłem nowe partycje wszystko zainstalowało się jak trzeba. Po pierwszym uruchomieniu systemu miałem fajnie do wyboru wszystkie systemy jakie miałem. Wybrałem oczywiście linuxa bo to z nim chciałem się bardziej zapoznać . Instalowałem jakiś programik i przyciął mi się Ubuntu, że nie reagował na nic to czasnąłem go na sztywno. Po ponownym uruchomieniu dalej miałem możliwość wybrania jednego z trzech systemów ale przy XP i Viscie wyskakiwał błąd "Intput device requested" (nie pamiętam dokładnie). Zmuszony tym razem do linuxa włączyłem go i zainstalowałem audiocostam (klon winampa) potem grałem sobie w jakąś linuxowska gierke. Kiedy chciałem wyłączyć grę znowu zcina kompa. No to znowu na sztywno i tym razem po włączeniu nie pokazało się nic........ tylko "brak BOOTMGR" naciśnij ctrl + alt + del aby zrestartować . Wiec zainstalowałem Vistę od nowa bo oryginalną mam i teraz z niej pisze posta i włącza mi się odrazu vista a nic innego się nie pokazuje . Co zrobić żebym mógł wejść na linuxa chociaż, bo XPeka planuje wywalić.

a propos XPekka to mam go na partycji 180GB i czy da się tak go usunąć ze zniknął wszystkie pliki systemowe a inne dane zostaną ?

Proszę o pomoc bo już nie mam sil #-o


(niezDarek) #2

http://www.nextmag.pl/index.php/artykul ... page_num/2

ciebie dotyczy: " Naprawianie GRUB-a – menedżera startu Linuksa "


(system) #3

"W takiej sytuacji, będącej najczęściej skutkiem wyboru instalacji GRUB-a w sektorze startowym partycji, a nie MBR, najprościej go zreinstalować. Jeśli tylko sam system nagrał się poprawnie, plik konfiguracyjny menedżera jest również stworzony, wystarczy zatem wskazać go GRUB-owi przy instalacji. Do tego celu najlepiej użyć tej samej płyty instalacyjnej, z której wgrywany był Linux, ale jeśli nie startuje ona jako live-cd lub nie udostępnia trybu ratunkowego, użyj System Rescue CD.

Polecenie grub uruchamia interaktywną powłokę menedżera. Następnie komenda find /boot/grub/stage1 (lub find /grub/stage1, jeśli masz partycję dla folderu /boot) zlokalizuje partycję z plikiem startowym GRUB-a, np. (hd0,1). Taki wpis oznacza, że jest to druga partycja, stąd „1”, pierwszego dysku fizycznego – (hd0). Wyświetloną nazwę partycji należy ustawić jako główny katalog GRUB-a komendą root (hd0,1), po czym zainstalować menedżer w MBR tego dysku poleceniem setup (hd0). Po opuszczeniu programu komendą quit i zresetowaniu komputera GRUB powinien zadziałać."

OK - czy teraz ktos moglby mi to przetlumaczyc na moj prosty jezyk? Linuxa dopiera wlaczylem przed wczoraj pierwszy raz :smiley: wiec nie do konca kapuje. Dysk mam SATA wiec chyba nie bede mial hd0,1 tylko cus innego. Moglby ktos to przepisac krok po kroku ? bede baardzo wdziecznny :smiley:


(Marcinkozikowski15) #4

Ściągnij sobie Super Grub do pobrania tutaj http://download.linux-live-cd.org/Super%20...%20sgd/cdrom/ wypal na CD http://thecamels.org/2007/11/07/odzyskiwanie-gruba/#more-164 tu jest instrukcja.


(system) #5

moglbys sprawdzic czy dziala Ci ten link ? bo ja po wlaczeniu go mam "Not Found

The requested URL /Super ... sgd/cdrom/ was not found on this server."


(Marcinkozikowski15) #6

http://download.linux-live-cd.org/Super_Grub_Disk/download/binaries/sgd/cdrom/

Sprawdź teraz


(system) #7

Wypaliłem jako BOOT na płytce włożyłem do napędu, ustawiłem bootowanie na CD/DVD i zrobiło się coś takiego. Co tam mam wpisać ?

pict4411.th.jpg


(Hudys1) #8

Zawsze robiłem tym http://forum.ubuntu.pl/showthread.php?t=45073 sposobem i działało :slight_smile:


(system) #9

EDIT. :smiley: noo ok mam linuxa i gruba ale nie mogę wejść teraz ani na viste ani na starego XPeka...


(system) #10

:stuck_out_tongue: jest rozwiązanie :slight_smile: podczas włączenia GRUBa wyskoczył błąd nr12 spróbowałem włączyć Viste ale nie poszła więc dałem "e" jak edit i spróbowałem zmienić z hd(0,5) na hd(0,1) i nie wiem czy się zaakceptowało/zapisało czy nie, ale nacisnąłem jeszcze jakiś klawisz tylko nie iwem czy "b" jak boot czy coś innego ale zaczęło mi się robić sprawdzanie Windows i po nim uruchomiła sie Vista 8)