Pytanie odnośnie SuperTuxa i SDL


(snajper___) #1

w dalszym ciągu użeram się z tą kompilacją i mam kolejne pytanko:
SuperTux 0.1.3 przy wykonywaniu ./configure sprawdza, czy zainstalowana jest biblioteka SDL w wersji minimum 1.2.4. Czemu w takim razie przy zainstalowanej 1.2.15 stwierdza, że nie ma wersji >= 1.2.4? Przy 1.2.6 kompiluje się bez problemów (no, powiedzmy - ma jakieś kłopoty z odtwarzaniem modułów XM - ale to już inny temat).


(Fizyda) #2

Może funkcja sprawdzająca wersję jest źle napisana i porównuję cyfra po cyfrze, a nie wartość po wartości. W tedy weźmie 1 z 15 i porówna z 4 w tedy 1 < 4 więc wersja niższa niż wymagana.