Quake ]I[ OpenGL problem


(system) #1
Q3 1.11 win-x86 Nov 24 1999

----- FS_Startup -----

Current search path:

e:\gry\quake iii arena\baseq3\pak0.pk3 (3539 files)

e:\gry\quake iii arena/baseq3


----------------------

execing default.cfg

execing q3config.cfg

couldn't exec autoexec.cfg

...detecting CPU, found Intel Pentium III


------- Input Initialization -------

Initializing DirectInput...

Couldn't set DI coop level

Falling back to Win32 mouse support...

Joystick is not active.

------------------------------------

----- Client Initialization -----

----- Initializing Renderer ----

-------------------------------

----- Client Initialization Complete -----

--- Common Initialization Complete ---

Winsock Initialized

Opening IP socket: localhost:27960

Hostname: ult1mepc

IP: 77.253.113.87

Working directory: e:\gry\quake iii arena

----- R_Init -----

Initializing OpenGL subsystem

...initializing QGL

...calling LoadLibrary( 'C:\WINDOWS\system32\opengl32.dll' ): succeeded

...setting mode 4: 800 600 FS

...using desktop display depth of 32

...calling CDS: ok

...registered window class

...created window@0,0 (800x600)

Initializing OpenGL driver

...getting DC: succeeded

...GLW_ChoosePFD( 32, 24, 0 )

...101 PFDs found

...hardware acceleration found

...PIXELFORMAT 7 selected

...creating GL context: succeeded

...making context current: succeeded

Initializing OpenGL extensions

...using GL_S3_s3tc

...using GL_EXT_texture_env_add

...using WGL_EXT_swap_control

...using GL_ARB_multitexture

...using GL_EXT_compiled_vertex_array

...WGL_3DFX_gamma_control not found


GL_VENDOR: NVIDIA Corporation

GL_RENDERER: GeForce FX 5200/AGP/SSE/3DNOW!

GL_VERSION: 2.1.2

GL_EXTENSIONS: GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_half_float_pixel GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shadow GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_gpu_program_parameters GL_EXT_multi_draw_a

GL_MAX_TEXTURE_SIZE: 4096

GL_MAX_ACTIVE_TEXTURES_ARB: 4


PIXELFORMAT: color(32-bits) Z(24-bit) stencil(0-bits)

MODE: 4, 800 x 600 fullscreen hz:60

GAMMA: hardware w/ 0 overbright bits

CPU: Intel Pentium III

rendering primitives: single glDrawElements

texturemode: GL_LINEAR_MIPMAP_NEAREST

picmip: 0

texture bits: 0

multitexture: enabled

compiled vertex arrays: enabled

texenv add: enabled

compressed textures: enabled

Initializing Shaders

...loading 'scripts/base.shader'

...loading 'scripts/base_button.shader'

...loading 'scripts/base_floor.shader'

...loading 'scripts/base_light.shader'

...loading 'scripts/base_object.shader'

...loading 'scripts/base_support.shader'

...loading 'scripts/base_trim.shader'

...loading 'scripts/base_wall.shader'

...loading 'scripts/common.shader'

...loading 'scripts/ctf.shader'

...loading 'scripts/eerie.shader'

...loading 'scripts/gfx.shader'

...loading 'scripts/gothic_block.shader'

...loading 'scripts/gothic_floor.shader'

...loading 'scripts/gothic_light.shader'

...loading 'scripts/gothic_trim.shader'

...loading 'scripts/gothic_wall.shader'

...loading 'scripts/hell.shader'

...loading 'scripts/liquid.shader'

...loading 'scripts/menu.shader'

...loading 'scripts/models.shader'

...loading 'scripts/organics.shader'

...loading 'scripts/sfx.shader'

...loading 'scripts/shrine.shader'

...loading 'scripts/skin.shader'

...loading 'scripts/sky.shader'

...loading 'scripts/test.shader'

----- finished R_Init -----


------- sound initialization -------

Initializing DirectSound

locked hardware. ok

------------------------------------

----- Sound Info -----

sound system is muted

    1 stereo

32768 samples

   16 samplebits

    1 submission_chunk

22050 speed

0x85e8060 dma buffer

Forcing all sounds to 8 bit

No background file.

----------------------

Loading dll file ui.

Failed to load dll, looking for qvm.

Loading vm file vm/ui.qvm.

VM file ui compiled to 902626 bytes of code

30 arenas parsed

32 bots parsed

trFMV::play(), playing idlogo.RoQ

********************

ERROR: Disconnected from server

********************

RE_Shutdown( 0 )

----- R_Init -----


GL_VENDOR: NVIDIA Corporation

GL_RENDERER: GeForce FX 5200/AGP/SSE/3DNOW!

GL_VERSION: 2.1.2

GL_EXTENSIONS: GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_half_float_pixel GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shadow GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_gpu_program_parameters GL_EXT_multi_draw_a

GL_MAX_TEXTURE_SIZE: 4096

GL_MAX_ACTIVE_TEXTURES_ARB: 4


PIXELFORMAT: color(32-bits) Z(24-bit) stencil(0-bits)

MODE: 4, 800 x 600 fullscreen hz:60

GAMMA: hardware w/ 0 overbright bits

CPU: Intel Pentium III

rendering primitives: single glDrawElements

texturemode: GL_LINEAR_MIPMAP_NEAREST

picmip: 0

texture bits: 0

multitexture: enabled

compiled vertex arrays: enabled

texenv add: enabled

compressed textures: enabled

Initializing Shaders

...loading 'scripts/base.shader'

...loading 'scripts/base_button.shader'

...loading 'scripts/base_floor.shader'

...loading 'scripts/base_light.shader'

...loading 'scripts/base_object.shader'

...loading 'scripts/base_support.shader'

...loading 'scripts/base_trim.shader'

...loading 'scripts/base_wall.shader'

...loading 'scripts/common.shader'

...loading 'scripts/ctf.shader'

...loading 'scripts/eerie.shader'

...loading 'scripts/gfx.shader'

...loading 'scripts/gothic_block.shader'

...loading 'scripts/gothic_floor.shader'

...loading 'scripts/gothic_light.shader'

...loading 'scripts/gothic_trim.shader'

...loading 'scripts/gothic_wall.shader'

...loading 'scripts/hell.shader'

...loading 'scripts/liquid.shader'

...loading 'scripts/menu.shader'

...loading 'scripts/models.shader'

...loading 'scripts/organics.shader'

...loading 'scripts/sfx.shader'

...loading 'scripts/shrine.shader'

...loading 'scripts/skin.shader'

...loading 'scripts/sky.shader'

...loading 'scripts/test.shader'

----- finished R_Init -----

Loading dll file ui.

Failed to load dll, looking for qvm.

Loading vm file vm/ui.qvm.

VM file ui compiled to 902626 bytes of code

30 arenas parsed

32 bots parsed

RE_Shutdown( 1 )

Shutting down OpenGL subsystem

...wglMakeCurrent( NULL, NULL ): success

...deleting GL context: success

...releasing DC: success

...destroying window

...resetting display

...shutting down QGL

...unloading OpenGL DLL

----- Initializing Renderer ----

-------------------------------

----- R_Init -----

Initializing OpenGL subsystem

...initializing QGL

...calling LoadLibrary( 'C:\WINDOWS\system32\opengl32.dll' ): succeeded

...setting mode 5: 960 720 FS

...using desktop display depth of 32

...calling CDS: failed, bad mode

...trying next higher resolution: failed, DISP_CHANGE_FAILED

...restoring display settings

...created window@3,16 (966x752)

Initializing OpenGL driver

...getting DC: succeeded

...GLW_ChoosePFD( 32, 24, 0 )

...101 PFDs found

...hardware acceleration found

...PIXELFORMAT 7 selected

...creating GL context: succeeded

...making context current: succeeded

...WARNING: fullscreen unavailable in this mode

...setting mode 5: 960 720 FS

...using colorsbits of 16

...calling CDS: failed, bad mode

...trying next higher resolution: failed, DISP_CHANGE_FAILED

...restoring display settings

...window already present, CreateWindowEx skipped

Initializing OpenGL driver

...WARNING: fullscreen unavailable in this mode

...shutting down QGL

...unloading OpenGL DLL

...assuming '3dfxvgl' is a standalone driver

...initializing QGL

...WARNING: missing Glide installation, assuming no 3Dfx available

...shutting down QGL

----- CL_Shutdown -----

RE_Shutdown( 1 )

-----------------------

GLW_StartOpenGL() - could not load OpenGL subsystem

Nie mogę ustawić rozdzielczości 960x720 oraz 1024x768, do których jest przeznaczony mój monitor.

Nie wiem co jest nie tak.

Grafa: nVidia GeForce Fx5200 Ultra 128MB

Proc: AMD Athlon XP 1800+

1GB RAM DDR1

Monitor Samsung SyncMaster 793DF.


(korni007) #2

Zainstaluj sterowniki 56.72 lub najnowsze (proponuję 56.72)


(Mrylec) #3

Ale po co ustawiasz na OpenGL, ustaw go na D3D. Grafika lepsza i gra będzie płynniej chodzić. Nawet może zmienisz rozdzielczość :wink:


(system) #4

Sterowniki zawsze po reinstalce wgrywam najnowsze :wink: Czyli mam z 14 Sierpnia 2008 roku :wink:

A gdzie jest opcja na D3D? :wink:


(Setjuniorhigh) #5

Zainstaluj detonatory zgodne z modelem twojej karty graficznej.


(system) #6

Hm... grzebę po Googlu i pisze że jest to ForceWare przed zmianą nazwy.

Może Omega Drivers?


(Mrylec) #7

Włączasz Quake'a Wchodzisz w "Options" --> System --> Graphics --> i tutaj musisz szukać :slight_smile:

Sam nie jestem pewien czy to dokładnie tak jest, dawano w Quake'a nie grałem. W każdym bądź razie musisz szukać w "Options" :wink:


(system) #8

Nie ma takiej opcji.

Rozwiązanie kłopotu to wgranie sterowników starszych 'trochę' niż te najnowsze.

Ja wgrałem sobie 5x.xx i pomogły ;D

Do zamknięcia.