Radeon 9550 i Beryl


(Vilco) #1

Posiadam taka wlasnie karte. Sterowniki zainstalowalem przez Envy. Nie dziala Beryl.

Moze tutaj jest cos nie tak:

Section "Files"

	Fontpath	"/usr/share/fonts/X11/misc"

	Fontpath	"/usr/share/fonts/X11/cyrillic"

	Fontpath	"/usr/share/fonts/X11/100dpi/:unscaled"

	Fontpath	"/usr/share/fonts/X11/75dpi/:unscaled"

	Fontpath	"/usr/share/fonts/X11/Type1"

	Fontpath	"/usr/share/fonts/X11/100dpi"

	Fontpath	"/usr/share/fonts/X11/75dpi"

	# path to defoma fonts

	Fontpath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

EndSection


Section "Module"

	Load "i2c"

	Load "bitmap"

	Load "ddc"

	Load "dri"

	Load "extmod"

	Load "freetype"

	Load "glx"

	Load "int10"

	Load "vbe"

EndSection


Section "InputDevice"

	Identifier	"Generic Keyboard"

	Driver "kbd"

	Option "CoreKeyboard"

	Option "XkbRules"	"xorg"

	Option "XkbModel"	"pc105"

	Option "XkbLayout"	"us"

EndSection


Section "InputDevice"

	Identifier	"Configured Mouse"

	Driver "mouse"

	Option "CorePointer"

	Option "Device"	"/dev/input/mice"

	Option "Protocol"	"ImPS/2"

	Option "ZAxisMapping"	"4 5"

	Option "Emulate3Buttons"	"true"

EndSection


Section "InputDevice"

	Driver "wacom"

	Identifier	"stylus"

	Option "Device"	"/dev/input/wacom"

	Option "Type"	"stylus"

	Option "ForceDevice"	"ISDV4"# Tablet PC ONLY

EndSection


Section "InputDevice"

	Driver "wacom"

	Identifier	"eraser"

	Option "Device"	"/dev/input/wacom"

	Option "Type"	"eraser"

	Option "ForceDevice"	"ISDV4"# Tablet PC ONLY

EndSection


Section "InputDevice"

	Driver "wacom"

	Identifier	"cursor"

	Option "Device"	"/dev/input/wacom"

	Option "Type"	"cursor"

	Option "ForceDevice"	"ISDV4"# Tablet PC ONLY

EndSection


Section "Device"

	Identifier	"ATI Technologies Inc RV350 AS [Radeon 9550]"

	Driver	"fglrx"

	Option	"VideoOverlay" "on"

	Option	"OpenGLOverlay" "on"

	Busid "PCI:1:0:0"

EndSection


Section "Monitor"

	Identifier	"H711"

	Option "DPMS"

EndSection


Section "Screen"

	Identifier	"Default Screen"

	Device "ATI Technologies Inc RV350 AS [Radeon 9550]"

	Monitor "H711"

	Defaultdepth	24

	SubSection "Display"

		Depth	1

		Modes "1280x1024"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"

	EndSubSection

	SubSection "Display"

		Depth	4

		Modes "1280x1024"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"

	EndSubSection

	SubSection "Display"

		Depth	8

		Modes "1280x1024"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"

	EndSubSection

	SubSection "Display"

		Depth	15

		Modes "1280x1024"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"

	EndSubSection

	SubSection "Display"

		Depth	16

		Modes "1280x1024"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"

	EndSubSection

	SubSection "Display"

		Depth	24

		Modes "1280x1024"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"

	EndSubSection

EndSection


Section "ServerLayout"

	Identifier	"Default Layout"

  screen "Default Screen"

	Inputdevice	"Generic Keyboard"

	Inputdevice	"Configured Mouse"

	Inputdevice	"stylus"	"SendCoreEvents"

	Inputdevice	"cursor"	"SendCoreEvents"

	Inputdevice	"eraser"	"SendCoreEvents"

EndSection


Section "DRI"

	Mode	0666

EndSection


Section "Extensions"

	Option "Composite" "Disable"

EndSection

// Poprawiłem Twój post, ale na przyszłość pamiętaj aby używać tagów code i quote, które zwiększają czytelność postów

Kaka'


(matiit) #2

a masz zainstalowany xgl?


(wacek) #3

Muszę Cię zamrtwić.

Nie znam takiej osoby która odpaliła by Beryla na tej karcie.

Tzn. Odpalić się go da i niby wszystko jest ok tylko że wtedy tracisz akcelerację :?

Jeżeli zna ktoś sposób na odpalenie beryla (czy jak kto woli Compiz Fusion) i nie stracenie tym samym akceleracji to proszę o jakieś HOW TO


(Vilco) #4

Dzieki. W takim razie zostaje przy orginalnych okienkach. :slight_smile:


(Kazio1987r) #5

Ja odpaliłem Beryla na tej karcie na Ubuntu 6.12 na sterach które były razem z systemem. Po zainstalowaniu sterów przez skrypt Envy Beryl się już nie uruchomił.


(matiit) #6

Bo jak jest xgl to ię traci akcelerację.

Jesli działają z nią otwarte stery to można na aiglx


(Adrian Nawrocki) #7

Ja odpaliłem na tej karcie beryla. Ja też miałem z tym problem http://forum.dobreprogramy.pl/viewtopic ... sc&start=0 , ale tu masz rozwiązanie http://www.forum.ubuntu.pl/viewtopic.php?p=210474

działa na pewno. Efekty będą Ci działać, ale na xgl, a nie aixgl. Do tego potrzebne jest to xserver-xgl. Tylko jest kłopot bo instalowałeś stery przez envy, nie te stery co są w repozytoriach.

Pozdrawiam


(wacek) #8

@Watras16

:roll:

Już wcześniej robiłem na XGL i niestety :dupa:

Tzn. oczywiście beryl działał i wszystkie efekty działały ale straciłem akceleracje

@kazio1987r

Ja też odpaliłem i wszystko działało (nawet akceleracja była) tylko że ekran był przesunięty parę centymetrów w prawo (czyli ewidentny efekt braku sterów)

Mogłem zmieniać rozdzielczość ale to nie pomagało


(Adrian Nawrocki) #9

http://www.forum.ubuntu.pl/viewtopic.php?p=210474 mi się udało odpalić. Spróbuj! W sesji będziesz wybierał czy chcesz odpalać gnome xgl czy bez.

Na xgl gry nie chodzą to się przełaczam na zwykłą sesje. Do pracy używam sesji z xgl, ale do gier zwykłej. Ten sposób działa


(Vilco) #10

I wszystko dziala :smiley:

Dzieki


(Adrian Nawrocki) #11

wacek4 no to instaluj tym sposobem i śmigaj z berylem :stuck_out_tongue: . Działa na pewno.

Ja niestety nie moge się cieszyć bajerami :cry: