Remix OS for PC - bootloop


(sajmon17099) #1

Witam. Na moim nowym pendrive SanDisk Ultra USB 3.0 32GB zainstalowałem Remix OS (z tej strony przez torrent). Na początku wszystko było w porządku, wszystko mi działało. Postanowiłem potem usunąć i połączyć partycje programem GParted, a potem podzieliłem pendrive na dwie partycje - 8GB Ext3 i reszta GB Fat32. Flagę partycji Ext3 ustawiłem na boot, a flagę Fat32 na lba. Na drugim pendrive zrobiłem Live CD Androida x86, a potem podłączyłem dwa pendrivy do komputera i z jednego pendriva na drugi (na ten z Ext3) zainstalowałem na partycji Ext3 Androida x86 (opcją Install to hard disk). Też wszystko działało jak należy. Po wypróbowaniu obu systemów spodobał mi się bardziej Remix OS (mimo że jest te uczucie kopiowania Windows 10 i braku pełnego polskiego tłumaczenia jego obsługa okienek była fantastyczna). Znów więc usunąłem partycje na pendrive, zrobiłem jedną dużą, ustawiłem jej flagi na boot i lba zmieniłem w komputerze system z Ubuntu na Windows 10 i w Windows 10 dla pewności żeby pendrive działał (chociaż i tak działał to nie ufam do końca Ubuntu przy formatowaniu na Fat32, czasem są dziwne błędy których wolę uniknąć) wykonałem komendy w DiskPart:

list disk

select disk 2

clean

create partition primary

format fs=fat32 quick

active

assign

exit

Po tym mój pendrive też działał (zmieniła mu się litera z F lub E na G, chociaż to nie przeszkadza, na Ubuntu jest dalej wykrywany jako sdb1). Zainstalowałem Remix OS plikiem EXE w paczce (nie przez Wine, na Windows 10). Wyłączyłem komputer, w menu bootowania ustawiłem na pierwszym miejscu SanDisk UEFI (tak samo jak kilka dni temu gdy Remix OS działał), gdy rozpoczęło się bootowanie z pendrive wybrałem opcję Użytkownika (nie Gościa, bo na Gościu nic się nie zapisuje tylko system przechodzi chyba do RAMu, tak jak Android x86). Zobaczyłem napis Android, a potem napis Remix OS. I tak lekko migał jak zwykle, myślałem że wszystko jest OK i czekałem. I czekałem, i czekałem. Po jakichś 15 minutach (albo i dłużej, ale na pewno po długim czasie czekania) dalej nic się nie działo. To był bootloop. Wyłączyłem komputer i z ciekawości sprawdziłem szybkość zapisu pendrive (myślałem że jakimś cudem coś mogłem zepsuć). Zapis był jednak raczej taki sam jak poprzednio (>20/30 MB/s). Akurat tyle też potrzebuje Remix OS do działania. Czyli szybkość to nie problem. Jeszcze raz uruchomiłem narzędzie instalacji po formatowaniu pendrive, dalej to samo. W normalnym trybie, bez UEFI też jest bootloop. Tylko przy opcji Gość system się bootuje. Ale ta opcja jest dla mnie bezużyteczna. Podłączyłem pendrive do komputera z Ubuntu, i sprawdziłem czy coś może nie działać. Instalator podzielił mi pendrive na 3 partycje - tak jak poprzednio - REMIX_OS, REMIXOSSYS i REMIXOSDATA. I o ile REMIX_OS i REMIXOSSYS mogę przeglądać i zamontować, to REMIXOSDATA już nie mogę. Gdy próbuję otworzyć REMIXOSDATA wyskakuje mi w Ubuntu taki błąd:

uF7rRau.png

Poprzednio jak Remix OS mi działał to mogłem chyba przejrzeć tę partycję. Zdaje mi się, że sam Remix OS nie może zamontować tej partycji, i dlatego jest bootloop. Jak myślicie - dlaczego tak się dzieje i jak mogę sprawić, żeby ten system działał?


(sajmon17099) #2

Rozwiązałem już ten problem. Problem tkwił, tak jak myślałem, w dev/sda3. Był problem z Ext3 i journalingiem. Naprawiłem to komendą sudo fsck.ext4 -v /dev/sdb3

Na wszystko trzeba odpowiadać tak (t)