Restart zamiast wyłączania systemu


(rpm) #1

Witam, czasem nie mogę zamknąć poprawnie system Linux, tylko następuje ponowny restart systemu. Sądziłem że to wina środowiska graficznego, testowałem kde, gnome-shell, cinnamon, openbox i jest to samo, czasem polecenie 'shutdown -h now' nie pomaga i następuje restart, różne opcje dodane w grubie też nie pomagają, czy zmiana biosu. Wychodzi na to, że winny jest systemd, co można jeszcze wypróbować, aby zamykał się poprawnie Linux?


(dragonn) #2

Watpię żeby winny był systemd - raczej to problem na poziomie kernel+konfiguracja sprzętowa. Podaj dokładnie jaki masz sprzęt.


(rpm) #3

Dzięki, że ktoś odpisał, no więc kernele były zmieniane różne począwszy od tych: http://repo.herecura.be/

http://repo-ck.com/  i na każdym było to samo. Konfiguracja sprzętowa to notebook z AMD E2-1800 APU with Radeon HD  7340 Graphics zintegrowana karta graficzna i 2GB RAM. Miałem różne środowiska graficzne z różnymi konfiguracjami i nadal było to samo. Jest to dość irytujące, aż już byłem skłonny zainstalować inną dystrybucję z upstart.


(roobal) #4

Może to być też problem sprzętowy, np. moja dziewczyna ma ten problem i pod Linuksem, i pod Windowsem. W serwisie też stwierdzili, że to usterka sprzętową.


(rpm) #5

No to fatalnie, kurtka wodna czeka chyba mnie zmiana dystrybucji. Ten sprzęt był w oryginale zakupiony z Linux Ubuntu 12.04, gdzie było zamiast systemd  ten upstart i wszystko działało i poprawnie zamykało system. Trudno, jeszcze sprawdzę inne kernele, tyle ich jest, a może podpowiesz który wybrać kernel na wersje mojego procesora AMD z serii Zacate E-Series? Nie wiem który z tych sprawdzić, no bo nic nie pisze w opisie tych kerneli o architekturze mojego procesora Zacate, są tylko z Family i3/i5/i7, Bobcat, Atom, Bulldozer, Xeon, Core2, K6/K8/K10 AthlonX2/PhenomX4/X6/X8/Turion. A o procesorze który mam nic nie pisze, no chyba że nie ma tam odpowiedniego kernela.     http://www.archlike.darmowefora.pl/index.php/topic,77.0.html

Chociaż wcale nie chce mi się wracać do *buntu dystrybucji.


(roobal) #6

Możesz sprawdzić jeszcze na Debianie Wheezy ze starym, dobrym SysVinit.


(dr.boczek) #7

Jeśli masz systemd to warto spróbować

systemctl poweroff

(dragonn) #8

Dam praktycznie głowę że to nie winna systemd - systemd wysyła tylko sygnał do kernel czy ma być reboot czy wyłączenie. To jest jakiś laptop? Podaj dokładnie jaki. Jakie stery do grafiki masz?

Opcję acpi=noirq sprawdzałeś? Również dobrą opcja jest zerknięcie do BIOSU i wyłączenie Wake on lan podobno albo coś w power management albo Config->USB->Always On USB


(rpm) #9

@dr.boczek ostatnio tak zacząłem zamykać bez systemctl, działa poweroff, ale to po jakimś czasie powraca jak dłużej system jest uruchomiony - może po wybudzaniu, wygaszaniu ekranu coś się potem komplikuje?

 

​@drafonn acpi=noirq mam cały czas ustawione, więc to nie to. Trzy razy już zmieniałem bios od najstarszych do najnowszego, bardzo mało tam jest opcji -nie ma tych co napisałeś. Jest tylko Fun Always on, sprawdzę jeszcze dokładniej z innymi opcjami, ale nie sądzę, aby to był winny bios. Tak to notebook HP, sterowniki mam otwarte xf86-video-ati.


(dragonn) #10

A próbowałeś zamknięte stery? Może w tym problem leży.


(rpm) #11

​Nie wiem tylko, czy ta karta graficzna i procesor nie będą za słabe do tych zamkniętych sterowników Catalyst od AMD. Do tego nie tak łatwo je zainstalować, tworzą się komplikację z zaleznościami, trzeba niektóre pakiety blokować, zmieniać xorg na inny. Mam zainstalowany xorg-server 1.16, to które sterowniki z tej strony będą odpowiednie 14.6 beta, czy 14.9 Ubuntu? Na Ubuntu to korzystałem z jakichś starszych Catalyst od Canonical o nazwie Hondo. Możesz napisać jak najlepiej poprawnie zainstalować, te sterowniki i które będą lepsze, może te ze strony AMD najnowsze - tylko że one są pod Desktopa, nie ma pod kartę graficzną mobilną jaką posiadam w ich wyszukiwarce sterowników, które to wspierają ją oficjalnie.

http://catalyst.wirephire.com/repo/catalyst/x86_64/

​W przypadku AMD istnieją dwa rodzaje sterowników:

> Catalyst - przeznaczone dla kart Radeon HD 5xxx oraz wzwyż,
> Catalyst Legacy - przeznaczone dla kart Radeon HD 2xxx, 3xxx oraz 4xxx


Instalacja własnościowego sterownika:

UWAGA! Ponieważ sterowniki Catalyst nie są kompatybilne z serwerem wyświetlania xorg 1.14 należy przed ich instalacją przeprowadzić jego downgrade do wersji 1.13 (w wersji sterownika Legacy do 1.12).

W tym celu należy otworzyć jako root plik konfiguracyjny pacmana:
nano /etc/pacman.conf
Odznaczyć (usunąć #) w nim opcję
IgnoreGroup
i dopisać do niej xorg tak aby wyglądało to następująco
IgnoreGroup = xorg
Mając już otwarty plik pacman.conf na jego końcu dodajemy również odpowiednie repozytoria zawierające stary xorg oraz sterowniki Catalyst.

UWAGA! Wpis repozytorium xorg należy dodać na pierwszym miejscu ponad wszystkimi innymi repozytoriami.

Dla sterowników Catalyst

> repozytorium xorg[xorg113]
Server = http://catalyst.wirephire.com/repo/xorg113/$arch
> repozytorium Catalyst
[catalyst-stable]
Server = http://catalyst.wirephire.com/repo/catalyst/$arch
Dla sterowników Catalyst Legacy

> repozytorium xorg
[xorg112]
Server = http://catalyst.wirephire.com/repo/xorg112/$arch
> repozytorium Catalyst Legacy
[catalyst-hd234k]
Server = http://catalyst.wirephire.com/repo/catalyst-hd234k/$arch
Po tym zapisujemy i zamykamy pkil pacman.conf

Należy dodać podpis repozytoriów (jako root):
pacman-key --keyserver pgp.mit.edu --recv-keys 0xabed422d653c3094
pacman-key --lsign-key 0xabed422d653c3094
Teraz należy odświeżyć repozytoria
pacman -Sy
przeprowadzić downgrade xorg

> w przypadku sterowników Catalyst
pacman -S xorg113/xorg
> w przypadku sterowników Catalyst Legacy
pacman -S xorg112/xorg
odinstalować niepotrzebne rzeczy zainstalowane wraz z grupą xorg
sudo pacman -R xf86-video-ati xf86-video-intel xf86-video-nouveau ati-dri glamor-egl intel-dri nouveau-dri
i zainstalować catalyst
pacman -S catalyst-utils catalyst dkms linux-headers
(opcjonalnie można doinstalować jeszcze lib32-catalyst-utils)

Po instalacji w/w pakietów należy jeszcze dodać opcję nomodeset do parametrów jądra. Aby to zrobić jako root trzeba otworzyć plik /etc/default/grub
nano /etc/default/grub
i do linii
 GRUB_CMDLINE_LINUX=""
dodać opcję nomodeset
GRUB_CMDLINE_LINUX="nomodeset"
Teraz należy zapisać i zamknąć plik i wykonać jako root
grub-mkconfig -o /boot/grub/grub.cfg
Na końcu należy jeszcze włączyć usługę dkms
systemctl enable dkms.service
oraz wykonać
aticonfig --initial
Po tym wszystkim po restarcie komputera system powinien uruchomić się na własnościowych sterownikach AMD.

Nie chcę narazie krakać, ale możliwe że dzięki waszej pomocy zostałem nakierowany na rozwiązanie problemu. Tak patrzę na komunikaty przy uruchamianiu systemu i widnieje tam power management 254… A ja przecież, aby zmusić opcje hdparm do startowania wraz z system, gdyż nie było innego wyjścia, ponieważ inne opcje nie działały. Stworzyłem polecenie w /etc/rc.local

#!/bin/bash
hdparm -B254 /dev/sda
echo "LID" > /proc/acpi/wakeup

​oraz stworzyłem plik w /etc/systemd/system/rc-local.service

​[Unit]
Description=/etc/rc.local Compatibility

[Service]
Type=oneshot
ExecStart=/etc/rc.local
TimeoutSec=0
StandardInput=tty
RemainAfterExit=yes

[Install]
WantedBy=multi-user.target

​systemctl enable rc-local

​Na razie zamykanie systemu działa, tak samo jak poprzez systemctl poweroff. Nie chcę jednak rezygnować ustawień parkowania głowicy dysku, dlatego będę musiał jakoś w opcjach Cinnamon, zastąpić komendę zamykania systemu tą systemctl poweroff, dopóki będzie działać. To chyba trzeba będzie zmienić jakieś pliki konfiguracyjne Cinnamon w xml? W dconf, gconf nic nie znalazłem gdzie to polecenie podmienić.


(dragonn) #12

“Radeon™ HD 7340”

To co za problem? Zwykłe Catalyst instalujesz, i nie ma się co tutaj martwić że karta czy procesor będzie za słaby… i raczej kieruj się tym https://wiki.archlinux.org/index.php/AMD_Catalyst . Ale pozwól że zapytam najpierw po co Ci ta linia “echo “LID” > /proc/acpi/wakeup” i ona może faktycznie powodować ten problem.


(rpm) #13

​Zgadza się, ale powstają różne błędy czasem i środowisko graficzne nie wstaje - w *buntowatych prościej się instaluje. Do tego za pomocą skryptu ze strony AMD nie mogłem zainstalować poprawnie tych sterowników, również nie wstały xy, natomiast na openSUSE, Gentoo, Slackware, skrypt po restarcie spełnił funkcję prawidłowo. Jednak rozumiem, że ta dystrybucja bardzo szybko się rozwija i osoby ją dopieszczające mogą nie nadążyć ze wszystkim. Wiadomo Fedora, Arch same w nich nowinki, ale i tak zacnie to wszystko działa, jedne z najlepszych dystrybucji Linuksa.

​Co do drugiego pytania, to ta linia raczej nie powoduje problemu, ponieważ był cały plik przy starcie systemu wyłączony tym poleceniem, systemctl disable rc-local. Jednak łudziłem się, rc-local nie ma z tym nic wspólnego, mimo, że był wyłączony po 7 zamknięciu systemu, nastąpił restart… Pozostaje jeszcze sprawdzać systemctl poweroff i wgrać poprawnie te sterowniki, choć jakoś nie lubię własnościowych, zawsze z nimi miałem najwięcej problemów z xorgiem. Możliwe, że tekst roobal się potwierdzi i to rzeczywiście problem sprzętowy. Więc pozostanie mi inna dystrybucja, do której sprzęt sie dopasuje z upstart lub sysvinit jak Slackware, ten nowy forkdebian.


(dragonn) #14

Prostota instalacji sterowników AMD wynika z tego że AMD aktualizuje sterownik wraz z wydanie nowego ubuntu, prędzej nie ma co czekać na update pod nowy kernel czy xorg dlatego sterowników AMD nie ma oficjalnie już długo w repo ponieważ devowie się wkurzyli z tym że blokowało im to zawsze update kernela oraz xorg i sterowniki te wyleciały. A próbowałeś https://www.archlinux.org/packages/?name=linux-lts może? To jest chyba tylko minimalnie nowszy kernel niż w ubuntu teraz jest (3.13 z tego co kojarzę jest w ubuntu teraz).


(rpm) #15

No nie wiem czy to coś da, sprawdzę, ale było już kilka update kerneli i to nic się nie zmieniło, problem nadal występuje. Może wiesz jak w menu zastąpić opcję pod ikonką wyłączania komendą: systemctl poweroff, nie wiem czy obecnie nie jest tam ustawione tak: cinnamon-session-quit --power-off

​Na razie sprawdzam opcję pod różnymi apletami Shutdown, poweroff na panel, dostępnymi w tym środowisku graficznym, tu łatwo to zmienić.


(dragonn) #16

Dlatego proponuję downgrade kernala. A co do widgetu myślę że najprościej i najszybciej na początek dodać sobie zwykły skrót do tego polecenia z stosowną ikonką na panel.


(rpm) #17

dragonn A czy mógłbyś sprawdzić, czy przy uruchamianiu systemu z jądrem linux-lts masz taki pojawiający się wpis: “system version 218”. Nie wiem dlaczego przy nowszych kernelach mam komunikat podczas uruchamiania: “system version 217” , czy przy standardowych noywch wersjach masz wpis z 217 czy 218? Ja mam obecnie  w systemie zainstalowany systemd 218, mimo to na nowszym kernerze pojawia się przy starcie ten wpis z 217, a na  linux-lts 218. Wydaje mi się, że po aktualizacji systemd do > 218 powinno i na nowszych kernelach widnieć przy starcie: “system version 218”?