Rezpozytoria dla programu simplescreenrecorder nie działają


(tomi001) #1

Mam taki problem mam system linux debian 8 i nie chcę przyjąć następujących repozytoriów

związku z  tym polecenie apt-get update zwraca błąd

 

W: Nie udało się pobrać http://ppa.launchpad.net/maarten-baert/simplescreenrecorder/ubuntu/dists/jessie/main/binary-amd64/Packages 404 Not Found



W: Nie udało się pobrać http://ppa.launchpad.net/maarten-baert/simplescreenrecorder/ubuntu/dists/jessie/main/binary-i386/Packages 404 Not Found

i polecenie apt-get install simplescreenrecorder nie znajduje danego pakietu, może wy znacie dobry adres repozytorium.


(JLynx) #2

https://github.com/MaartenBaert/ssr

Spróbuj z tej strony. Znajdziesz tam instrukcje dla debiana.


(dragonn) #3

Bo jest chyba repo dla ubuntu a nie debiana ;p, korzystanie z ppa na debianie to tylko proszenie się o problemy.


(tomi001) #4

Ale nigdzie nie mogłem znaleźć repo dla debiana.

Teraz skompilowałem ten program ze źródeł i dobrze się skompilował, tylko, że utworzył tylko jeden plik w katalogu /usr/local/bin o nazwie ssr-glinject i wywołując ten plik dostaje tylko następujące komunikaty.

 

ssr-glinject: LD_PRELOAD = :libssr-glinject.so

ssr-glinject: command =

 


(sajmon17099) #5

Może spróbuj nagrywać OBSem, właściwie odkąd jest OBS Studio można chyba spokojnie porzucić SimpleScreenRecorder. OBS Studio ma o wiele więcej funkcji. Możesz nim np. też streamować, możesz dodać od razu do nagrywania kamerkę, możesz zrobić chroma key i wiele innych efektów, ogólnie to chyba najlepszy program do nagrywania na Linuxa. Według mnie używanie teraz SimpleScreenRecorder’a to trochę jak używanie MS Painta gdy ma się GIMPa.

 

Jeśli za to dalej chcesz nagrywać SimpleScreenRecorderem, możesz postępować według tego poradnika:

http://www.maartenbaert.be/simplescreenrecorder/recording-steam-games/

Jeśli tego nie rozumiesz czy coś, to mogę ci to później przetłumaczyć.


(tomi001) #6

Przy kompilacji dostaje komunikat

 

CMake Error at /usr/share/cmake-3.0/Modules/FindPackageHandleStandardArgs.cmake:136 (message):

  Could NOT find FFmpeg (missing: avfilter avdevice) (found version

  "56.26.100")

Czyli, że brakuje avfilter i avdevice a nie ma następujących pakietów i tez nie wiem jakie pakiety będą zawierały następujące bilbioteki ?


(sajmon17099) #7

Może najpierw zainstaluj ffmpeg.


(tomi001) #8

ffmpeg jest zainstalowany.


(OneOfUnnamed) #9

 

Zainstaluj inny pakiet:

apt-get install libav-tools

https://wiki.debian.org/ffmpeg#Installation

 


(tomi001) #10

Jednak to nie pomogło i zrezygnowałem z tego programu i zainstalowałem sobie vokoscreen.


(bax20) #11

APPImage działający na Debianie, bez kompilacji, bez instalacji.

Uczyń wykonywalnym i odpala:

 

https://bintray.com/probono/AppImages/SimpleScreenRecorder/0.3.6%2B1.glibc2.14#files