Router nie pamięta DNS dla komputera stacjonarnego


(kluczyk1234) #1

Witam,
Miałem małe problemy z Orange Neostrada, oni naprawili ale mój router miał już 6 lat więc kupiłem nowy. Skonfigurowałem podobnie jak ten stary - wszystko śmiga szybko i na wi-fi i na kablu przy kompie, gdzie jest podpięty router.

Jeden problem - WI-FI na laptopie i telefonach jest cały czas, natomiast jak ten stacjonarny odpocznie kilka godzin lub rano jak się go włącza to router pokazuje, że ok ale włączając przeglądarkę jakąkolwiek wyskakuje komunikat, że nie mógł znaleźć czy połączyć z serwerem DNS (w tym samy czasie wi-fi cały czas działa). Jak się router wyłączy i włączy - to znowu działa ok, aż do ponownego włączenia komputera.

DNS mam od Orange standardowe… działało wszystko od lat. Nie wiem czemu teraz jakby router nie mógł zapamiętać czegoś po kablu i po pierwszym włączeniu kompa trzeba go restartować i wtedy śmiga dobrze.

Z góry dzięki za pomoc.


(MeHowG) #2

A stacjonarke masz na kablu? Ustaw sobie dla niego adres statyczny spoza puli wyznaczonej w DHCP.


(kluczyk1234) #3

Tak stacjonarny jest na kablu telefonicznym z routerem.
A jak mam ustawić ten adres statyczny - możesz prościej?


(MeHowG) #4

W ustawieniach routera musisz sprawdzić jaki zakres adresów IP masz przydzielany a jaki wolny…

Np DHCP przydziela 50 adresów od 192.168.1.100… więc od 2 do 99 masz wolne adresy. Sprawdź sobie jakie są maska sieci, adres bramy - powinien być z końcówką 1 i adresy DNS. Najszybciej sprawdzić w CMD wpisując ipconfig /all

I we właściwościach połaczenia lokalnego dla karty sieciowej odszukujesz IP4 i tam ustawiasz IP, maske, bramę i DNSy recznie…


(kluczyk1234) #5

Microsoft Windows [Version 6.2.9200]
© 2012 Microsoft Corporation. Wszelkie prawa zastrzeżone.

C:\Users\łukasz>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : lukasz
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Połączenie lokalne* 4:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Karta Microsoft Hosted Network Virtual Ad
apter
Physical Address. . . . . . . . . : 0E-D2-92-83-FB-71
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Połączenie lokalne* 2:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Karta Microsoft Wi-Fi Direct Virtual Adap
ter
Physical Address. . . . . . . . . : 0C-D2-92-83-FB-72
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wi-Fi:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® Centrino® Wireless-N 135
Physical Address. . . . . . . . . : 0C-D2-92-83-FB-71
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::e158:224:b7ed:57b%15(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.103(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 11 lutego 2019 18:53:32
Lease Expires . . . . . . . . . . : 12 lutego 2019 18:53:37
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DHCPv6 IAID . . . . . . . . . . . : 302830226
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-E8-89-BE-20-1A-06-30-83-F8

DNS Servers . . . . . . . . . . . : 8.8.8.8
8.8.4.4
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Ethernet:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Qualcomm Atheros AR8172/8176/8178 PCI-E F
ast Ethernet Controller (NDIS 6.30)
Physical Address. . . . . . . . . : 20-1A-06-30-83-F8
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Połączenie sieciowe Bluetooth:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Urządzenie Bluetooth (sieć osobista)
Physical Address. . . . . . . . . : 0C-D2-92-83-FB-75
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{EC6FA64B-75C5-4D73-BD0D-0C535A1E12AE}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Karta Microsoft ISATAP
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Karta tunelowania Teredo firmy Microsoft
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes


(MeHowG) #6

No i nie jesteś podpięty po kablu :confused: tylko przez WiFi… a DNSy masz publiczne googla z tego co widzę… Czy to z laptopa?

Pisałem wcześniej, że najlepiej komputer stacjonarny podłączyć kablem RJ45 do routera… zrób screena ustawień dla ip4 z ustawień karty sieciowej. I zdecyduj się czy stacjonarka ma być podpięta kablem czy przez WiFi… chyba, że to polecenie wykonałeś na lapku…

Ustawienia dla Ciebie dla stacjonarki na sztywno:
IP 192.168.1.2
MASKA 255.255.255.0
BRAMA 192.168.1.1

DNSY:
Orange
217.116.100.100
217.116.104.104

lub
194.204.152.34
194.204.159.1

albo google
8.8.8.8
8.8.4.4

lub OpenDNS
208.67.222.222
208.67.220.220


(kluczyk1234) #7

Jest podpięty RJ45 - ale ipconfig /all był z laptopa. Poniżej masz z stacjonarnego:

Po uruchomieniu Chroma wyskakuje, że serwer DNS googla (strony startowej) nie znaleziony i ipconfig takie coś wtedy wyskakuje: (router cały czas świeci się poprawnie i wi fi działa):

Microsoft Windows XP [Wersja 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig/all

Konfiguracja IP systemu Windows

    Nazwa hosta . . . . . . . . . . . : ppp-8c24141ac49
    Sufiks podstawowej domeny DNS . . . . . . :
    Typ węzła . . . . . . . . . . . . : Nieznany
    Routing IP włączony . . . . . . . : Nie
    Serwer WINS Proxy włączony. . . . : Nie

Karta Ethernet Połączenie lokalne 2:

    Sufiks DNS konkretnego połączenia :
    Opis . . . . . . . . . . . . . . :  Atheros L1 Gigabit Ethernet 10/100/1

000Base-T Controller
Adres fizyczny. . . . . . . . . . : 00-1F-C6-A5-A1-AB
DHCP włączone . . . . . . . . . . : Tak
Autokonfiguracja włączona . . . . : Tak
Adres IP autokonfiguracji . . . . : 169.254.45.79
Maska podsieci. . . . . . . . . . : 255.255.0.0
Brama domyślna. . . . . . . . . . :
Serwery DNS . . . . . . . . . . . : 194.204.159.1
194.204.152.34

C:\Documents and Settings\Administrator>


A jak się wyłączy i włączy router (nie komputer) to po chwili wszystko gra i wtedy ipconfig tak wygląda:

Microsoft Windows XP [Wersja 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig /all

Konfiguracja IP systemu Windows

    Nazwa hosta . . . . . . . . . . . : ppp-8c24141ac49
    Sufiks podstawowej domeny DNS . . . . . . :
    Typ węzła . . . . . . . . . . . . : Nieznany
    Routing IP włączony . . . . . . . : Nie
    Serwer WINS Proxy włączony. . . . : Nie

Karta Ethernet Połączenie lokalne 2:

    Sufiks DNS konkretnego połączenia :
    Opis . . . . . . . . . . . . . . :  Atheros L1 Gigabit Ethernet 10/100/1

000Base-T Controller
Adres fizyczny. . . . . . . . . . : 00-1F-C6-A5-A1-AB
DHCP włączone . . . . . . . . . . : Tak
Autokonfiguracja włączona . . . . : Tak
Adres IP. . . . . . . . . . . . . : 192.168.1.101
Maska podsieci. . . . . . . . . . : 255.255.255.0
Brama domyślna. . . . . . . . . . : 192.168.1.1
Serwer DHCP . . . . . . . . . . . : 192.168.1.1
Serwery DNS . . . . . . . . . . . : 194.204.159.1
194.204.152.34
Dzierżawa uzyskana. . . . . . . . : 12 lutego 2019 08:30:03
Dzierżawa wygasa. . . . . . . . . : 13 lutego 2019 08:30:03

C:\Documents and Settings\Administrator>

Nie wiem czemu z laptopa dużo więcej tekstu, ustawień?


(kluczyk1234) #8

Wklejam jeszcze ze stacjonarnego - ustawienia sieci lokalnej:
fadsf


(MeHowG) #9

Ok, z laptopa masz więcej ustawień bo jest w systemie więcej interfejsów sieciowych fizycznych i wirtualnych…

W stacjonarce, w tym oknie protokół internetowy zaznacz użyj następującego adresu IP i w pola wpisz kolejno
192.168.1.2
255.255.255.0
192.168.1.1

W przypadku kiedy Twój komputer ma Adres IP autokonfiguracji . . . . : 169.254.45.79 oznacza to, że nie otrzymał adresu z DHCP routera, ponieważ jest to system XP trzeba by sprawdzić i przetestować kilka wariantów tej sytuacji. Ale jeśli ustawisz to co napisałem powyżej problem powinien się rozwiązać.


(kluczyk1234) #10

Jak wchodzę na stacjonarnym na xp w centrum sieci - to są 2 połączenia, jedno jakieś 1324 a drugie lokalne 2 — wczoraj zmieniłem tak jak pisałeś w jednym z nich (bo w obu na raz nie można) - rano włączam i dalej nic. Teraz na odwrót w tym drugim pozmieniałem… sprawdzę i dam znać, bo to się dzieje tak jak komp jest kilka godzin nie używany.

Skoro piszesz, że nie działa bo nie dostaje numeru z DHCP - to czemu raz działa, a raz nie? Jak się zrobi on/off to od razu łapie?


(MeHowG) #11

Przy XPku powodów może być kilka, 1324 cie nie interesuje, tylko połączenie lokalne. Zmień jeszcze port w routerze, do którego podłączony jest PC


(kluczyk1234) #12

Połączenie lokalne jak robię tak jak piszesz - to nie łączy się wcale. Nawet jak zresetowałem router i był internet - wprowadzając takie dane jak podajesz, momentalnie nie znajduje DNS i nie wyświetla się żadna strona.

A port w routerze jak zmienić? Chodzi o fizyczne kabelki aby podpiąć pod inne gniazdo?


(MeHowG) #13

Tak, fizyczne przepięcie portu


(kluczyk1234) #14

Sprawdzę i dam znać… bo tak się dzieje jak komputer odpocznie kilka godzin :slight_smile: więc sorry, że z opóźnieniem daję znać… ale posprawdzam jeszcze ten kabel.


(kluczyk1234) #15

Po zmianie kabla, dziś rano włączył się normalnie i wszystko działało. Na razie więc dzięki za pomoc… choć kilka dni poobserwuję i dam znać co to by było. Zrobiłem też czyszczenie CCleanerem, może to też pomogło jakby były jakieś śmieci.

Na razie dzięki, a jakby problem wrócić to dam znać w najbliższych dniach :slight_smile: