Rozjechane obrazy po eksporcie Calc (*.ods) do PDF


(pocolog) #1

Mam problem z eksportem arkusza kalkulacyjnego Calc programu LibreOffice 5.2.7.2 do formatu PDF.
Dokument zawiera osadzony obraz JPG zakotwiczony do komórki, który nie potrafi się poprawnie zapisać. Nie ma znaczenia czy wybiorę PDF/A-1a czy zwykły PDF, czy wybiorę kompresję bezstratną czy JPEG, nie ma też wpływu czy ustawię zmniejszenie DPI obrazów czy nie. Za każdym razem otrzymuję taki bazgroł na dokumencie:


Co ciekawe po wydrukowaniu napis (logo) jest czytelne tylko kolory są odwrócone…

Jeśli ma ktoś pomysły jak temu zaradzić to chętnie poczytam, bo mi się już skończyły…


(Monczkin) #2

Jakim programem robisz tego pdf? Wbudowane narzędzie?


(pocolog) #3

Tak.


(Monczkin) #4

To użyj np. https://www.dobreprogramy.pl/PDFCreator,Program,Windows,12691.html Działa jako wirtualna drukarka.


(pocolog) #5

Wiem, że mogę użyć wirtualnej drukarki, ale chcę to rozwiązać na poziomie tego programu, bo nie chce mi się biegać po komputerach i instalować wszystkim dodatkowych programów.


(Monczkin) #6

Po co na wszystkich? Jeżeli komputery są w sieci, to możesz ją zwyczajnie udostępnić. To raz. A dwa, po prostu sprawdź czy ten sam problem wystąpi przy użyciu innego narzędzia.


(pocolog) #7

I drukowany plik będzie zapisywany na maszynie wysyłającej czy udostępniającej?


(krystian3w) #8

Sprawdzałeś może jak działa opcja wydruku do pdf w nowszej wersji (mniej stabilnej 5.4)?


(takijeden.ninja) #9

Z LCalc kłopotów w zasadzie nie miałem, ładowalem do arkusza zarówno logo jak i zdjęcia i było dobrze, ale to było kiedyś…
Podobnego problemu do Twojego doświadczyłem całkiem niedawno w LDraw przy formatce A1 z osadzonym plikiem rastrowym. Wyglądało to bardzo dobrze na ekranie, ale przy eksporcie do PDF istna pikseloza. Nie pomagała też żadna drukarka PDF.
Po czasie zorientowałem się co bruździło. Plik zrobiony na linuksie za cholerę nie dawał dobrego wydruku, nawet odpalony w LO pod Windows. Zrobiłem taki sam pliczek od zera pod Windowsem i tą samą wersją LO i nie było już żadnych problemów. Głupie? No pewnie, ale może tu jest haczyk.


(Domker) #10

Zrobiłem obrazek JPG i zakotwiczyłem w dokumencie LibreOffice Calc, weksportowałem do PDF i u mnie takie coś nie występuje.
(LibreOffice 5.3.4-2)

Raz miałem sytuację, że obrazek w negatywie wychodzi po druku z PDF, ale spróbuj wkleić do GIMPA jako nowa warstwa i spłaszczyć obraz, a następnie skopiuj z GIMPA i w klej do arkusza, zakotwicz i wyeksportuj do PDF - powinno być ok.
Albo po prostu zabugowana wersja LO.


(pocolog) #11

Pod Windowsem mam ten sam problem… ale teraz nie wiem jaka wersja jest na Windows… sprawdzę jutro i dam znać.


(pocolog) #12

Spróbuję wymusić instalację nowszej wersji, ale dla mnie to jest dziwne, bo nie eksportuję do pdf krzywych(svg) tylko bitmapę :confused: