Rożnica w wyświetalniu między IE a FF


(system) #1

Witam, mam problem z fragmentem kodu. Otóż gdy dodam takie coś, pod IE 7 strona rozjeżdża się kilka px, natomiast pod FF 3 jest tak jak należy.


(Mariuszs) #2

Nie używamy border dla . Dla każdego wymagany jest 'alt'. Lepiej dodać wymiary obrazka.


(_mnich) #3

a możesz powiedzieć dlaczego ?


(Kutar 0) #4

(_mnich) #5

no oki wszyscy wiemy że określnie odnośnie border powinno być zdeklarowane w arkuszu styli


(system) #6

(_mnich) #7

może jeszcze jakiś doctype jeszcze ustaw na początek

rzuć okiem tutaj

http://www.w3schools.com/tags/tag_DOCTYPE.asp


(system) #8

No wiem wiem o tym doctype i metach, ale najpierw jedno, nie pisałem tego bo jeszcze nie raz będę zmieniał index... Robie grafe w photoshopie i nie chce mi sie co chwile przeklejać wszystkiego. Najpiero muszę tamten problem rozwiązać.


(_mnich) #9

a dlaczego robisz od końca zrób to od początku


(system) #10

Poniważ to niczego nie zmienia, a mam już obrany cel, tylko zanim go zrealizauje musze sprawdzić czy będzie się to trzymac qpy, a jak widac coś nie bardzo chce. Nie chce rezygnować z IE przez kilka px...


(Mariuszs) #11

Daj screena. Muszę to zobaczyć.


(system) #12

c9e586e1febca15f.jpg

Na grafe nie patrzcie bo to tylko przykład :stuck_out_tongue_winking_eye:


(system) #13

Po 3 dniach walki rozwiązałem problem. Okazuje się że "nowe" IE nie lubie jak się zamyka znacznyki w innej lini, dla przykładu:

[/code]


Jeżeli tak zapiszemy to wszystko będzie elegancko, ale jeżeli zrobimy tak:

[code][![obrazek](obrazek)](google.pl)

To już obrazek ucieka kilka px...

Jak to zobaczyłem to się załamałem poprostu...