Rozwalony grub, Windows nie startuje


(adrian218) #1

Witam mam problem , chciałem zainstalować antregosa , bo nigdy nie miałem styczności z archem. Do pcta mam wpięte 2 dyski twarde na 1 jest Windows 10 , na drugim postawiłem antregosa , gruba umieściłem na dysku z Windowsem , no i po instalacji antregos nie startował. Odpiąłem dysk z antregosem i wiadomo co sie dzieje przy probie odpalenia Windowsa grub rescure. I nie mam pojęcia jak naprawić rozruch Windowsa. Mam jedynie dostęp do antregosa live odpalonym z dysku zewnętrznego , takie coś wyrzuca mi fdisk ma ktoś jakieś pomysły ?


(pocolog) #2

Wygląda, że na pierwszym dysku masz Windowsa, a na drugim nie masz nic (jedna partycja o rozmiarze 2GB i druga 64MB). Zainstaluj Antergosa jeszcze raz uważnie czytając opisy w instalatorze.


(adrian218) #3

Jest podpięty tylko dysk z windowsem, i nie chce antregosa, tylko naprawić windowsa.


(pocolog) #4

Na zrzucie ekranu który wkleiłeś jest podpięty dysk sda o rozmiarze 233 GB, oraz sdb 298GB więc ewidentnie są dwa.
Tutaj masz link jak przywrócić bootloader Windowsa.
https://websetnet.com/pl/repair-efi-bootloader-windows-10/
Jeśli oczekujesz precyzyjniejszych wskazówek, to polecam przenieść temat do odpowiedniego działu :wink:


(adrian218) #5

Jak by czytal ze zrozumieniem zauw azyl bys ze mam odpalonego antregosa na dysku zewnetrznym :slight_smile: I mam dostep tylko do antregosa na live nie mam nigdzie obrazu z 10 i nie mam nawet na co nagrac.


(marcin82) #6

To zrobisz z Angegros livecd - podaj wynik skryptu bootinfoscript:
https://sourceforge.net/projects/bootinfoscript/ .


(adrian218) #7
                  Boot Info Script 0.61      [1 April 2012]

============================= Boot Info Summary: ===============================

=> Grub2 (v1.99) is installed in the MBR of /dev/sda and looks at sector 1 of
the same hard drive for core.img. core.img is at this location and looks
in partition 130 for .
=> Grub2 (v1.99) is installed in the MBR of /dev/sdb.

sda2: __________________________________________________________________________

File system:       ntfs
Boot sector type:  Windows Vista/7: NTFS
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  
Boot files:        /bootmgr /Windows/System32/winload.exe

sda4: __________________________________________________________________________

File system:       ntfs
Boot sector type:  Windows Vista/7: NTFS
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  
Boot files:        

sdb1: __________________________________________________________________________

File system:       iso9660
Boot sector type:  Unknown
Boot sector info: 
Operating System:  
Boot files:        

sdb2: __________________________________________________________________________

File system:       vfat
Boot sector type:  FAT16
Boot sector info:  According to the info in the boot sector, sdb2 starts 
                   at sector 0. But according to the info from fdisk, 
                   sdb2 starts at sector 224.
Operating System:  
Boot files:        /efi/archiso/vmlinuz.efi /efi/boot/bootx64.efi 
                   /efi/boot/HashTool.efi /efi/boot/loader.efi

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________
Dysk /dev/sda: 232.9 GiB, bajtów: 250058268160, sektorów: 488395055
Jednostki: sektorów, czyli 1 * 512 = 512 bajtów
Rozmiar sektora (logiczny/fizyczny) w bajtach: 512 / 512
Rozmiar we/wy (minimalny/optymalny) w bajtach: 512 / 512
Typ etykiety dysku: dos

Partition Boot Start Sector End Sector # of Sectors Id System

/dev/sda2 1,026,048 204,019,294 202,993,247 7 NTFS / exFAT / HPFS
/dev/sda4 205,770,752 488,392,703 282,621,952 7 NTFS / exFAT / HPFS

Drive: sdb _____________________________________________________________________
Dysk /dev/sdb: 298.1 GiB, bajtów: 320072933376, sektorów: 625142448
Jednostki: sektorów, czyli 1 * 512 = 512 bajtów
Rozmiar sektora (logiczny/fizyczny) w bajtach: 512 / 512
Rozmiar we/wy (minimalny/optymalny) w bajtach: 512 / 512
Typ etykiety dysku: dos

Partition Boot Start Sector End Sector # of Sectors Id System

/dev/sdb1 * 0 3,912,959 3,912,960 0 Empty
/dev/sdb2 224 131,295 131,072 ef EFI (FAT-12/16/32)

/dev/sdb1 overlaps with /dev/sdb2

GUID Partition Table detected, but does not seem to be used.

Partition Start Sector End Sector # of Sectors System
/dev/sdb1 0 3,912,895 3,912,896 Data partition (Windows/Linux)
/dev/sdb2 224 131,295 131,072 Data partition (Windows/Linux)

“blkid” output: ________________________________________________________________

Device UUID TYPE LABEL

/dev/loop0 squashfs
/dev/sda2 265CDAF95CDAC32B ntfs
/dev/sda4 B45ABB925ABB4FBA ntfs
/dev/sdb1 2017-11-06-09-10-49-00 iso9660 ANTERGOS
/dev/sdb2 5A80-25E1 vfat ARCHISO_EFI

================================ Mount points: =================================

Device Mount_Point Type Options

/dev/loop0 /run/archiso/sfs/root-image squashfs (ro,relatime)
/dev/sdb1 /run/archiso/bootmnt iso9660 (ro,relatime,nojoliet,check=s,map=n,blocksize=2048)

======================== Unknown MBRs/Boot Sectors/etc: ========================

Unknown BootLoader on sdb1

00000000 33 ed 90 90 90 90 90 90 90 90 90 90 90 90 90 90 |3…|
00000010 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 |…|
00000020 33 ed fa 8e d5 bc 00 7c fb fc 66 31 db 66 31 c9 |3…|…f1.f1.|
00000030 66 53 66 51 06 57 8e dd 8e c5 52 be 00 7c bf 00 |fSfQ.W…R…|…|
00000040 06 b9 00 01 f3 a5 ea 4b 06 00 00 52 b4 41 bb aa |…K…R.A…|
00000050 55 31 c9 30 f6 f9 cd 13 72 16 81 fb 55 aa 75 10 |U1.0…r…U.u.|
00000060 83 e1 01 74 0b 66 c7 06 f1 06 b4 42 eb 15 eb 00 |…t.f…B…|
00000070 5a 51 b4 08 cd 13 83 e1 3f 5b 51 0f b6 c6 40 50 |ZQ…?[Q…@P|
00000080 f7 e1 53 52 50 bb 00 7c b9 04 00 66 a1 b0 07 e8 |…SRP…|…f…|
00000090 44 00 0f 82 80 00 66 40 80 c7 02 e2 f2 66 81 3e |D…f@…f.>|
000000a0 40 7c fb c0 78 70 75 09 fa bc ec 7b ea 44 7c 00 |@|…xpu…{.D|.|
000000b0 00 e8 83 00 69 73 6f 6c 69 6e 75 78 2e 62 69 6e |…isolinux.bin|
000000c0 20 6d 69 73 73 69 6e 67 20 6f 72 20 63 6f 72 72 | missing or corr|
000000d0 75 70 74 2e 0d 0a 66 60 66 31 d2 66 03 06 f8 7b |upt…ff1.f...{| 000000e0 66 13 16 fc 7b 66 52 66 50 06 53 6a 01 6a 10 89 |f...{fRfP.Sj.j..| 000000f0 e6 66 f7 36 e8 7b c0 e4 06 88 e1 88 c5 92 f6 36 |.f.6.{.........6| 00000100 ee 7b 88 c6 08 e1 41 b8 01 02 8a 16 f2 7b cd 13 |.{....A......{..| 00000110 8d 64 10 66 61 c3 e8 1e 00 4f 70 65 72 61 74 69 |.d.fa....Operati| 00000120 6e 67 20 73 79 73 74 65 6d 20 6c 6f 61 64 20 65 |ng system load e| 00000130 72 72 6f 72 2e 0d 0a 5e ac b4 0e 8a 3e 62 04 b3 |rror...^....>b..| 00000140 07 cd 10 3c 0a 75 f1 cd 18 f4 eb fd 00 00 00 00 |...<.u..........| 00000150 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................| * 000001b0 e0 00 02 00 00 00 00 00 39 a2 7a 60 00 00 80 00 |........9.z…|
000001c0 01 00 00 77 e0 fa 00 00 00 00 00 b5 3b 00 00 fe |…w…;…|
000001d0 ff ff ef fe ff ff e0 00 00 00 00 00 02 00 00 00 |…|
000001e0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |…|
000001f0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 55 aa |…U.|
00000200

=============================== StdErr Messages: ===============================

mdadm: No arrays found in config file or automatically


(marcin82) #8

Czy przed instalacją Antegrowa ręcznie przygotowałeś partycje - zwłaszcza chodzi mi o EFI?

Windows 10 został zainstalowany w trybie BIOS/MBR (nie UEFI). Tak samo musi być zainstalowany Antegros.

Jeśli sam zrobiłeś partycję EFI to zrobiłeś źle.

Jeśli cały dysk /dev/sdb ma być przeznaczony dla Antegrosa,

to korzystając z livecd Antegros LUB innego livecd usuń wszystkie partycje na /dev/sdb i utwórz nowe. Najlepiej utwórz nową tablicę partycji DOS/MBR (nie GPT). Utwórz partycję na “/” główny system plików, na “/home” i na swap - o ile używasz pełnej hibernacji.

Jak będziesz miał partycje to zainstaluj Antegros od nowa i zainstaluj Gruba w tym samym miejscu, co poprzednio, czy /dev/sda.

Windows powinien zostać wykryty i powinieneś móc go uruchomić przez GRUBA.

Jak uruchomisz Windowsa - zainstaluj program EasyBCD i tam przywrócisz pliki rozruchowe Windows.


(adrian218) #9

Nic nie daje ponowna instalacja nadal bd kernela