[rozwiązany] Co zrobić (wklepać w terminal) żaden program się nie instaluje


(kikamil) #1

Przetwarzanie wyzwalaczy pakietu hicolor-icon-theme (0.15-1)…
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu kmail:
kmail zależy od libkf5akonadisearch-plugins; jednakże:
Pakiet libkf5akonadisearch-plugins:amd64 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu kmail (–configure):
problemy z zależnościami - pozostawianie nieskonfigurowanego
Brak raportu programu apport, ponieważ komunikat błędu wskazuje, że przyczyna niepowodzenia leży w poprzednim błędzie.
Wystąpiły błędy podczas przetwarzania:
libkf5akonadisearch-plugins:amd64
kmail
E: Sub-process /usr/bin/dpkg returned an error code (1)
ikamil@ikamil-MacBookPro:~$

tak to wygląda w terminalu


(FadeMind) #2

sprawdź:

sudo dpkg --configure -a
sudo apt-get -f install


(marcin82) #3

Pakiet kmail nie został poprawnie zainstalowany. Zresztą masz taką informację.

Co pokaże komenda?


(Domker) #4

Możesz spróbować odinstalować “kmail” i “libkf5akonadisearch-plugins”, następnie re-install pakietu “akonadi”, doinstaluj “kf5-kdepimlibs-kio-plugins” i “libkf5akonadisearch-plugins” i spróbuj ponownie zainstalować “kmail”.


(kikamil) #5

/usr/sbin/dpkg-reconfigure: kmail jest uszkodzony, lub nie jest w pełni zainstalowany


(kikamil) #6

nie da się nic zainstalować i odinstalować


(Domker) #7

Spróbuj wymusić usunięcie paczki sprawiającej problem:
sudo dpkg --purge --force-remove-reinstreq NAZWA_PACZKI
Tylko ostrożnie z tym poleceniem, bo to wymusza bezwzględne odinstalowanie paczki i czyści jej pliki konfiguracyjne!!
Po tym wykonaj:
sudo dpkg --configure -a

Rozumię, że zewnętrznych repozytoriów nie dodawałeś ? Być może one są przyczyną problemu.


Nie działa apt znowu
(kikamil) #8

działa dzięki naprawiłeś