SAMBA - problem z udostępnianiem zasobów dla konkretnych użytkowników


(Krotock) #1

Witam!

Mam problem z konfiguracją Samby na swoim Banana Pi (system Bananian 15.04, bazuje na debianie).

Gdy udostępniam foldery publicznie wszystko jest ok, problem pojawia się gdy chcę przydzielić zasób konkretnemu użytkownikowi. Oto fragment pliku konfiguracyjnego:

[global]
 workgroup = smb
 security = share
 share modes = yes
 read raw = yes
 write raw = yes
 netbios name = Pi
 hide dot files = yes
 client code page = 852
 
[homes]
 comment = Home Directories
 browsable = no
 read only = no
 create mode = 0750
 
[Wszystko]
 path = /media/storage/
 browsable = yes
 valid users = pi
 writable = yes
 comment = smb share
 guest ok = no

Chodzi o zasób "Wszystko". Utworzyłem wcześniej użytkownika "pi" poprzez adduser (co chyba nie było konieczne, ale już nieważne :slight_smile: ). Dodałem użytkownika samby przez "samba -a pi" i ustawiłem hasło. Teraz gdy klikam w udostępniony folder wyskakuje okienko logowania, jednak gdy podaję użytkownika "pi" i ustawione hasło wyskakuje błąd, że nie można się zalogować. Pozostałe, publiczne foldery działają poprawnie. Nie mam zbyt dużego doświadczenia w temacie Linuxa, dlatego proszę o pomoc, bo sam chyba nigdy do tego nie dojdę :).


(madoch) #2

W logach sprawdzałeś co jest powoduje błąd ? Myślę, że od tego trzeba by zacząć.


(pocolog) #3

hmmm… wykonaj może

chown pi:pi /media/storage/ -R

edit.

Samba nie reaguje od razu na zmiany, trzeba albo przeładować usługę (sambad) albo odczekać jakiś czas.


(Krotock) #4

Co do logów systemowych to też ciekawa sprawa. W /var/log/samba znajduje się plik log.mójIP, w którym to spodziewałem się logów dotyczących połączenia z moim komputerem, ale jest on pusty. Oprócz tego są jeszcze 2 pliki z logami, ale nie znalazłem w nich nic ciekawego czyt. nie zmieniają się gdy próbuję się zalogować do zasobu. W smb.conf dodałem nawet log level = 10 i nic się w tej kwestii nie zmieniło.

 

Komenda chown również nic nie pomogła.

 

Proszę o dalsze wskazówki, szczególnie jeśli chodzi o te logi, bo mogą być one dla mnie naprawdę przydatne i niepokoi mnie ich brak.


(pocolog) #5

Używanie log level > 3 nie przyniesie pozytywnych skutków, a najwyżej niepotrzebny szum informacyjny. Ustaw poziom 3, skasuj wszystkie logi samby, zresetuj usługę, spróbuj się zalogować jako użytkownik pi z innego komputera, następnie wklej tutaj w tagach < code > co wypluła samba. <- w tej kolejności.


(Krotock) #6

Zalogowałem się z innego komputera i okazało się, że wszystko jest ok, a mój nierestartowany od wielu dni Windows zapamiętał sobie, że nie ma dostępu do zasobu i nawet tego nie weryfikował przy kolejnych próbach logowania… Teraz po restarcie już wszystko działa poprawnie.

 

Jednak co do logów… Nie zapisują się żadne informacje o logowaniu, tworzeniu czy usuwaniu plików. Dodałem linijkę:

log file = /var/log/samba-log.%m

Jak rozumiem oznacza ona plik logów “samba-log.adresIP”. Usunąłem jak radziłeś wszystkie pliki logów i w folderze logów samby pojawiły się pliki “log.smbd” i “log.rmbd”, które zawierają bezwartościowe dla mnie informacje i oprócz tego nic. O co może chodzić?


(pocolog) #7

Spróbuj w takim razie ustawić log level na 2. U mnie na tym poziomie wypisuje logi dla każdego IP. Pamiętam że kiedy stawiałem sambe to też miałem jakieś czary z niektórymi poziomami.


(madoch) #8

Dodawałem użytkowników do samby poprzez pdbedit . Poza tym po dodanie usera przez pdbedit trzeba jeszcze było zrobić “enable” i dopiero wtedy można było się zalogować do zasobu.
Może w tym jest problem ?