Serwer [localhost] - Krasnal czy XAMPP?


(Kam) #1

Witam. Na którym serwerze lepiejby chodziło Forum phpBB oraz różne CMS'y ?? Na XAMPPie Forum mi chodziło, a teraz coś sie porombało i nie chce wogóle wejść... No więc, który polecacie ??


(lazikar) #2

Ja używam krasnala i wszystko chodzi jak należy. :smiley:


(Kam) #3

Lazikar - a pomożesz w jego konfiguracji?? :smiley: Bo sciągnąłem go, zainstalowałem i nie wiem co dalej zrobić. Nie ma konkretnej czytelnej instrukcji... Pozdrawiam i plis pomóż :lol:


(lazikar) #4

A dokładnie o co ci chodzi??


(Kam) #5

Po zainstalowaniu go, gdy wpisuję localhost wyskakuje komunikat, że połączenie zostało utracone... Gdy klikam: Kransal Start, w tym czarnym okienku pisze: Note the errors... [dalej nie zdążyłem przeczytać, bo się samo wyłączyło]. Jednym słowem, nie działa :(. Lampka się świeci na czerwono. Jak mam to wszystko ustawić, żeby działało poprawnie??


(lazikar) #6

Po zainstalowaniu nie trzeba nic ustawiać, jedynie zmienić IP aby inni cię widzieli (Musisz mieć zewnętrzne IP inaczej będą cię widzieli tylko w sieci).

Może twoja instalka jest do niczego?? Z tego co pamiętam miałeś jakieś dziwne problemy ze swoim kompem, to moze być przyczyną.

Może zobacz masz tam forum:

:arrow: http://www.krasnal.tk/


(Kam) #7

Ale jak zainstaluję, to pokazuje mi czerwoną lampkę - dlaczego?? I gdzie zmienić to IP?? I na jakie.


(lazikar) #8

Wchodzimy do MENU: USTAWIENIA->httpd.conf i odszukujemy taka linijkę:

ServerName 127.0.0.1

Następnie w miejsce 127.0.0.1 wstawiamy swoje IP, następnie zapisać plik i przerestartowac serwer.

Bo serwer u ciebie nie działa. U mnie po zainstalowaniu pokazało zieloną. Zastanawiam sie czy dopuściłeś mu dostęp do internetu. Firewall zapewne o to pytał. :?


(Kam) #9

No mam Firewalla. Ale co, mam go wyłączyć, czy włączyć??

PS.: co się wpisywało w Start --> uruchom, żeby pokazało moje IP?? :slight_smile:


(lazikar) #10

Nie wyłączyć tylko pozwolić krasnalowi na połączenie z internetem.

Wejdz w panel sterowania i na karcie sieciowej możesz zobaczyć swoje ip. :smiley:


(Kam) #11

OK, teraz jak wpisuję w przeglądarce: localhost, to pokazuje mi się bardzo podobna strona, co na krasnal.tk. W kalalogu c:\usr\krasnal\www\phpBB2\ mam forum i nie mogę go zainstalować. Tzn jaką ścieżkę mam wpisać w przeglądarce, żebym mógł zacząć instalację?? I gdzie jest PhpMyAdmin, żebym mógł wysłać plik .sql

PS.: Czerwona lampka nadal świeci...


(lazikar) #12

No to fajnie że działa. Ta stronka jest identyczna tylko że na twoim kompie. :smiley:

Usuń ten katalog.

Aby zainstalować forum musisz najpierw utworzyć konto> Wejdz:

Ustawienia>>Konta i tam wpisz nazwę konta np.forum. Konto zostanie utworzone w C:\usr\krasnal\www i tam skopiuj pliki i zainstaluj forum jak na innym serwerze to robiłeś. Adres będzie wtedy (jeżeli konto ma nazwe forum) http://(Twoje IP)/~forum/

PhpMyAdmin jest WWW>>phpMyadmin

Domyślne ustawienia dostępu do phpMyAdmin:

UŻYTKOWNIK: root

HASŁO: krasnal :smiley:

Możesz zainstalować sobie: Forum by przemo; Php Nuke 6.5; IBP 1.3 final; Jportal 2.2.1; Mambo; Geklog w jednej instalce.

:arrow: Krasnal Pack 1.9 5mb


(Kam) #13

Nie ma tam tego. Jest tylko: localhost nic więcej


(lazikar) #14

Kliknij prawym przyciskiem na piórku (Ikonka w tray) :smiley: www>>phpMyadmin Musi to tam być jak poprosi o Longin i hało to wpisz te co podąłem wyżej. :smiley:


(Kam) #15

Yyy... zostaję na XAMPPie :stuck_out_tongue:


(lazikar) #16

To trzeba było tak odrazu. :smiley:


(Kam) #17

No wiesz, gdybym wiedział, że nie poszło by tak "gładziutko" jak na XAMPPie, to bym Krasnala nawet nie ruszał :-D. Nara