Serwery dns


(adrian218) #1

Witam , mam takie pytanie jeśli posiadam serwer , postawiony na debianie. I mam zamiar stworzyć serwer dns to potrzebuje bind9. Tylko że serwer jest podpięty do rutera , a na routerze są odblokowane porty i to działa. Tylko że w bindzie dostane jeden serwer dns a potrzebne są 2 mógłby mnie ktoś nakierować jak to ugryźć ?


(bachus) #2

Nadal nie rozumiem pytania… W czym jest dokładnie problem? Chodzi Ci o forwardery? Z jakim problemem konfiguracji masz problem?


(adrian218) #3

A mam problem z tym że gdy mam zamiar podpiąć swoją domenę musze podać:
ns1.domena.pl
ns2.domena.pl
A bind da mi jeden adres dns dobrze myślę ? A z drugim co nie mogę tego rozgryźć , uczę się dopiero administracji dlatego próbuje, dowiedzieć się od kogoś kto się bardziej na tym zna.


(roobal) #4

Nie potrzebujesz dwóch ns (name serverów). U rejestratora domeny wskazujesz jeden i tyle. ns1 i ns2 znaczy tyle, że jeden jest podstawowym serwerem DNS, drugi rezerwowym.

Pamiętaj też, że rejestrator domeny w swoim panelu musi umożliwić Ci dodanie glue record. Bez tego będziesz musiał mieć osobną domenę na ns1 i ns2.


(roobal) #5

To nawet nie chodzi o to, że potrzebujesz 2 serwery, a 2 publiczne adresy IP. DNSów możesz mieć nawet 20, ale jeśli masz tylko jedno IP, to nic z tym nie zrobisz.


(Fizyda) #6

Zawsze można ustawić ns1 i ns2 na ten sam adres ;). Zresztą czy będziesz miał dwa IP przypisane do jednego serwera czy jedno ip na ns1 i ns2 niczym nie będzie się to różniło. Jedynie w przypadku jakiś dnschecków nie będą one sugerowały błędu w konfiguracji domeny bo zwyczajnie nie będą jej widziałem - pomimo iż będzie ona nadal występowała.
Czasami też zdarza się tak, że rejestrator domeny nie pozwala na ustawienie mniej niż 2 ns dla domeny.

Ogólnie sensem jest posiadanie dwóch serwerów NS (redundancja), a jeśli finanse na to nie pozwalają to można ustawić ns1 i ns2 na ten sam IP, no chyba, że i tak mamy dwa publiczne adresy. Nie ma sensu wykupować specjalnie adresu IP by nie mieć błędu w dnscheckach bo to tylko będzie działało jak efekt placebo.


(adrian218) #7

No dobra a jeśli w serwer jest u mnie , własny , jest system debian , tak to nie da się tego jakość oszukać i i dodać w intrefaces eth1 np na static daj drugi adres ip z zakresu 192.168.x.x , to czy wtedy dało by się to obejść nie mając 2 publicznych ip ?


(Fizyda) #8

Przecież Ci napisałem, jak obejść nie mając dwóch publicznych, dla ns1 i ns2 ustawiasz ten sam adres.


(bachus) #9

Tak z innej beczki - skąd masz internety? Masz stałe IP?


(adrian218) #10

Tak mam stałe ip czyli podaje adres ip 192.168.X.X bo on w ustawieniach routera dostaje wyjście na świat ?


(Fizyda) #11

Nie bo to jest prywatny adres IP, chyba że stawiasz dns dla intranetu.


(adrian218) #12

Dobra walczę z tym rozumiem że podaje w bindzie adres zewnętrzny , tylko teraz walczę z konfiguracją
/etc/bind/named.conf.options

przy próbie reload dostaje:

lut 10 13:12:05 adserv named[19044]: using up to 4096 sockets
lut 10 13:12:05 adserv named[19044]: loading configuration from '/etc/bind/named.conf’
lut 10 13:12:05 adserv named[19044]: /etc/bind/named.conf.options:11: ‘{’ expected near 'any’
lut 10 13:12:05 adserv named[19044]: loading configuration: unexpected token
lut 10 13:12:05 adserv systemd[1]: bind9.service: Main process exited, code=exited, status=1/FAILURE
lut 10 13:12:05 adserv rndc[19049]: rndc: connect failed: 127.0.0.1#953: connection refused
lut 10 13:12:05 adserv systemd[1]: bind9.service: Control process exited, code=exited status=1
lut 10 13:12:05 adserv systemd[1]: bind9.service: Unit entered failed state.
lut 10 13:12:05 adserv systemd[1]: bind9.service: Failed with result ‘exit-code’.
lut 10 13:12:27 adserv systemd[1]: bind9.service: Unit cannot be reloaded because it is inactive.

Rozumiem, że błąd siedzi gdzieś w tym pliku :

loading configuration from ‘/etc/bind/named.conf’

A zawartość tego pliku to:

options {
version “adserv”;
directory “/var/cache/bind”;

forwarders {
193.239.124.100;
193.239.124.200;
};

auth-nxdomain no;
listen-on any;
};


(Fizyda) #13

binda konfigurujesz by nasłuchiwał na interfejs pod który jest podpięty publiczny adres ip. Ja wcześniej mówiłem o konfiguracji domeny.

Po co Ci forwarders?

Źle ustawiłeś wartość dla opcji listen-on, powinno być:

listen-on { any; };

EDIT:
W ogóle jaki serwer stawiasz? Cache DNS dla sieci prywatnej czy NS dla domeny?


(adrian218) #14

Stawiam ns dla domeny lecz mnie to już powoli doprowadza do szału. serwer ma adres 192.168.1.XXX , w routerze są odblokowane porty na ten adres i wtedy po zewnetrznym ip wszystko idzie w świat, tylko nie mogę sobie poradzić z domeną.


(Fizyda) #15

Masz miliony poradników od tego w necie: https://www.digitalocean.com/community/tutorials/how-to-configure-bind-as-a-private-network-dns-server-on-ubuntu-14-04
Pomijasz tylko na primary dns konfigurację dla reverse zone bo tego nie zrobisz, jedynie właściciel IP może tego dokonać oraz nie konfigurujesz secondary dns. Aha no i na primary nie musisz ustawiać zezwolenia dla transferu stref dla secondary dns. Forwarders też sobie możesz odpuścić bo to tylko potrzebne jest jeśli zamierzasz używać serwera jako własny dns, a nie tylko jako ns dla domeny.

Możesz się też posiłkować informacjami: https://wiki.debian.org/Bind9 oraz manualem czy dokumentacją binda.


(adrian218) #16

No dobra czyli w konfiguracji podaje 192.168.x czy juz wtedy adres któy wchodzi w świat ?


(Fizyda) #17

Podajesz ten na który przekierowany jest ruch z internetu.


(adrian218) #18

Niby strefy wygenerowało poprawnie lecz w panelu domeny po podaniu ns1.domena.p ns2.domena.pl dostaje komunikat :
Wystąpił błąd 2004 podczas zmiany serwerów DNS.


(roobal) #19

Generalnie też chciałem to zasugerować. Pytanie tylko czy rejestrator to łyknie :wink:


(roobal) #20

Robisz może coś takiego?

domena.pl -> ns1.domena.pl

Jeśli tak, to bez glue record w zarządzaniu domeną tego nie zrobisz. Musisz mieć osobną domenę, domena1.pl, wowczas ustawiasz.

domena.pl -> ns1.domena1.pl