Sklep Play - aplikacje i dostęp do nich w 2018


(blumberplumber) #1

Witam!
Dzisiaj przeglądając newsy na DP natrafiłem na ten artykuł:


Wzbudził on we mnie trochę niepokój ze względu na starszą wersję Androida (6.0) na mojej Xperii M5. Czy rzeczywiście będzie tak, że za rok nie będę mógł update’ować aplikacji?? Ten niepokój potęguje też fakt, że mam odblokowany bootloader, a co za tym idzie, brak możliwości ew. aktualizacji przez OTA systemu. Ten BL był odblokowany prawdopodobnie przed moim zakupem, bo ja nic nie robiłem.
Powiedzcie mi jak to jest z tymi aktualizacjami? Trzeba będzie często wymieniać telefon? Liczę na szybką odpowiedź, bo mnie to trochę martwi.


(krystian3w) #2

Poszukałbym jak to opisali gdzieś na zagranicznym portalu.

Ale jak to wprowadzą że system zacznie olewać minSdkVersion to nie mam pojęcia (Aktualizacja usług google play i sklepu by to powodowała? Wrzucą to w krytycznych aktualizacjach grudniowych?).


Jak nie jest to przekręcone, to od listopada po prostu nie znajdziemy kompatybilnych mając androida poniżej 8.1, bo będzie to celowo podbite na poziom 27.

A każda nowo dodana aplikacja od sierpnia powinna być kompatybilna od androida 8.1 (a nie niżej np. android 4.1.2+).


(sgj) #3

W oryginalnym tekscie macie wyraźnie napisane że aplikacja ma mieć ustawiony target na aktualną wersję oraz kompatybilność w dół dowoli wg uznania autora aplikacji. Dla posiadaczy starszych smartfonów niczego to nie zmienia. To są 2 osobne ustawienia, stosowane również obecnie w większości aplikacji. W przyszłym roku sklep po prostu nie przyjmie aplikacji z niższym targetem. To jest po prostu wymuszenie pełnej zgodności aplikacji z nową/aktualną wersją systemu z równoczesnym zachowaniem kompatybilności wstecznej.