Skrętka i wifi naprzemian


(Tyczek88) #1

Przedstawię wam moją sprawę mam nadziej w sposób jasny.

Otóż mam 2 PC. Połączone są one ze sobą przez wifi w trybie ad hoc. Służy to głównie do internetu. Również są tam zwykłe karty ethernet, które chciałbym użyć do przesyłania plików ze względu na dużo większy transfer. Mianowicie... czy da się skonfigurować sieć tak, aby internet był z wifi a kiedy będzie potrzeba to podłączę skrętkę i konfiguracja wifi się nie zepsuje?

Próbowałem też połączać osobno, ale za każdym razem trzeba spowrotem konfigurować albo wifi, albo zwykły lan. Jeśli tylko dało by się osobno to czy da się jakoś zautomatyzować konfigurację... np wyeksportować do pliku?


(Mrooveq) #2

na kablu przydziel adresy IP z innej puli adresowej niż na WiFi (np zamiast 192.168.0.x ustaw 172.16.0.x) i nie ustawiaj bramy domyślnej na komputerze z pośrednim internetem przy kablowej karcie sieciowej.

wtedy, żeby mieć pewność co do wybranego medium transferu, łącz się po IP zamiast po nazwie komputera, czyli zamiast z \nazwa_komp_a\udzial, łącz się z \numer.ip.komp.a\udzial.

zautomatyzować konfigurację też się da, podczas udostępniania połączenia internetowego windows sie pyta, czy chcesz utworzyć dysk automatycznej konfiguracji.


(Tyczek88) #3

Jest mały problem. Gdy jest wifi włączone a podłącze kabel to na chwile jest "pobieranie adresu IP" a potem się wyłącza i tak co chwile się na zmiane robi.


(Grzegorz Ch) #4

przydziel adresy IP statycznie (ustaw ręcznie).


(Tyczek88) #5

Więc tak:

Wifi W stacjonarnym komputerze(udostępniającym internet) nadałem adres:

IP:192.168.0.1

maska: 255.255.0.0

brama: 192.168.0.1

Laptop (wifi) nadałem:

IP:192.168.0.2

maska:255.255.0.0

brama:192.168.0.1

dns:192.168.0.1

Poprzez udostępnianie internetu udostępniłem internet tylko na wifi.

Wszystko działa świetnie, internet jest dostępny.

Teraz problem z sieciówkami na skrętkę.

Jak wiecie służyło by to do chwilowego połączenia i przesłania pliku, żeby nie babrać konfiguracji wifi.

Skrętka

Więc mój komputer:

IP:172.16.0.1

maska:255.255.0.0

Laptop:

Ip: 172.16.0.2

maska: 255.255.0.0

Jak podłączam skrętkę to na początku miga co chwile pobieranie adresu ip i się wyłącza. po chwili na lapopie jest napisane, że połączono z zaporą, ale na moim pisze, że kabel jest odłączony.


(Grzegorz Ch) #6

jeśli pisze, że kabel jest odłączony, to rzeczywiście jest jakiś problem z kablem lub wtyczką (coś nie łączy).

jeśli łączysz dwa komputery kablem, bez udziału switcha/huba, to oczywiście stosujesz kabel skrosowany?


(Tyczek88) #7

Tak kabel jest skrosowany. Działa na sto procent, bo nawet zrobiłem połączenie bez udziału wifi i wszystko było dobrze.

EDIT

Udało się :slight_smile: Pomogła zmiana ip 10.0.0.1 na 1 PC i 10.0.0.2 na 2