SLiM, XFCE nie startuje domyślnie


(Marcineez) #1

Nie mam pomysłu co mogło się spsuć. Po wpisaniu danych logowania do SLiMa nie startuje mi XFCE, tylko "pusta" sesja. Programy które maja startować przy uruchamianiu XFCE uruchamiają się, ale nie uruchamia się samo środowisko. Co ciekawe jeśli podczas logowania nacisnę F1 i wybiorę sobie XFCE wszystko uruchomi się normalnie. Problem polega na tym, że XFCE jedyną opcją, ale bez naciśnięcia F1 nie odpali się tylko wystartuje puste coś.

Może ktoś z was ma pomysł co może być przyczyną takiego stanu rzeczy?


(Frankfurterium) #2

Tak trochę na ślepo, bo nie podałeś dystrybucji:

 

W /etc/slim.conf odkomentuj linię sessiondir /usr/share/xsessions/ 

W ~/.xinitrc musisz mieć odkomentowane exec startxfce4


(Marcineez) #3

Debian Jessie x64

 

Jest, a folder /usr/share/xsessions/ zawiera tylko xfce.desktop

Również jest.


(marcin82) #4

Zaloguj się w trybie tekstowym na tty1 i wyczyść konfigurację:

rm -f ~/.cache/sessions/*

rm -rf ~/.config/xfce4

 

Zaloguj się do trybu tekstowego.


(Marcineez) #5

Próbowałem już wcześniej, nie pomogło.

 

Nie sądzę żeby to był problem z samym XFCE, w każdym razie również spróbowałem, bez rezultatu.


(marcin82) #6

Jessie już lata na systemd, wykonałeś takie polecenie po instalacji Slima?

 

su -c "systemctl enable slim"

W przypadku menedżera logowania Slim trzeba jeszcze określić domyślną sesję w pliku:

~/.xinitrc

na przykład dopisać tam taką linię:

exec startxfce4

Wszystkie sesje w systemie znajdziesz w katalogu:

/usr/share/xsessions

(Marcineez) #7

Czy czasem bez tego Slim nie startował by wcale?

 

Jest

 

Pisałem już, jest tu tylko xfce.desktop