[SOLVED] ARCH - Failed to start load kernel modules


(macios4) #1

Przy starcie systemu jakas usługa nie chce się włączyć. System startuje i działa normalnie, ale widać coś jst nie tak:

Przy starcie systemu:

Failed to start load kernel modules



See 'systemctl status systemd-modules-load.service' for details

Potem sprawdzam komende:

16:06[user1@arch ~]$ sudo systemctl status systemd-modules-load.service



[sudo] hasło użytkownika user1: 



● systemd-modules-load.service - Load Kernel Modules



   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)



   Active: failed (Result: exit-code) since śro 2016-11-16 16:05:47 CET; 1min 8s ago



     Docs: man:systemd-modules-load.service(8)



           man:modules-load.d(5)



  Process: 178 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)



 Main PID: 178 (code=exited, status=1/FAILURE)

CO z tym zrobić?


(StrasznyyUnkeL) #2

Po pierwsze pytanie jaka konfiguracja sprzętu i czy nie wysypało się coś ze sterownikiem np grafiki.

Po drugie czy nie jest to czasami błąd na maszynie Wirtualnej ??

Po trzecie po jakiej operacji system się wysypał ?

Po czwarte wskazane było by więcej szczegółów.

Po piąte co pokazuje journalctl ?

Ponieważ po tym co kolega pokazał można co najwyżej wróżyć z fusów


(macios4) #3

Dlatego zwracam się tutaj bo z tych info mało szczegółów.

System zainstalowany już pare lat, wszystko śmiga aż miło, ten błąd jest w sumie od paru miesięcy (pisze teraz bo wszystko działa ale jednak troche to irytuje).

To nie jest na wirtualnej maszynie. system zainstalowany normalnie, jako główny. Jakie szczegóły mam podać, jakie konkretne wyniki poleceń?


(StrasznyyUnkeL) #4

Błędy powinno zwrócić polecenie journalctl oraz polecenie journalctl _PID=178 , fajnie by było jakbyś wkleił co ono zwróciło i tam powinniśmy zobaczyć błędy systemd.


(macios4) #5

PID inny po restarcie, journal widać chyba wyłączone:

18:33[user1@arch ~]$ sudo journalctl

No journal files were found.

-- No entries --

18:33[user1@arch ~]$ sudo journalctl _PID=856

No journal files were found.

-- No entries --

 


(StrasznyyUnkeL) #6

Spróbuj journalctl jako root poprzez su ponieważ często journalctl nic dosłownie nic nie pokazuje jako sudo w dużej części wypadków.


(macios4) #7

Nie działa z roota, wynik taki sam jak wyżej

Nie wiem czy ma coś współnego z tym to, że wyłączyłem księgowanie ext4 w /etc/fstab:

/dev/sda1 / ext4 rw,noatime,discard,data=ordered,commit=300	0 1

 


(K2o) #8

Miałem u siebie ten sam komunikat na Mincie 17.3 KDE. Powstał po ręcznym zainstalowaniu spoza

repozytorium jądra Linuksa 4.8.0-040800. Po powrocie na jądro 4.4.0-47 ten komunikat zniknął.


(dragon321) #9

Te opcje nie służą do wyłączenia księgowania.


(macios4) #10

Arch, jako że rolling-release nie bardzo można zrobić downgroad kernela tym bardziej na starszą wersję. To więc wina kernela? Musi być jakiś sposób żeby to naprawić.


(Frankfurterium) #11

 

https://www.archlinux.org/packages/?name=linux-lts


(K2o) #12

Też miałem problem z usunięciem tego kernela. Nie można tego zrobić przez Menedżer aktualizacji. Poradziłem sobie w ten sposób, że najpierw zainstalowałem starszą wersję, a następnie za pomocą Menedżera Pakietów Synaptic usunęłam wszystkie pakiety, gdzie miałem wpis 4.8.0-040800. potem restart systemu i ten starszy kernel zainstalowany wcześniej sam się załadował.

Od razu zaznaczam, że moją zabawę z Linuksem dopiero zaczynam. Nie biorę odpowiedzialności, jak coś pójdzie nie tak.


(saturno) #13

Zła kolejność.

  1. Doinstalować dodatkowy kernel.

  2. Uruchomić ponownie komputer wybierając na starcie kernel który ma zostać.

  3. odinstalować nie potrzebny kernel.

 

Ogólnie chodzi o to żeby nie odinstalowywać kernela który jest aktualnie w użyciu!


(K2o) #14

W jaki sposób na starcie wybiera się dany kernel?

Mój sposób też zadziałał. Wszystko działa, jak należy. Tak przynajmniej się wydaje.

 

Ok. Już wszystko wiem. Podczas uruchamiania wchodzę w opcje zaawansowane i tam jest wybór kernela.

Dzięki.


(macios4) #15

linux-lts i linux-lts-headers zainstalowane (wer 4.4.31-1), dodatkowo mkinicpio -p linux , restart na tym kernelu ale błąd nadal, tak samo jak dotychczas. To jednak nie wina kernela.


(K2o) #16

Rozumiem, że zainstalowałeś zalecane jądro?


(macios4) #17

tak, zainstalowałem linux-lts (i headers), uruchomiłem system z tego kernela i dalej ten sam błąd.


(K2o) #18

Po naszemu przetłumaczone przez Google;

 

„Nie udało się uruchomić moduły jądra obciążenia 
Patrz 'systemctl statusu Systemd-modules-ładunek. Usługa 'o szczegóły"

 

Na tej stronie znalazłem ciekawy artykuł na temat modułów.

 

http://www.ubucentrum.net/2009/06/wyaczanie-adowania-zbednych-moduow.html

 

Teoretycznie należy go zlokalizować i wyłączyć, raczej jest zbędny, skoro moduł nie działa, a system chodzi prawidłowo, ale to czysta teoria.


(macios4) #19

No dobrze, ale jak go własnie zlokalizować? jak sprawdzić który to moduł??


(Domker) #20

Ja bym po prostu zrobił:

sudo systemctl disable systemd-modules-load.service

… skoro i tak nie działa