[solved] Ostatni div przesuwa się trochę niżej


(baton1) #1

Witam,

mam pewien problem :slight_smile:

Po dłuższej przerwie postanowiłem zrobić jedną stronę i znalazłem bardzo funkcjonalny/schludnie wyglądający framework http://www.designinfluences.com/fluid960gs/.

Wszystko ładnie już szło, ale w pewnym momencie zauważyłem że ostatni floatujący div jest odrobinę niżej od pozostałych. Nie wiem w którym dokładnie momencie się to stało, także nie jestem wstanie wyśledzić które zmiany mogły to spowodować, jednak cssów w ogóle nie ruszałem.

Kod strony przeszukałem już parokrotnie i też nic nie znalazłem.

Przypuszczam że problem jest prosty i powszechny, ale sam w Google nie mogę nic znaleźć, tak więc proszę o pomoc :slight_smile:

A tutaj testowy adres strony: http://qw12qw.net63.net/index.php


(Grzesie K) #2

Zmiana do grid.css linia 163

.container_16 .grid_10 {

width: 59%;

}

(baton1) #3

Po części działa jednak powoduje, że strona nie trzyma sie layoutu (prawy brzeg nie jest taki sam dla header jak dla contentu).

Na tych samych css-ach wersja nie przerobiona (jak w linku do frameworka) działa dobrze, a tak jak mówiłem stylów wcale nie ruszałem.


(Drobok) #4

Framework != CMS :stuck_out_tongue:

Między gridami masz spacjowe treści, nie wiem gdzie to dodałeś, ale poszukaj ich, jak je wywalisz to będzie ok :stuck_out_tongue:


(baton1) #5

Wiem, że to nie CMS, podwozie dobuduje później, najpierw chciałem ogarnąć wygląd, tym bardziej że początkowo ma działać jako prosta strona, bez działającego nawet logowania.

Spacji już szukałem i żadnych nie znalazłem...


(Grzesie K) #6

UP: Szczególnie, że to nawet nie jest CMS :wink:


(baton1) #7

Sprawa się rozwiązała, chociaż pomysł na to wpadł mi nie wiem w jaki sposób :slight_smile:

pliki z css-ami jako że były z frameworka były kodowane w ASCI, a pliki php które ja stworzyłem z zawartością strony kodowałem już w UTF-8.

po przekonwertowaniu wszystkich plików (dla pewności na UTF-8 bez BOM) div ustawił się tak jak powinien :slight_smile: