[SOLVED] Windows 10 vs. Ubuntu 15.04 - bootowanie


(raanst) #1

Witam. 

Wczoraj postawiłem sobie na Lenovo G510 Ubuntu 15.04 obok Windowsa 10 i mam problemy z bootowaniem.

Jeżeli wybieram w biosie bootowanie Legacy First to wyskakuje mi GRUB, jednak podczas próby uruchomienia z niego Windows 10 wyskakuje mi taki komunikat:

5618dc972b553_20151009_2318261.thumb.jpg

i mogę jedynie z GRUB włączyć Ubuntu. Natomiast jeżeli wybieram w BIOS opcję "UEFI First" to wtedy normalnie startuje Windows, jednak nie mam opcji dostępu do Ubuntu.

Czy jest jakiś pomysł by rozwiązać ten problem? Chciałem sobie potestować na nowo Ubuntu, bo Windows niestety z dnia na dzień robi się coraz bardziej mułowaty...


(Jusko) #2

Mnie od czasu laptopa z UEFI - Windows 8/10, nie potrafił wystartować z poziomu GRUB (błąd a’la jak Twój).

Wielu łapie się na tym, że wskakując na UEFI, mają problem aby odnaleźć się w bootowaniu systemów. Polecam zawsze zaprzyjaźnić się z biosowymi opcjami Boot Order, zamiennie Boot Menu (jeśli jest dostępne, chodzi o wybór systemu na etapie loga producenta, zazwyczaj pod którymś z klawiszy F).


(GamerPL) #3

Nic dziwnego że w uefi się nie odczytuje grub skoro go tam nie ma ! Włączyłeś instalkę w trybie bios, więc grub nie został zainstalowany w ESP!


(raanst) #4

Powiedzmy że rozumiem, ale czy:

  • da się jakoś zmienić zapis w GRUB by przekierowywało odpowiednio?

  • czy może lepiej postawić Ubuntu od nowa uruchamiając pendrive przez EFI?


(nintyfan) #5

W moim odczuciu, to musisz zainstalować tylko odpowiedni pakiet i wykonać odpowiednią komendę w terminalu(grub2-mkconfig > /boot/grub2/grub.cfg).


(GamerPL) #6

@nintyfan w ubuntu jest to uproszczone i tylko “update-grub” :wink:


(raanst) #7

Czyli wystarczy że wpiszę 

sudo apt-get update grub

i będzie po problemie?


(nintyfan) #8

Czy aby na pewno? Nie trzeba przypadkiem uruchamiać systemu z włączonym UEFI?


(GamerPL) #9

Nie, powinno być

“sudo update-grub” 


(raanst) #10

No cóż, wykonałem 

sudo update-grub

i niestety nadal to samo. Myślę że chyba nie obędzie się bez reinstalacji, tylko że odpalę instalację pod EFI i powinno być okay :wink:


(nintyfan) #11

Zamiast reinstalować, to odpal Live CD z opcją EFI, następnie chrootuj się do zainstalowanego systemu i wykonaj update-grub.


(GamerPL) #12

@nintyfan Aktualizujesz tylko konfigurację gruba zamiast go zainstalować. 

Tutaj jest opisana instalacja Grub 2

https://wiki.archlinux.org/index.php/GRUB#Installation_2


(-Łukasz-) #13

Jeżeli to świeżo instalowany system, to chyba jednak polecałbym wyczyścić i zrobić instalację na nowo - mniej zachodu, chyba, że chciałbyś się czegoś nowego nauczyć.

Ubuntu w przeciwieństwie do systemów z rodziny Microsoft Windows stawia się zdecydowanie szybciej, bo wszystkie najpotrzebniejsze programy, kodeki czy sterowniki już są na starcie.


(raanst) #14

Szczerze powiedziawszy to mam ochotę całkowicie zastąpić Windowsa Ubuntu ale jeszcze mam małe obawy co do działania i ciągle go testuję ze względu na stabilność :wink:

EDIT:

Udało mi się naprawić to! Wystarczy uruchomić system z pendrive (w trybie LiveCD) i zastosować się do tego:

http://linux-nie-gryzie.blogspot.com/2013/05/ubuntu-1304-i-windows-8-jak-pokonac-uefi.html

 

Problem rozwiązany, dziekuję wszystkim :slight_smile:

 


(dragonn) #15

Dla informacji update-grub tylko aktualizuje jeden plik /boot/grub/grub.cfg nie powoduje to zmiany gruba BIOS-owego na EFI w żadnym przypadku, trzeba zrobić kompletny reinstall gruba, inaczej nie da rady.