Splash image dla gruba


(matiit) #1

Dodaję odpowienią linijkę do menu.lst

#Splash Image

splashimage=(sd1,4)/boot/grub/36909-soft-tux.xpm.gz

System jest na /dev/sdb5 wynik ls /boot

[mat@xmat ~]$ ls /boot/grub/

36909-soft-tux.xpm.gz ffs_stage1_5 minix_stage1_5 vstafs_stage1_5

default iso9660_stage1_5 reiserfs_stage1_5 xfs_stage1_5

device.map jfs_stage1_5 stage1

e2fs_stage1_5 menu.lst stage2

fat_stage1_5 menu.lst.pacnew ufs2_stage1_5

[mat@xmat ~]$

Nie działa splash:/

Teraz niech ktoś mi wyjaśni dlaczego.


(Kostrzewa83) #2

co znaczy ze nie dziala? co sie pojawia?


(roobal) #3

Ponieważ masz wrzuconą do tego folderu paczkę z obrazem, rozpakuj paczkę gz i wrzuć sam obraz xpm a na pewno zadziała, wiem bo tak robiłem i tak u mnie działa. Musi to wyglądać tak:

#Splash Image

splashimage=(sd1,4)/boot/grub/36909-soft-tux.xpm

Oczywiście ten obrazek będziesz miał tylko na liście GRUBa :slight_smile:

Pozdrawiam!


(Kostrzewa83) #4

nie trzeba nic rozpakowywac


(roobal) #5

Tylko dziwne, że u mnie obraz zadziałał dopiero po rozpakowaniu :slight_smile:

Pozdrawiam!


(matiit) #6

sphinx

Pojawia się czarno-biały grub


(roobal) #7

A próbowałeś mojego sposobu ??

Pozdrawiam!


(Kostrzewa83) #8

masz zly wpis w menu.lst, powinno byc (hd1,4) mimo, ze to sdb


(matiit) #9

Nie działa ani przy hd ani przy rozpakowaniu obrazka :confused:


(Kostrzewa83) #10

pokaz caly menu.lst


(matiit) #11

OK poradziłem sobie.

Trzeba było zainstalować pakiet grub-gfx i wydać polecenie grub-install /dev/sdb (wcześniej używałem sda (bo mam w MBR))