Sprawdzanie spójności danych na dysku przy starcie systemu


(scripter) #1

Witam

Problem wiele razy poruszany jednak przeczesując internet (w tym także forum DP) znalazłem wiele rozwiązań, które nie pomagają.

Sytuacja wygląda tak:

Przy każdym uruchomieniu systemu włącza się sprawdzanie spujności danych na dysku F. Stało się to po tym jak nie zdążyłem podpiąć notebooka do zasilania i po prostu się wyłączył.

Poniżej przedstawie jakich prób dokonywałem i które nie pomogły (ps. mój OS to Windows XP z systemem plików NTFS)

  1. Pozwoliłem na przepowadzenie sprawdzania spójności do końca

  2. przeprowadziłem pełne skanowanie chkdsk wraz z naprawą błędów (z poziomu "Mój komputer")

  3. Przeskanowałem system programem antywirusowym i antyspyware

  4. Przeczyściłem rejestr

  5. Przeczyściłem cache

  6. Zdefragmentowałem dysk

Dodam, że:

* nie mam zaplanowanych żadnych zadań w harmonogramie

* chkdsk nie wykazał żadnych błędów na dysku

* w rejestrze wartość SFC w kluczu:

jest ustawiona na 0

* w rejestrze wartość BootExecute w kluczu:

zawiera:

ps. PDboot.exe to jest od Perfect Disk więc nie w tym problem

* dysk jest całkowicie sprawny, notebook ma pół roku

Proszę o jakieś instrukcję aby rozwiązać ten problem


(Anocs) #2

Proponuję użyć doskonałego narzędzia firmy SysInternals (teraz to już jest Microsoft :? ) zwanego "autoruns".

Tam w zakładce "Boot Execute" będzie to co się uruchamia podczas startu OS.


(scripter) #3

Anocs , jest to co wyżej wyszukałem w rejestrze, ta fonkcja pokazuje ścieżkę do BootExecute

czyli HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager i zawiera:


(Kolmar) #4
Windows Registry Editor Version 5.00


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]

"AutoChkTimeOut"=dword:0000000


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]

"BootExecute"=hex(7):61,00,75,00,74,00,6f,00,63,00,68,00,65,00,63,00,6b,00,20,\

00,61,00,75,00,74,00,6f,00,63,00,68,00,6b,00,20,00,2a,00,00,00,00,00


[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]

"SFCScan"=dword:00000000


[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\cleanuppath]

@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\

00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,63,00,6c,00,\

65,00,61,00,6e,00,6d,00,67,00,72,00,2e,00,65,00,78,00,65,00,20,00,2f,00,44,\

00,20,00,25,00,63,00,00,00

Wklejasz do notatnika, zapisujesz z rozszerzeniem REG i dodajesz do rejestru.


(scripter) #5

rokko , nie pomogło. chkdsk nadal uruchamia się ze startem (w trzech krokach) a teraz dodatkowo podczas chkdsk jest napis, że wolumin zawiera błędy

Pomóżcie bo już nie wiem co robić


(Kolmar) #6

Jedyną rzecz jaką mogę jeszcze poradzić to ponowną naprawę, w konsoli odzyskiwania wpisz:

chkdsk /f /r


(Leon$) #7

W wierszu poleceń wpisz fsutil dirty query F:

następnie

Wpisz w wierszu poleceń chkdsk F: /f

Po uruchomieniu polecenia może się pojawić: " Program CHKDSK nie może działać, ponieważ wolumin jest używany przez inny proces.Można uruchomić program CHKDSK po uprzedniej dezinstalacji woluminu.Czy chcesz wymusić dezinstalacje tego woluminu?(T/N) wpisz T

:slight_smile:


(scripter) #8

Więc tak, wykonałem następujące czynności:

dodałem najpierw do rejestru wartość:

Windows Registry Editor Version 5.00


[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]

"SFCScan"=dword:0000000


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]

"AutoChkTimeOut"=dword:0000000


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]

"BootExecute"=hex(7):00,00

następnie od razu dodałem wartość:

Windows Registry Editor Version 5.00


[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]

"SFCScan"=dword:0000001


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]

"AutoChkTimeOut"=dword:0000000a

...czyli krótko mówiąc, wyłączyłem i włączyłem wartości związane z chkdsk

od tej chwili chkdsk nie uruchamiał się ze startem ale pojawił się kolejny problem: ochrona plików systemu windows

2d6343e520cafb30.jpg

powyższy komunikat pojawiał się po każdym uruchomieniu systemu, nie pomogła płyta z XP ani komenda sfc /scannow.

Użyłem więc komendy sfc /revert i pomogło, problem zniknął a system poprawnie się uruchamia, także jeśli ktoś miałby uciążliwy problem z chkdsk i sprawdzaniem ochrony plików to może zastosować się do powyższych sposobów.

Dzięki wszystkim za pomoc