SQL Server 2008 R2 Management Studio Express nie loguje się lokalnie


(Sebastianhalaczkiewicz) #1

Mam problem z ww oprogramowaniem. Chcę zalogować się do niego lokalnie, ale nie da rady. Wyświetla się błąd połączenia z serwerem, ale chcę zalogować się lokalnie, więc serwerem jest mój komputer. Wersja oprogramowania: x64, wersja systemu: Win 8.1 x64

___________________________________________________________________________________________

Proszę zapoznać się z regulaminem, a szczególnie z fragmentem dotyczącym maksymalnych rozmiarów grafik wklejanych do posta.

Pozdrawiam,

Dimatheus


(Shaamaan) #2

A jak nazwałeś instancję podczas instalacji?

Z tego co kojarzę, (local) działa tylko jeżeli zrobiłeś instalację domyślną, bez nazywania instancji.

Jak rozwiniesz listę ‘Server name’ nie ma tam Twojego serwera?

Jeżeli w liście wyboru serwerów masz pusto, spróbuj zamiast (local) wpisać:

  1. LOCALHOST\nazwa_instancji

  2. LOCALHOST\SQLEXPRESS (o ile dobrze pamiętam, to SQLEXPRESS to podpowiadana domyślna nazwa instancji)

ewentualnie

  1. LOCALHOST

 

daj znać, czy poszło


(Sebastianhalaczkiewicz) #3

Jak rozwinę listę mam tylko to:


(Shaamaan) #4

Instancja to w uproszczeniu konkretna (zazwyczaj nazwana) instalacja SQL Serwera. Możesz mieć na jednym komputerze (serwerze) kilka instancji - będą to niezależne byty obsługiwane przez osobne procesy.

 

W takim razie zacznij od sprawdzenia, czy jest włączony dostęp po TCP/IP dla SQL Server.

Uruchom: Menu Start -> MS SQL Server -> Configuration Tools -> SQL Server Configuration Manager

W lewej cześci okna wskaż: SQL Server Network Configuration -> Protocols for <tu będzie nazwa instancji>

W prawej części okna sprawdź, czy TCP/IP ma status Enabled. Jeżeli nie, uaktywnij ten protokół i wtedy sprawdź (nie jestem pewien, czy nie będzie potrzebne ponowne uruchomienie).

Jeżeli nadal będzie ten sam efekt, to z tej rozwijanej listy wybierz <Browse for more…> i pozwól mu wyszukać instancje


(Sebastianhalaczkiewicz) #5

Żadnych protokołów mi nie wyświetla


(Shaamaan) #6

Hmmm… dziwne. Powinno być przynajmniej Shared memory i Named pipes.

Sprawdzałeś w gałęzi 32bit ? Może jednak wersję 32bitową zainstalowałeś.

Jeżeli tam też jest pusto, to wg mnie coś poszło nie tak z instalacją.

Próbowałeś wybrać <Browse for more…> ? Znalazł cokolwiek? (przy pustych protokołach nie spodziewam się, ale sprawdziłbym to)


(Sebastianhalaczkiewicz) #7

Wszystkie gałęzie były puste. Usunąłem 2008 i zainstalowałem 2012. Teraz wszystko działa. Dzięki, temat można zamknąć.