Średnia wartość z każdego miesiąca w Excelu


(Qmmate) #1

Witam,

potrzebuję zautomatyzować liczenie w Excelu średniej wartości z danego miesiąca. Muszę policzyć średnie ciśnienie atmosferyczne w każdym z 240-stu miesięcy z dwudziestu lat, i nie chcę tego robić na piechotę, tylko jakoś zautomatyzować. Proszę o radę, jaką funkcję (formułę), za pomocą której to zrobię. Mam Excel 2003. Załączam plik, w którym pracuję.

http://chomikuj.pl/ehhe/Dokumenty


(Tomek Matz) #2

Najpierw zamień cyfry rzymskie na arabskie, czyli zamiast tego I, II, itd. zrób 1, 2, itd. Oznaczenia miesięcy, które stosujesz w tabeli z danymi, mają się zgadzać z oznaczeniami miesięcy w tabeli z wynikami. Następnie sprawdź, czy ta formuła zadziała (wklej ją w komórce I3 i później poprzeciągaj na wszystkie strony):

=SUMA.ILOCZYNÓW(($B$2:$B$7286=I$2)*($A$2:$A$7286=$H3)*($D$2:$D$7286))/SUMA.ILOCZYNÓW(($B$2:$B$7286=I$2)*($A$2:$A$7286=$H3))

Formułę tą utworzyłem w oparciu o informacje z tego linku http://www.bygsoftware.com/Excel/functions/sumproduct.htm. W Excel 2007 ten sam problem można rozwiązać prościej poprzez zastosowanie formuły ŚREDNIA.WARUNKÓW.


(Tobiasz01) #3
=ŚREDNIA.WARUNKÓW($D:$D;$B:$B;I$1;$A:$A;$H3)

nad rzymskimi liczbami miesięcy napisz arabskie i wstaw tą formułę w pierwsze pole odpowiadające za I 1991 i przeciągnij w pozostałe.


(Qmmate) #4

Dzięki za odpowiedzi, ale w końcu poradziłem sobie inaczej. Połączyłem kolumny z rokiem i z miesiącem w jedną kolumnę i użyłem funkcji:

=SUMA.JEŻELI(A2:A7286;199101;C2:C7286)

gdzie 199101 oznacza rok 1991 styczeń. Dzięki temu miałem sumę ciśnień ze wszystkich dni, teraz tę sumę wystarczyło podzielić przez liczbę dni w danym miesiącu (do tego zrobiłem kolejną tabelkę) i już miałem średnie wartości dla każdego miesiąca z 20-stu lat.