SSL contra WordPress, kłódeczka tylko po stronie administracji bloga


(Emigrant Sebastian) #1

Kłaniam się.

Postaram się opisać problem najbardziej zwięźle jak tylko według mnie można.
Mam wykupione konto hostingowe w https://www.unlimitedwebhosting.co.uk/, chmura, dostęp przez Plesk. Do konta tego mam podpięte dwie domeny. W poddomenie jednej z nich zainstalowałem kilka lat temu bloga WordPress. Było cudnie bez problemów do momentu, gdy uznano że Google ma rację a Chrome jest najpiękniejsza. SSL. Odkryłem że Chrome nie chce wyświetlać mojego bloga gdyż ten jest rzekomo niebezpieczny!!! Udałem się na https://www.sslforfree.com/, zrobiłem jak radzą. Po stronie administracji Plesk też nie napotkałem żadnych problemów. Podobny certyfikat zainstalowałem dla innej poddomeny, też poszło gładko i przyjemnie.

PROBLEM:
Moje przeglądarki Opera, Edge i FF, zgodnie twierdzą że kłódeczka mojemu blogowi się nie należy, oto adres https://sebastian.michael-studio.net/. Podejrzewam że Chrome idzie dalej w zaparte i standardowo raczej nie chce wyświetlić bloga. Jednakże po zalogowaniu do mojego WordPressa (kokpitu :slight_smile:) okazuje się że kłódeczka jest, co przynajmniej mi sugeruje, że certyfikat SSL zainstalowałem prawidłowo.

Nie ma kłódki, niemiła stroma ma jest :frowning:

Wszystko działa jak planowałem, ale tylko po stronie administracji, łaj?!

Bardzo proszę szanowną społeczność o jakiekolwiek wskazówki.


(krystian3w) #2

Jakieś dwie grafiki:

  • ja_ja.jpg

  • smiley-cry.gif

idą po http:

(index):602 Mixed Content: The page at 'https://sebastian.michael-studio.net/' was loaded over HTTPS, but requested an insecure image 'http://sebastian.michael-studio.net/magazyn/ja_ja.jpg'. This content should also be served over HTTPS.
(index):842 Mixed Content: The page at 'https://sebastian.michael-studio.net/' was loaded over HTTPS, but requested an insecure image 'http://sebastian.michael-studio.net/wp-content/plugins/wp-edit/plugins/emoticons/img/smiley-cry.gif'. This content should also be served over HTTPS.

(Emigrant Sebastian) #3

Dzięki :slight_smile:, jednakże :frowning: dobiłeś mnie. Nie mam pojęcia jak to zmienić. Odwołania do tych grafik robi sam WordPress jak się domyślam. Czy w nim szukać rozwiązania?


(Emigrant Sebastian) #4

Wymuszę po stronie hostingu dla tej kontentej poddomeny przekierowania na https niezależnie od wywołania, gdzieś to tam widziałem. Internety to przetrawią w jakies 25 minut i wrócę tutaj by potwierdzić (lub nie) że to pomogło. Dzięki wielkie @krystian3w!


(krystian3w) #5

Najwyżej poproś Fizdę zna lepiej wordpress i może coś skutecznego i wygodnego podpowie.


    Tą twoją miniaturę :alien: można pewnie w kontenerze / komponencie (textwigdet) edytować jak tak masz dodaną i np. tak zapisać:

    <img src="/magazyn/ja_ja.jpg" alt="Ja :-)">
    

    będzie się cofała i powinien wyjść adres:

    https://sebastian.michael-studio.net/magazyn/ja_ja.jpg
    

A co do pluginu to nie mam pojęcia nawet jak to wyszukać.

Hipoteza:

    Może wystarczy sprawdzić czy wtyczka jest aktualna i jakoś odświeżyć stare posty np. jak zastosowali
    podobny sposób do linkowania lub bez protokołu
    - czyli samo //:

     //sebastian.michael-studio.net/wp-content/plugins/wp-edit/plugins/emoticons/img/smiley-cry.gif
    

(Emigrant Sebastian) #6

Odpowiedni plugin do Wordpress kasujący wszelakie http i https z linków, plus ustawienia po stronie hostingu wymuszające https (cośtam 301) i działa :slight_smile:. Nie wnikam które z tych działa bardziej.
Jeszcze raz wielkie dzięki @krystian3w, otworzyłeś mi mózg na szersze pojmowanie tego hatepowego dziadostwa.

PROBLEM ROZWIĄZANY!


(krystian3w) #7

Jeszcze przed starą wersją TLS 1.0 ostrzega whynopadlock.com:

:warning: Protocols You currently have TLSv1 enabled.
This version of TLS is being phased out. This warning won’t break your padlock, however if you run an eCommerce site, PCI requirements state that TLSv1 must be disabled by June 30, 2018.

Jak że to nie strona eCommerce raczej problem na maj-czerwiec 2018 jak to się podzieje z przeglądarkami www.


(Emigrant Sebastian) #8

Po stronie hostingu mogę zaznaczyć/odznaczyć opcję SSL/TLS, jest to jedność. Zapytam hostingodawcę jak on widzi wyłączenie TLS i to konkretnie v1.


(Emigrant Sebastian) #9

@krystian3w otrzymałem odpowiedź że na tą chwilę nie jest to problemem. Jeśli będzie konieczność hostingodawca dostosuje się i wyłączy co trzeba po swojej stronie :smile:.