Sterowniki ATI Catalyst nie chcą działać - Ubuntu 9.10


(Adrian Zawislo) #1

Witam,

Mam następujący problem. Mam problem ze sterownikami grafiki, otóż sterowniki własnościowe nie chcą się w żaden sposób uruchomić. W momencie kiedy w System-Administracja-Sterowniki dam włącz sterowniki własnościowe to po wielokrotnej próbie włączenia nigdy się one nie włączają. Próbowałem pobrać paczkę binarną sterowników i po instalacji także niestety nie uruchamiają się chociaż jak niżej pokażę xorg.conf wygląda tak jakby sterowniki były włączone (na pewno nie są widząc przewijanie ekranu czy chociażby wynik komendy fglrxinfo)

Xorg.conf:

Section "ServerLayout"

	Identifier "aticonfig Layout"

	Screen 0 "aticonfig-Screen[0]-0" 0 0

EndSection


Section "Files"

EndSection


Section "Module"

	Load "glx"

EndSection


Section "Monitor"

	Identifier "aticonfig-Monitor[0]-0"

	Option "VendorName" "ATI Proprietary Driver"

	Option "ModelName" "Generic Autodetecting Monitor"

	Option "DPMS" "true"

EndSection


Section "Device"

	Identifier "aticonfig-Device[0]-0"

	Driver "fglrx"

	Option "UseFastTLS" "1"

	BusID "PCI:1:0:0"

EndSection


Section "Screen"

	Identifier "aticonfig-Screen[0]-0"

	Device "aticonfig-Device[0]-0"

	Monitor "aticonfig-Monitor[0]-0"

	DefaultDepth 24

	SubSection "Display"

		Viewport 0 0

		Depth 24

	EndSubSection

EndSection

Wynik komendy lgrxinfo:

X Error of failed request: BadRequest (invalid request code or no such operation)

  Major opcode of failed request: 156 (GLX)

  Minor opcode of failed request: 19 (X_GLXQueryServerString)

  Serial number of failed request: 14

  Current serial number in output stream: 14

Proszę o pomoc, nigdy nie miałem aż takich problemów z grafiką aż do teraz. Dodam, ze moja karta grafiki to ATI Mobility Radeon HD 3400.

Pozdrawiam.


(roobal) #2

Spróbuj doinstalować sterowniki fglrx z repo:

sudo apt-get install xorg-driver-fglrx fglrx-kernel-source

Pozdrawiam!


(Adrian Zawislo) #3

Tą czynność już wykonałem wcześniej. Nie dało żadnej poprawy. Niestety..


(Kojot) #4

Masz 64-bitowy system?