Sterowniki do AMD GPU pod Ubuntu


(james007) #1

Witam, miałem dłuższą przerwę z pingwinem, ale z racji tego, że całkowicie nie akceptuje tego co się dzieje z Windows 10, postanowiłem wrócić na pingwina. Upodobałem sobie Ubuntu Budgie, postawiłem wersję 16.04, pobrałem sterowniki do R9 380 z strony AMD, zainstalowałem i działa. Jednak nie długo będzie Ubuntu Budgie 18, a na stronie AMD nie ma nawet sterowników do Ubu 17. Coś w necie piszą, że Canonical wypiął się na zamknięte sterowniki i nie będzie ich więcej dla Ubuntu. O co kaman ? Gram w CS:Go i potrzebne mi zamknięte stery, a wiecznie na 16 nie będę siedział. Ktoś kto jest w temacie może wytłumaczyć całą sytuację ?


(Domker) #2

Nie instaluj ze strony producenta tylko z repozytorium.
O ile mi wiadomo to Ubuntu ma nawet preinstalowanego managera sterowników, który sam zaciągnie i zainstaluje odpowiednie sterowniki grafiki.


(james007) #3

Kolega wie mniej niż ja widzę. Ma menadżer sterowników ale są tam tylko sterowniki do nvidii i microcode do CPU Intela. Do AMD Gpu nie ma.


(Domker) #4

Faktycznie nie widzę amdgpu-pro dla Ubuntu 17-stki.
Już dawno Ubuntu nie odpalałem, kiedyś był odpowiedni moduł, który proponował binarne zamknięto źródłowe jak i otwarte dla GPU.

W każdym razie pod Archem w AUR jest. Zarówno dla dkms jak i normalne :wink:


(james007) #5

Czyli pozostaje migracja na Arch lub Manjaro. Miało być tak pięknie … O co chodzi z tymi sterami pod Ubuntu ?


(Razi) #6

Następny LTS to 18.04, do tego czasu 16.04 będzie dobrze wspierany, więc niczym się nie przejmuj.


(james007) #7

18LTS będzie lada moment. Co jest powodem zaistniałej sytuacji Canonical => AMD ?


(Razi) #8

Prawdopodobnie na chwilę obecną chodzi o Waylanda, którego Cannonical chciał przetestować na większą skalę. Z tego co wiem, to 18.04 LTS ma wracać na starego x-servera, więc będzie OK.

Generalnie od 14.04 nie widzę sensu pakowania się w wydania nie-LTS.