Sterowniki do Monitora LG i GF 8600 dla ubuntu 8.04


(smoq5) #1

Witam

Kurcze próbowałem dość długo, szukałem na różnych forach ma jakiś plik ze sterami do GF z rozszerzeniem run ale nie mam pojęcia, z której strony go ugryźć dodatkowo Hoża Hawajka wykrywa mi panoramiczny monitor LG jako standardowy wyświetlacz albo LG 32 i mogę ustawić różne głupie rozdzielczości tylko nie 1440x900 a właśnie takiej bym potrzebował, może ktoś wie jak to poprawnie skonfigurować w tej najnowszej dystrybucji. Pewnie jest to proste ale tak jak mówię z Linuxem mam styczność od dzisiaj a wszelkie metody, które odszukałem w sieci dotyczą starszych dystrybucji ubuntu i na Hożej Hawajce (rozbraja mnie ta nazwa :wink: ) niestety nie działają ;(


(Filip Turek) #2

Instalacja sterów nvidia:

http://www.forum.ubuntu.pl/showpost.php ... stcount=13

Jeżeli po zainstalowaniu sterów nadal nie będziesz mógł wybrać rozdzielczości, to:

viewtopic.php?f=14&t=108066

(też kiedyś miałem podobny problem)


(matiit) #3

Instalujesz sterowniki. (dla ubuntu jest tyle poradników, że ciężko nie znaleźć...pozatym jest tam menedzer sterowników własnościowych)

Jak zainstalujesz to powinieneś mieć program nvidia-settings i w nim będziesz mógł wybrać żądaną rozdzielczość.


(smoq5) #4
nvidia-installer log file '/var/log/nvidia-installer.log'

creation time: Wed Aug 20 10:09:18 2008

installer version: 1.0.7


option status:

  license pre-accepted : false

  update : false

  force update : false

  expert : false

  uninstall : false

  driver info : false

  precompiled interfaces : true

  no ncurses color : false

  query latest version : false

  OpenGL header files : true

  no questions : false

  silent : false

  no recursion : false

  no backup : false

  kernel module only : false

  sanity : false

  add this kernel : false

  no runlevel check : false

  no network : false

  no ABI note : false

  no RPMs : false

  no kernel module : false

  force SELinux : default

  no X server check : false

  no cc version check : false

  force tls : (not specified)

  X install prefix : (not specified)

  X library install path : (not specified)

  X module install path : (not specified)

  OpenGL install prefix : (not specified)

  OpenGL install libdir : (not specified)

  utility install prefix : (not specified)

  utility install libdir : (not specified)

  doc install prefix : (not specified)

  kernel name : (not specified)

  kernel include path : (not specified)

  kernel source path : (not specified)

  kernel output path : (not specified)

  kernel install path : (not specified)

  proc mount point : /proc

  ui : (not specified)

  tmpdir : /tmp

  ftp mirror : ftp://download.nvidia.com

  RPM file list : (not specified)


Using: nvidia-installer ncurses user interface

-> The file '/tmp/.X0-lock' exists and appears to contain the process ID '5284'

   of a runnning X server.

ERROR: You appear to be running an X server; please exit X before installing. 

       For further details, please see the section INSTALLING THE NVIDIA DRIVER

       in the README available on the Linux driver download page at

       http://www.nvidia.com.

ERROR: Installation has failed. Please see the file

       '/var/log/nvidia-installer.log' for details. You may find suggestions

       on fixing installation problems in the README available on the Linux

       driver download page at http://www.nvidia.com.

Coś takiego mi w logu zapisuje i nie mogę zainstalować sterów


(matiit) #5

Zainstaluj z repo... Na google poszukaj.

Masz też menedzera sterowników własnościowych...

Czytałeś jakiś opis jak instalować z .run?

Trzeba wyłączyć Xserver, mieć build-essential, nagłówki kernela.

Xserver wyłączasz poprzez sudo /etc/init.d/gdm stop albo sudo /etc/init.d/xdm stop albo sudo /etc/init.d/kdm stop


(smoq5) #6

Robiłem wszystko tak jak tu:

http://kaka.ovh.org/howto/nvidia_drivers/

Po wpisaniu podanej komendy nic sie nie stało (?)

Listing #6: Uruchomianie instalatora sterowników

sh NVI*

a ta wywołała to co powyżej napisałem


(matiit) #7

A jesteś w trybie tekstowym?

Tylko tekstowym... bez grama grafiki


(smoq5) #8

tak sam tekst


(matiit) #9

Masz wyłączonego xorga i się pokazuje to:

ERROR: You appear to be running an X server; please exit X before installing.

Sory nie wierzę...


(smoq5) #10

Po zalogowaniu ctrl+alt+f1 i komenda

sudo /etc/init.d/gdm stop

i jest potwierdzenie


(matiit) #11

a pokaż

ls -l /etc/init.d

(smoq5) #12

Chwilowo musiał niestety wrócić do starego (niezbyt) dobrego xp, szkoda że są problemy ze sterami dla ubuntu chociaż pewnie w dużej mierze problem wynikł z mojej winy i braku doświadczenia z linuxem niemniej jednak gdy tylko będę miał okazję znów postaram sie zainstalować ubuntu i wtedy pewnie wrócimy do tematu ;p :wink:

matiit mógłbyś wyjaśnic mi do czego służy komenda którą podałeś i jakich wyników powinienem się spodziewać w przyszłości/

Wielkie dzięki za poświęcony czas i wszelką pomoc :slight_smile:

POZDRAWIAM


(matiit) #13

Już mówię -

ls - pokazuje listę plików

-l - przełącznik który dodaje więcej info

/cos/tam - argument mówiący jaki chcemy wylistować katalog

W init.d znajdują skrypty. Chciałem wiedzieć czy zamiast gdm skrypt nie nazywa się np. xdm - jak w Gentoo np


(Soren) #14

Niema żadnych problemów!!

Trzeba było użyć "managera sterowników własnościowych" w menu system->Administracja->Sterowniki

On sam wyszukuje jakei są dostępne zamknięte stery do twojej konfiguracji sprzętowej (w tym wypadku do grafiki nvidii) i wystarczy jeden ptaszek przy nich zaznaczyć, poczekać i restart. Czemu nie posłuchałeś matiita i go nie użyłeś? Przecież ci to zasugerował.


(smoq5) #15

Po instalacji z menadżera nie mogłem ustawić rozdzielczości 1440x900 i monitor wykrywało jako unknow :frowning:


(matiit) #16

To trzeba było odpalić nvidia-settings.


(Soren) #17

Lub ewentualnie doinstalować jeżeli nie zostało dociągnięte jako zależność i po problemie.


(smoq5) #18

Ok jak tylko będę miał możliwość i czas znów postawić ubuntu to spróbuje w ten sposób DZIĘKI WIELKIE