Strona nie przechodzi walidacji


(Barthezz) #1

Witam. Mógłby mi ktoś pomóc przetłumaczyć i naprawić błąd z validatora?

# Warning Line 66, Column 205: cannot generate system identifier for general entity "id"


…-1">Oceń: [-]


✉


An entity reference was found in the document, but there is no reference by that name defined. Often this is caused by misspelling the reference name, unencoded ampersands, or by leaving off the trailing semicolon (;). The most common cause of this error is unencoded ampersands in URLs as described by the WDG in "Ampersands in URLs".


Entity references start with an ampersand (&) and end with a semicolon (;). If you want to use a literal ampersand in your document you must encode it as "&" (even inside URLs!). Be careful to end entity references with a semicolon or your entity reference may get interpreted in connection with the following text. Also keep in mind that named entity references are case-sensitive; &Aelig; and æ are different characters.


If this error appears in some markup generated by PHP's session handling code, this article has explanations and solutions to your problem.


Note that in most documents, errors related to entity references will trigger up to 5 separate messages from the Validator. Usually these will all disappear when the original problem is fixed.

[/code]

Link do validatora: http://validator.w3.org/check?uri=www.t ... ne&group=0


(mario@) #2
href="index.php?kat=1&mm=no"

W linkach zamiast & pisze się &

href="index.php?kat=1&mm=no"

W html nie zamyka się tagu

. Zamiast

.

alt="1" dla linka ?


(Barthezz) #3

Dzięki wielkie, od razu ubyło kilkudziesięciu błędów.

Czym w takim razie mogę zastąpić atrybut alt?

Jest mi coś takiego potrzebne ponieważ skrypt głosowania w ten sposób odwołuje się do tekstów.


(Spam) #4

title


(M@ster) #5

Czy

czy

to zależy czy pisze w HTML czy w XHTML.


(mario@) #6

Dlatego pisze html :stuck_out_tongue: Barthezz w międzyczasie zmienił doctype z html ? na xhtml transitional.