Strona rozjeżdża się pod IE


(dragonn) #1

Muszę zrobić stronkę ale pod ie się rozjeżdża, o ta stronka http://www.dragonn.yoyo.pl/CPolsca/Malbork.html i tak jest w wszystkich innych miastach o to kod strony http://www.wklej.org/id/36604/ a tu kod CSS http://www.wklej.org/id/36607/ co jest nie tak :?: Co zrobić aby strona działa dobrze pod IE :?:

Z góry dzięki za odpowiedzi :smiley: .


(Mireczek) #2

Na początek, spróbuj doprowadzić do takiej sytuacji, żeby na stronie nie było błędów składniowych:

W3C Markup Validation Service

W3C CSS Validation Service

Jak to będzie zrobione, to nawet badz IE wna przeglądarka może zadziałać. :slight_smile:


(dragonn) #3


(MaRa) #4

U mnie pod Operą na MacOSX krzaczą się polskie literki, zmiana standardu nic nie daje (nigdy to się nie zdarzało na polskojęzycznych stronach).

I jaka wersja IE? Bo 6.0 jest już strasznie archaiczna i można sobie darować jej obsługę. Od 2001 roku standardy poszły nieco do przodu :stuck_out_tongue:

Nawet nowa IE7.0 nie bardzo wspiera standardy, a pod wcześniejszymi (IE 5.0, 5.5) niemal żadna strona w internecie już nie wyświetla się poprawnie.

Przystosowanie pod starsze IE najczęściej spowoduje, że w nowszych przeglądarkach będą kłopoty.


(dragonn) #5

Polskie liter już poprawiłem, to samo jest pod IE 7 jak i pod 6.

Tyle to ja też wiem, wystarczy wejść na acid3 test po IE :smiley: .

EDIT

Został mi jeden błąd


(Exorf) #6

chyba chodzi o to, że w tagu

wstawiłeś tablekę.... albo o to że tag nie jest zamknięty.


(dragonn) #7

Strona przeszła oba testy i dalej nie chodzi po IE :frowning:


(Mireczek) #8

Najciekawsze jest to, że za pierwszym razem otwarła mi się dobrze pod IE 7. Wszystkie podstrony. Następne otwarcie powoduje "rozjeżdżanie" się szablonu. Też tak miałem z jedną z moich podstron pod IE, ale teraz nie pamiętam co to było. W wolnej chwili rzucę okiem do kodu strony. Może coś mi zaświta. :slight_smile:

EDIT:

Spróbuj może dać fotografie w jednym wymiarze (np. 390 px x 290 px). Ja tylko zgaduję, bo nie mam teraz czasu, żeby stronę wrzucać na serwer.


(dragonn) #9

Mireczek właśnie u mnie też, jak odświeżałem pod IE kilka razy to zdarzało się że było dobrze :o .


(Mireczek) #10

Może w CSS w znaczniku IMG narzuć wymiary. Trzeba pokombinować. :slight_smile:

Jeśli strona nie ma błędów składniowych, a nie ma bo sprawdzałem, to teraz trzeba kombinować jak ominąć durnotę IE. :frowning:


(troiP) #11

Ja wszedłem i nie widziałem aby się rozjechała. Może flash. Taka strona nadaje się wprost aby ją zrobić we flashu, Żadnych rozjazdów, problemów