Świrujący mplayer przy XGL


(invader92) #1

Witam wsyztkich. Mam dość dziwny problem. Zainstalowałem spowrotem ubuntu 7.04 (wczesniej debian), i naszło mnie na instalajcę compiz fusion. jako że mam trochę nowszą kartę (radeon Xpress 1250) zmuszony jestem do korzystania z zamkniętych sterowników (fglrx) oraz XGL (dla compiza).

Niestety po instalacji XGL gdy otwieram jakikolwiek film za pomocą mplayera to ekran rozciąga się do maksimum na szerokość, coś jakby z rozdzielczośći 800x600 zrobiło zię 2000x800. Na pełnym ekranie dzieje się to samo. Na ubuntu edgy eft wszystko chodziło idealnie, nie miałem żadnych problemów.

Tylko proszę aby nie kierować mnie spowrotem do edgy jeżeli mi na tym zależy.

Czy jest jakieś rozwiązanie tego problemu na fiesty?

dzięki za odpowiedź, pozdrawiam


(matiit) #2

uruchom gmplayer z konsoli

gmplayer

Otwórz film..

inapisz co konsola wypluwa podczas problemu.


(invader92) #3

a więc tak

sam mplayer

invader@lukasz:~$ gmplayer

MPlayer 2:1.0~rc1-0ubuntu9.1 (C) 2000-2006 MPlayer Team

CPU: Intel(R) Core(TM)2 Duo CPU E4500 @ 2.20GHz (Family: 6, Model: 15, Stepping: 13)

CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1

Compiled with runtime CPU detection.

Xlib: extension "XFree86-VidModeExtension" missing on display ":1.0".

Can't open joystick device /dev/input/js0: No such file or directory

Can't init input joystick

mplayer: could not connect to socket

mplayer: No such file or directory

Failed to open LIRC support. You will not be able to use your remote control.

Xlib: extension "XFree86-VidModeExtension" missing on display ":1.0".

zaś teraz mplayer z otwartym filmem (nie wiem czy ma znaczenie ale daje)

invader@lukasz:~$ gmplayer '/media/sda5/Filmy/film_ze_mucha_nie_siada.mpg' 

MPlayer 2:1.0~rc1-0ubuntu9.1 (C) 2000-2006 MPlayer Team

CPU: Intel(R) Core(TM)2 Duo CPU E4500 @ 2.20GHz (Family: 6, Model: 15, Stepping: 13)

CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1

Compiled with runtime CPU detection.

Xlib: extension "XFree86-VidModeExtension" missing on display ":1.0".

Can't open joystick device /dev/input/js0: No such file or directory

Can't init input joystick

mplayer: could not connect to socket

mplayer: No such file or directory

Failed to open LIRC support. You will not be able to use your remote control.

Xlib: extension "XFree86-VidModeExtension" missing on display ":1.0".


Playing /media/sda5/Filmy/film_ze_mucha_nie_siada.mpg.

MPEG-PS file format detected.

VIDEO: MPEG1 384x288 (aspect 8) 25,000 fps 0,0 kbps ( 0,0 kbyte/s)

[gl] using extended formats. Use -vo gl:nomanyfmts if playback fails.

==========================================================================

Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough

VDec: vo config request - 384 x 288 (preferred colorspace: Mpeg PES)

Could not find matching colorspace - retrying with -vf scale...

Opening video filter: [scale]

The selected video_out device is incompatible with this codec.

Try adding the scale filter, e.g. -vf spp,scale instead of -vf spp.

VDecoder init failed :(

Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b

Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))

==========================================================================

==========================================================================

Forced audio codec: mad

Opening audio decoder: [libmad] libmad mpeg audio decoder

AUDIO: 32000 Hz, 2 ch, s16le, 96,0 kbit/9,38% (ratio: 12000->128000)

Selected audio codec: [mad] afm: libmad (libMAD MPEG layer 1-2-3)

==========================================================================

AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)

Starting playback...

VDec: vo config request - 384 x 288 (preferred colorspace: Planar YV12)

Could not find matching colorspace - retrying with -vf scale...

Opening video filter: [scale]

VDec: using Planar YV12 as output csp (no 0)

Movie-Aspect is 1,42:1 - prescaling to correct movie aspect.

SwScaler: using unscaled yuv420p -> rgb32 special converter

VO: [gl] 384x288 => 410x288 BGRA 

Xlib: extension "XFree86-DRI" missing on display ":1.0".

A: 1,8 V: 1,8 A-V: 0,011 ct: 0,056 32/ 32 5% 10% 1,0% 0 0

(matiit) #4

uruchom najpierw sam gmplayer i w konfiguracji zmień wyjście video na xv


(invader92) #5

jak chciałeś, wyjście zmienione na xv bez filmu

invader@lukasz:~$ gmplayer

MPlayer 2:1.0~rc1-0ubuntu9.1 © 2000-2006 MPlayer Team

CPU: Intel® Core2 Duo CPU E4500 @ 2.20GHz (Family: 6, Model: 15, Stepping: 13)

CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1

Compiled with runtime CPU detection.

Xlib: extension "XFree86-VidModeExtension" missing on display ":1.0".

Can't open joystick device /dev/input/js0: No such file or directory

Can't init input joystick

mplayer: could not connect to socket

mplayer: No such file or directory

Failed to open LIRC support. You will not be able to use your remote control.

Xlib: extension "XFree86-VidModeExtension" missing on display ":1.0".


(matiit) #6

hehe no ale odtworz film i zobacz czy pomogło :smiley:


(invader92) #7

bez komentarza. Jakby pomogło to odpisałbym

"dzieki wielkie pomogło"

nie pomogło :smiley:

może napiszę jaśniej: nie pomoglo, dalej mplayer świruje.