Switch blokuje widoczność komputerów w sieci


(szwabek998) #1

Mam sieć w domu:

switch->Laptop (Win10) i “Serwer domowy” (win7; serwer FTP, Media Serwer)
^
|
Router->PC(Win10)

Problem jest następujący:
Laptop nie widzi PC.

Serwer i PC widzą wszystko normalnie (screenshot tylko z serwera bo z PC jest taki sam):
https://scr.hu/0mMJYv
(Na PC nie ma Media Servera więc go nie widać).
Z Serwera i PC mogę się dostać na każde urządzenie w mojej sieci.

Co ciekawe z laptopa ping na PC - jest odpowiedź. Gdy wpisze w pasku adresu \\PC - mogę się na niego dostać - po prostu windows na laptopie nie widzi PC.

Grupa domowa na serwerze działa doskonale, ale na lini laptop-PC i PC laptop już nie:
Komunikat: “Ten komputer jest obecnie niedostępny”

Problem pojawił się po zakupie switcha - aby laptop miał internet po kablu - nie tylko WiFi.
Problem pojawia się tylko na kablu.

I co to jest to tajemnicze coś z pierwszego zdjęcia? - widoczne tylko na laptopie.
Switch: TP-Link TL-SG105

Co ciekawe raz na jakiś czas Laptop widzi PC ale na chwilkę i potem problem znowu się pojawia. Grupa domowa działa cały czas tak samo (jak wyżej).

Gratulacje dla tych, którym chciało się to przeczytać :smiley:


(bachus) #2

Opisz coś więcej:

  • co jest Twoim routerem (model urządzenia),
  • czy stosujesz statyczne IP, czy z DHCP.
    Co do switcha - nie powinno mieć żadnego znaczenia, nie ma on na oko żadnych zaawansowanych funkcji, działa w warstwie drugiej OSI jako “złodziejka” (rozdziela gniazdo). Rozumiem, że wpięty jest (switch) do jakiegoś portu na routerze (nie jest to DMZ?)

(gunter) #3

Połącz switch do routera, a nie odwrotnie to wszyscy będą w tej samej sieci.


(szwabek998) #4

Router: TP-Link TD-W9980.
W sieci wszystkie urządzenia mają statyczne IP.
Nie jest to DMZ, switch wpięty do portu na routerze - brakowało mi jednego kabla do laptopa a ściany kuł nie będę to zakupiłem najtańszy gigabitowy switch ze sklepu w mojej okolicy.

switch jest podłączony do routera - “rysunek” zrobiłem tak bo na klawiaturze nie ma strzłki w dół - jest tylko ^ :wink:

Nie będzie to pomocna informacja ale na “Serwerze” wszystkie usługi korzystające z LAN/ WAN działają poprawnie (Wake on Lan/Wan, VNC, FTP).

EDIT. I kolejna zmiana statusu: z laptopa opuściłem grupę domową i znów dołączyłem - i grupa domowa działa. Postanowiłem też zrestartować router - teraz Serwer też nie widzi PC, ale przez pasek adresu mogę dalej wejść na PC :slight_smile:

Czyli wg. mnie tak jak napisał @bachus switch chyba nie - raczej Windows. Jakieś pomysły?


(bachus) #5

Nie masz w domu nic Dlinka? Nikt nie jest wpięty na lewo do Twojego wifi (DWR-116)?


(szwabek998) #6

Nic od DLinka nie posiadam. Urządzenie pojawiło się po podpięciu switcha. WiFi 2,4 GHz i 5 GHz jest z hasłem i MAC filteringiem. Na routerze brak śladów urządzenia.

EDIT. Odpiąłem switch od zasilania i dziwak dalej tam jest i go nie ma :slight_smile: pojawia się tylko czasami na laptopie. Więc teraz mam dwa problemy - widoczność i ten “obcy” przez swicha. Dodam, że na routerze dla testu wyłączyłem UPnP - ale tam i tak nic nie było: skype i terendo.

EDITv2. Na PC Ten DWR-116 widnieje jako sieć WiFi - pewnie ma go sąsiad - tylko dlaczego windows daje go do mojej sieci?


(bachus) #7

Sąsiad kradnie internet? Zrób skan podsieci na obce urządzenia.