System nie zapamiętuje ustawień rozdzielczości


(greh) #1

Witam.

Mam mały problemik. Zainstalowałem opublikowaną niedawno wersję stabilną systemu PinguyOS 12.04 LTS.

Otóż problem jest taki. Mam zainstalowane sterowniki własnościowe NVidii i w ustawieniach owych driverów zmieniłem rozdzielczość, na taką, jaka mi pasuje, czyli 1152x864 piksele. Zapisuje do pliku /etc/X11/xorg.conf, lecz po ponownym uruchomieniu komputera na przykład na drugi dzień rozdzielczość jest taka, jak domyślnie, czyli 1024x768 pikseli. Czemu tak się dzieje? Zawsze pamiętało ustawienia.

Screen dodatkowych sterowników:

http://img171.imageshack.us/img171/3325 ... iki007.png


#2

Zapisz xorg.conf:

Otwieramy panel NVIDIA X Server Settings > X Server Display Configuration > Save to X Configuration File.


(greh) #3

Chyba niedokładnie przeczytałeś mój wpis gdyż napisałem, że ów plik zapisuję. :wink:


(Frankfurterium) #4

Zapis do xorg.conf odbywa się tylko przez sterowniki (mam ATI i niezbyt się orientuję)? Próbowałeś edytować plik manualnie?

W podsekcjach Display sekcji Screen wystarczy dodać wpis Mode z odpowiednimi rozdzielczościami:

http://humanreadable.nfshost.com/sdeg/x ... _sizes.htm


(greh) #5

Ale ja mam na liście rozwijanej wszystkie rozdzielczości, jakie mój monitor obsługuje i nigdy nie musiałem nic dodawać, ani edytować. Dopiero teraz. Nawet na wersji beta tego systemu było ok.


(roobal) #6

Było dobrze, ale widocznie jest jakiś błąd albo w sterownikach, albo w systemie. Po to Ci ktoś daje rady, abyś ich spróbował, chociażby po to, żeby wiedzieć gdzie występuje problem.

Pokaż zawartość xorg.conf.

cat /etc/X11/xorg.conf

Pozdrawiam!


(greh) #7

Wedle prośby:

# nvidia-settings: X configuration file generated by nvidia-settings

# nvidia-settings: version 295.33 (buildd@allspice) Fri Mar 30 13:37:33 UTC 2012



Section "ServerLayout"

    Identifier "Layout0"

    Screen 0 "Screen0" 0 0

    InputDevice "Keyboard0" "CoreKeyboard"

    InputDevice "Mouse0" "CorePointer"

    Option "Xinerama" "0"

EndSection


Section "Files"

EndSection


Section "InputDevice"


    # generated from default

    Identifier "Mouse0"

    Driver "mouse"

    Option "Protocol" "auto"

    Option "Device" "/dev/psaux"

    Option "Emulate3Buttons" "no"

    Option "ZAxisMapping" "4 5"

EndSection


Section "InputDevice"


    # generated from default

    Identifier "Keyboard0"

    Driver "kbd"

EndSection


Section "Monitor"


    # HorizSync source: xconfig, VertRefresh source: xconfig

    Identifier "Monitor0"

    VendorName "Unknown"

    ModelName "CRT-1"

    HorizSync 28.0 - 55.0

    VertRefresh 43.0 - 72.0

    Option "DPMS"

EndSection


Section "Device"

    Identifier "Device0"

    Driver "nvidia"

    VendorName "NVIDIA Corporation"

    BoardName "GeForce 8500 GT"

EndSection


Section "Screen"

    Identifier "Screen0"

    Device "Device0"

    Monitor "Monitor0"

    DefaultDepth 24

    Option "TwinView" "0"

    Option "TwinViewXineramaInfoOrder" "CRT-1"

    Option "metamodes" "1152x864 +0+0"

    SubSection "Display"

        Depth 24

    EndSubSection

EndSection

Niby jest napisane, że 1152x864, ale widzę po obrazie, że takowa rozdzielczość nie jest ustawiona. Wszystko jest takie wielkie. :frowning: Dodam jedynie, że modyfikacja pliku xorg.conf, tak jak radzi to Frankfurterium całkowicie demoluje środowisko graficzne. Dobrze, że zrobiłem kopię.


(Frankfurterium) #8

W pliku /var/log/Xorg.0.log wyszukaj ciąg "Modelines:". Pod spodem też nie ma odpowiedniej rozdzielczości? W takim wypadku Xorg może nie dogadywać się z twoją kartą graficzną (nie odczytuje wszystkich zapisanych w biosie karty rozdzielczości).

Widzę też, że masz nierozpoznany monitor. Trochę to niebezpieczne, ale mógłbyś w xorg.conf wypełnić pola producenta, model i (zwłaszcza) częstotliwości odświeżania poprawnymi danymi (np z instrukcji). Da się wyczytać, że paru ludziom z twoją kartą coś takiego pomogło, ale powtarzam - lepsze żadne/defaultowe dane niż niewłaściwe.


(greh) #9

Dobrze, tylko powiedz, czemu na becie tego systemu z tymi samymi sterami działało jak należy a teraz nie.

Tak samo dobrze działało na Linux Mint 13.

Jak Ci podam model monitora, będziesz w stanie podać przybliżone dane, jakie tam wpisać?

Od razu mówię, że wpis CRT w xorg.conf jest raczej błędny bo mam monitor LCD.


#10

Fakt :stuck_out_tongue:

Zaktualizuj sterowniki imo:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates

sudo apt-get update

sudo apt-get upgrade

Następnie restart.


(greh) #11

Tak się składa, że mam już to repo w systemie, więc i ta Twoja wskazówka jakoś nie po drodze. Dodatkowo z błędem.

sudo apt-get add-repository ppa:ubuntu-x-swat/x-updates

sudo apt-get update

sudo apt-get upgrade

Nie wiem, po co get? :slight_smile:


#12

Meh, na szybko pisane.... Ale skoro masz już to repo, to czemu w xorg masz sterownik 295.33 zamiast 295.59?


(greh) #13

Może dlatego, że instalowałem przez aplet Dodatkowe Sterowniki?

Mimo wszystko, jak chciałem zainstalować przez terminal, to pisało, że jest już w najnowszej wersji.

-- Dodane 09.07.2012 (Pn) 16:45 --

Powiem szczerze, że chyba coś się udało. Miałem już to repo dodane, i aktualizację robię jedynie przez terminal.

Wpisuję jednak zawsze

sudo apt-get dist-upgrade

dziś wpisałem po Twoim poście Gutigen

sudo apt-get upgrade

i zaktualizowało stery z tego właśnie repo. Do wersji 302.17. Teraz mam już nawet po resecie lub ubiciu X'ów taką rozdzielczość, jak sobie życzę. :wink: A już szykowałem się do instalacji Linux Mint 13. :smiley:

Dziękuję Gutigen


#14

Dziwne, że zainstalowało Ci najnowsze stery, na stronie NVIDII jako ostatnia wersja sterów do 8500GT jest podana 295.59 :o

Grunt, że działa :slight_smile: