TeamSpeak 3 - nie chce działać


(Skredox147) #1

Siemka! Mam pewien problem z programem TeamSpeak 3 pod wersję Ubuntu 10.04 32 bit. Zainstalowałem program, wszystko ładnie pięknie pliki są i wgl., próbuję go odpalić przez plik "ts3_runscript.sh" i nic, to samo gdy stworzę aktywator tego pliku. Proszę o pomoc!


(roobal) #2

Nie wiem czy jesteś tą samą osobą, która pytała o to samo na innym forum, ale powtórzę pytanie, bo masz ten sam problem. Uruchamiasz z uprawnieniami do wykonywania? Jaką wersję pobrałeś?


(nintyfan) #3

Program na Linuksa musi mieć uprawnienia do uruchamiania, by odpalić. Prawoklik na ikonę programu, właściwości i tam znajdujesz uprawnienia czy prawa dostępu i  robisz tak, by program był wykonywalny.

 

Na 32-bitowym systemie nie będzie działać wersja 64-bitowa.


(Skredox147) #4

2u5coeh.png


(Zielpak) #5

a co wypluwa terminal jak odpalisz?


(roobal) #6

Jak nie jak tak. Znajomy miał VPSa z Debian 6 32-bit i przenosiłem TS3 na swój serwer z Debianem 7 64-bit i działał bez problemu. Instalowałem celowo wersję 64-bit TS3, ale licencja była na wersję 32-bitową....


(Skredox147) #7

Nic. Nie odpalam go przez terminal.


(Marcineez) #8

 

I w tym momencie człowiek posiadający choć odrobinę pomyślunku odpaliłby terminal i sprawdził. Jak widać ty jednak do takich nie należysz.


(Skredox147) #9

Wziąłem "uruchom w terminalu" - terminal się włącza pusty i w takim samym stanie się wyłącza..


(roobal) #10

Tak się nie robi jak chcesz uzyskać jakiś wynik. W taki sposób terminal zawsze się wyłączy, gdy aplikacja zakończy działanie. Uruchom terminal i uruchom plik ręcznie

 

/katalog/w/ktorym/jest/teamspeak/./ts3client_runscript.sh

Lub

cd /katalog/w/ktorym/jest/teamspeak/
./ts3client_runscript.sh

(Skredox147) #11

This application failed to start because it could not find or load the Qt platform plugin "xcb".

Reinstalling the application may fix this problem.

./ts3client_runscript.sh: line 17: 29444 Przerwane               ./ts3client_linux_x86 $@

Problem w tym, że próbowałem reinstalować, ale nic z tego.


(nintyfan) #12

XCB jest następcą XLib. Inne programy korzystające z QT możesz odpalić?


(Skredox147) #13

Nie rozumiem zbytnio co do mnie piszesz. Jestem zielony w ubuntu :s


(nintyfan) #14

Poprawiłem już post. Chodziło o inne programy korzystające z QT. To te programy dla środowiska graficznego KDE.


(roobal) #15

Uruchamiasz aplikację na systemie, który nie jest już wspierany (zakładam, że to nie Ubuntu Server) i jest już przestarzały, więc ma ona prawo nie działać.


(Skredox147) #16

Odpalam TeamSpeak 3 client. Czyli nie ma szans, żeby mi działało?


(roobal) #17

Szanse może i są, ale pewnie szybciej zaktualizujesz system. Jak strona System Requirements wróci do życia, to będziesz mógł sprawdzić minimalne wymagania dla aplikacji. Mimo wszystko ta wersja Ubuntu wspierana jest już tylko w wersji serwerowej (zresztą już wiele czasu do końca nie zostało), więc warto zaktualizować system.


(Skredox147) #18

Ojj chciałbym, ale ubuntu 11.04 na moim komputerze ma jakieś problemy. :confused:


(Kamatori) #19

10.04 i 11.04? Toż to zabytek, więc nie dziwne że ci TS3 nie chodzi. Przeinstaluj go całkowicie i wgraj Xubuntu 14.04/14.10 albo Ubuntu 14.04/14.10. Jak się boisz o ustawienia to po prostu zachowaj sobie partycję /home. 


(roobal) #20

Załóż temat to może uda się je rozwiązać. Możesz spróbować też Debiana Wheezy, TS3 zarówno klient, jak i serwer działa bez problemu. Sam korzystam z klienta na Wheezy, a na serwerze, którym się opiekuje działa serwer TS3.