Telnet nie łączy


(Mr Hektor) #1

Witam, szukałem już trochę na ten temat, telnet mam włączony/zainstalowany na obu komputerach, firewall wyłączony, nazwa użytkownika ta sama na obu komputerach, na jednym komputerze Windows XP na laptopie 7. Jak próbowałem na XP połączyć się z laptopem to doszło do tego pytania czy chce się połączyć (y/n), wybrałem y i jedynie wywala komunikat, że drugi komputer nie jest w jakiejś grupie itp itp.. Z kolei jak z laptopa jak chce się połączyć z XP to pisze, że nie może się połączyć na porcie 23.. Byłym wdzięczny za pomoc w tej sprawie.


(Drobok) #2

Masz tą samą grupę roboczą ? A co do 7 spróbuj na innym porcie :slight_smile:


(Mr Hektor) #3

Jasna sprawa. Pliki i foldery też się udostępniają bez problemów.

Próbowałem - nic. Z resztą to bez różnicy czy na 23 czy na innym bo na 23 nasłuchuje tak samo jak na innych:

51603377452246067421.jpg


(roobal) #4

Od którejś wersji service pack dla Windows XP, telnet jest domyślnie wyłączony lub blokowany, sprawdź czy telnet na obu systemach w ogóle działa.

Pozdrawiam!


(Mr Hektor) #5

Na obu uruchamiam cmd i na obu wpisuje telnet i na obu uruchamia się program telnet. Tyle, że nie łączy po wpisaniu adresu IP. Chyba trzeba do jakiejś grupy dodać te komputery, ale nie wiem jakiej.


(roobal) #6

Klient może i działa, ale chodziło mi to, czy działa na systemach serwer. Jeśli chcesz się podłączyć zdalnie do jakiegoś systemu przy wykorzystaniu protokołu telnet, to jesteś klientem, a na komputerze zdalnym powinien być uruchomiony serwer.

Pozdrawiam!


(Mr Hektor) #7

15758718171489649066.png

Na obu tak to wygląda, brakuje czegoś ? Być może muszę dodać komputery do jakiejś Telnetgroup ? Bo taki komunikat też mi wywala, czytałem na stronie Microsoftu, że użytkownicy muszą być w tej grupie, ale na Windows 7 Home Premium nie działa polecenie lusrmgr.msc do zarządzania grupami więc nie bardzo wiem co robić.

Edit

Upewniłem się. Serwer i klient jest zainstalowany na obu komputerach.


(Drobok) #8

Tak włączasz telnet ? hmm...

Panel sterowania\Wszystkie elementy Panelu sterowania\Programy i funkcje\włącz i wyłącz funkcje systemu windows. Zaznacz serwer telnet i klient telnet :slight_smile:


(Mr Hektor) #9

Ale ja już zrobiłem tak wcześniej ; ) Tzn na Windows 7, na XP jak chce tak zrobić to w ogóle nie mam na liście Telnetu, w usługach też nie.


(Drobok) #10

Czyli masz windows xp home, który nie obsługuje telnetu :slight_smile:


(Mr Hektor) #11

Obsługuje, bo dzisiaj jak wpisałem telnet w cmd to normalnie się odpalił (w XP oczywiście). Wpisałem:

open ip komputera

i za pierwszym razem wywaliło komunikat, że ten drugi komputer nie jest w TelnetClients, a za drugim razem już prosił o podanie loginu i hasła, tak jakby chciał się połączyć tyle, że jak wpisywałem to się nie zgadzało mimo, że na 100% wpisywałem dobrze.


(Drobok) #12

Może się źle wyraziłem, nie ma on serwera telnetu. (nie możesz się do niego połączyć). Ogólnie z telnetem wbudowanym w windows jest wiele problemów nie mających racjonalnego wyjaśnienia. Niektóre wersje działają, a niektóre nie. Mógłbyś użyć np putty.

Jedyne co przyszło mi na myśl to może w twoim haśle / loginie są jakieś polskie litery etc ?


(Mr Hektor) #13

Putty musi być zainstalowany na obu komputerach ?

Edit zainstalowałem Putty, łącze się przez Telnet, pyta mnie o login i hasło, wpisuje takie jak mam na drugim komputerze i mnie nie łączy. Przez SSH też mnie nie łączy eh -.-