Tiny mce - ustawianie edytora w okreslonych textarea


(Sobladen) #1

Witam

Jak ustawić w tiny mce żeby pokazywał sie edytor tylko w wybranych textarea np. określajac to w name="tutaj1"

Proszę o pomoc

Z góry dzięki


(Scofield111) #2

Tutaj masz odpowiedź.


(Sobladen) #3

Ustawiłem:

Ale nic to nie dało, dalej we wszystkich textarea jest edytor..;/ A chciałem żeby był tylko w tresc24


(Kontakt) #4

A ustawiłeś

id="tresc24" name="tresc24"

w textarea?


(Scofield111) #5

Albo druga możliwość, czy pozostałe textarea nie mają tego samego name="tresc24" :?:


(Sobladen) #6

Tak ustawiłem. I na 100% inne pola nie maja name="tresc24" tylko inne

I ten kod dałem w sekcji head

//edit

A jest możliwość ustawienia tego gdzies w plikach edytora? Bo ten edytor nie ściagałem ze strony autora tylko z innego skryptu i może tam było juz coś ustawione dlatego nie działa.


(Scofield111) #7

Spróbuj załadować wszystko od początku skrótem: Ctrl+F5 (Nie wszystkie przeglądarki tak mają obstawiam, że używasz Firefoxa :-D). A tak poza tym to wkleiłeś w tylko tyle co podałeś wyżej?


(Sobladen) #8

w head wkleiłem to i linka do skryptu

p.s uzywam Firefoxa i Chrome

p.s2 A jest możliwość ustawienia tego gdzies w plikach edytora? Bo ten edytor nie ściagałem ze strony autora tylko z innego skryptu i może tam było juz coś ustawione dlatego nie działa.


(Scofield111) #9

Spróbuj dodać jeszcze: theme : "advanced" czyli :

Nie mam pojęcia, ale raczej nie ponieważ konfiguracja jest tylko w tym pliku, w którym inicjujesz edytor. TinyMCE.


(Sobladen) #10

po dodaniu: theme : "advanced

Tam gdzie jest tresc24 widać teraz ten styl, a w innych jest standardowy


(Scofield111) #11

Standardowy? Jeśli możesz to wklej zawartość tego pliku, w którym chcesz włączyć edytor TinyMCE.


(Sobladen) #12

"Standardowy".Chodziło mi o ten skin gdy nic nie ustawiałem on właśnie był.

Link do edytora (w head)

Plik, którym chcę ustawić gdzie ma byc wyswietlany edytor (też incloduje go w head):

tinyMCE.init({


		// General options


		mode : "exact",


		elements : "tresc24",


		theme : "advanced",

		language : "pl",


		plugins : "safari,pagebreak,style,layer,table,save,advhr,advimage,advlink,emotions,iespell,insertdatetime,preview,media,searchreplace,print,contextmenu,paste,directionality,fullscreen,noneditable,visualchars,nonbreaking,xhtmlxtras,template,inlinepopups",




		// Theme options


		theme_advanced_buttons1 : "bold,italic,underline,strikethrough,|,justifyleft,justifycenter,justifyright,justifyfull,formatselect,fontselect,fontsizeselect",


		theme_advanced_buttons2 : "cut,copy,paste,|,search,replace,|,bullist,numlist,|,outdent,indent,blockquote,|,undo,redo,|,link,anchor,image,cleanup,help,|,insertdate,inserttime,|,forecolor,backcolor",


		theme_advanced_buttons3 : "tablecontrols,|,hr,removeformat,visualaid,|,sub,sup,|,charmap,emotions,iespell,media,advhr,|,fullscreen",


		theme_advanced_buttons4 : "insertlayer,moveforward,movebackward,absolute,|,styleprops,|,cite,abbr,acronym,del,ins,attribs,|,visualchars,nonbreaking,template,pagebreak,preview",


		theme_advanced_toolbar_location : "top",


		theme_advanced_toolbar_align : "left",


		theme_advanced_statusbar_location : "bottom",


		theme_advanced_resizing : true,




		// Example content CSS (should be your site CSS)


		content_css : "css/content.css",




		// Drop lists for link/image/media/template dialogs


		template_external_list_url : "lists/template_list.js",


		external_link_list_url : "lists/link_list.js",


		external_image_list_url : "lists/image_list.js",


		media_external_list_url : "lists/media_list.js",




		// Replace values for the template plugin


		template_replace_values : {


			username : "Some User",


			staffid : "991234"


		}


	});

Tutaj chcę wyświetlić edytor:

| Treść: |
| |
| |

[/code] Link do edytora (wrzuciłem go na sendspace):
[code]http://www.sendspace.pl/file/2fcc3b778f4e1607b70342c

Proszę o pomoc. zrobiłem chyba wszystko dobrze a edytor wyświetla się we wszystkich textarea na stronie


(Scofield111) #13

Uruchomiłem u siebie ten edytor i wszystko działa jak należy. Zrobiłem plik config.js ,który zawiera tą konfigurację edytora co podałeś wyżej, plik umieściłem w katalogu js. Dalej w pliku index.html w

dodałem dwie linijki:

Pierwsza linijka includuje kod edytora, a druga konfigurację. W miejscu gdzie ma wyświetlić edytor wkleiłem twój kod i skopiowałem go jako drugie pole textarea tylko zmieniłem wartości: id, name

| Treść2: |
| |
| |

[/code] Efekt jest taki. Sprawdź w całym czy w tym pliku, w którym chcesz użyć edytora nie masz dodatkowego/zbędnego kodu js, który również konfiguruje tinymce, np coś w tym stylu:
[code]


(Sobladen) #14

Bardzo dziękuje za pomoc i wytrwanie do końca.

Bardzo mnie to dziwiło dlatego zrobiłem też to samo co Ty czyli utworzyłem osobny plik i sprawdziłem to i wszystko było ok.

Wiec szukałem w kodzie strony wszystkie includowane pliki i ten fragment który podałeś (bo ja nie pisałem tej strony) i znalazłem to i usunałem..

Teraz jest już wszystko ok.

Pozdrawiam


(Lepiejniewiedziec) #15

Witam,

jestem nowym użytkownikiem Chrome i napotkałem taki problem. Na jednej ze stron, gdzie jestem adminem nie działa mi edytor tekstowy. W Mozilli i IE jest ok, w Chrome nie.

Załączam screeny.

Czy ktoś zna sposób, jak to naprawić?

CHROME

bezedytora.jpg

MOZILLA

zedytorem.jpg

Pozdrawiam


(Scofield111) #16

Chrome chyba czasami tak ma. Wszystko powinno działać po odświeżeniu strony - F5.