Tomb Raider 2013 ze Steam nie uruchamia się, choć wcześniej był ok


(ra-v) #1

To co widać po uruchomieniu Tomb Raidera
http://wklej.to/ubJkN
Latalog ~/.local/share/feral-interactive/Tomb Raider/crashes jest pusty.

Kupiłem gdzieś w listopadzie poprzedniego roku, bo była mała przecena. Przetestowałem i wszystko działało. Chciałem zagrać teraz po czasie, ale przy uruchamianiu nic się nie dzieje.
Oczywiście wg “oficjalnego” poradnika Steam nie można zaczerpnąć pomocy Valve, można zażądać zwrotu, ale z góry ostrzegają, że raczej zwracają zakupy z ostatnich 2 tygodni (próbowałem, oczywiście prośbę odrzucili).

Grafika to GTX 780, sterowniki 375.39 (z lutego z oficjalnego repo dla openSUSE).


(nintyfan) #2

Mam to samo, również na OpenSuSE, jednak z Hero Academy. Problem zaczął się po instalacji Civilization V,.


(Domker) #3

Może problem z zależnościami jakiś po aktualizacji systemu lub steama.
W logu widać, że czepia się trochę bibliotek *.so


(MartinaNeumayer) #4

@ra-v Parówa na openSuse ma swoje własne cudaczne libs’y :wink:
Spróbuj zmienić nazwę dla libcrypto.so.1.0.0 i zobacz po reboocie co będzie.
Spróbuj także ze zmianą dla libcurl.so.4 i też reboot.
Obie powinny siedzieć gdzieś w /.local/share/Steam/

Edit:
Znalazłam właśnie coś takiego… To chyba ten sam problem co u Ciebie.
https://steamcommunity.com/app/203160/discussions/0/343787920132866394/


(nintyfan) #5

Co dziwne - u mnie dzisiaj wszystko zaczęło działać. Oczywiście po aktualizacji Steam-a. Może spróbuj włączyć Steam.


(ra-v) #6

ROZWIĄZANY.

To co pisała @MartinaNeumayer pomogło (akurat prędzej znalazłem rozwiązanie na Google+).Okazało się, że GRID Autosport też się wywalił.

Dla leniwych:

$ mv ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libcrypto.so.1.0.0 ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libcrypto.so.1.0.0_bak
$ mv ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libcrypto.so.1.0.0_bak

Czy ja przypadkiem nie “naprawiałem” BTRFSa w międzyczasie na / (czyli zmieniałem to nieudane cudo na EXT4) i nie instalowałem 42.2 zamiatst 42.1 i czy to mogło spowodować ten problem, tego już się nie dowiem.


(MartinaNeumayer) #7

Miło, że już działa :slight_smile: Widziałam, że nie tylko gry się ludziom “biesiły”, ale i sporo programów ma problemy.
U mnie właśnie tak wykopało się Deluge. Chyba jest coś nie halo ogólnie z libcrypto.so